Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
How to contact Customer Service Read more... ×

Using Reverb G2, constant dropped frames :(

Recommended Posts

I am getting an incredible number of dropped frames as shown in fpsVR. I can easily be on over 100 dropped frames in a minute or so.

This is even when running at a very low SS of 30% for example, and framerate stays at 90fps, GPU and CPU usage very low (3090 & 10900k). So to be clear, this isn't low framerate or reprojection etc, it is literally only "dropped frames".

Other sims run great, just something is causing an issue with DR2. I didn't have this problem with my Vive Pro.

Thanks.

Share this post


Link to post
Share on other sites

Just tried with my Quest 2 and no dropped frames, so seems specific to WMR/G2 for me. Is it just me?

Share this post


Link to post
Share on other sites

Hey there.

Just to confirm, have you tried everything here?

 

 

Share this post


Link to post
Share on other sites

Hi, I have yes, I have used DR2 great with Vive Pro and Quest 2, this issue is only with G2, or specifically WMR most likely. Issue is still there if I lower SteamVR supersampling to just 30% for example, lower than either of those headsets. 

Share this post


Link to post
Share on other sites
23 hours ago, RagingBeard said:

this issue is only with G2, or specifically WMR most likely

The G2 has a larger per-eye resolution than many headsets so there may be something to this.

It could also like you said be something specific to WMR, but I haven't seen enough comments from others to prove either of these things 🤔

If I find out any info I'll let you know; I'm asking around.

Share this post


Link to post
Share on other sites

I can use the Quest 2 on high super sampling and get a smooth experience, while the G2 even at very low super sampling (so a MUCH lower resolution), I still have this problem.

Share this post


Link to post
Share on other sites

Seems specific to the G2 or WMR then.

I've asked about it but got no potential workarounds yet to suggest.

Share this post


Link to post
Share on other sites

Same here frames are dropped no matter what headset and game settings I am using, 

HP Reverb G2 + 10900k + RTX 3090 

Did anyone found solution on this ? 

Share this post


Link to post
Share on other sites

I'm running 3090, but appears specific to G2/WMR for me. I don't have the frame drop issue using Quest 2, and didn't have it in past with 2080ti and Vive Pro.

Share this post


Link to post
Share on other sites

Hi, 

I tried practically everything:

- changed refresh rate of G2 into 60 Hertz  

- tested practically all settings on G2 WMR settings and Steam VR settings

60 hertz brought a little better performance but stuttering still exist. 

I have noticed that on FPSVR software I have constant drops on FPS (below 60 FPS) but on the graph there are no dropped frames observed + my GPU is only running on 40% of available power,

It really looks like a poor support for WMR headsets or Steam VR. 

It is really frustrating to not be able to play on my new G2. 

Not sure what I can improve in terms of hardware (i9-10900K / 64 GB RAM / RTX 3090/ Fast SSD) 

Best Regards

Greg

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Turn off screen space reflections, set vehicle details to low, set crowds to low, turn off any multisampling, get rid of any supersampling (SteamVR will super sample automatically based on your PC's hardware, so you need to manually set Dirt Rally 2 to run at the correct per eye resolution).

These are the settings I found to cause the most issues in VR with Dirt Rally 2.0. Crowds are known to cause stuttering issues in Dirt games, setting them to "low" or turning them off stops this.

Screen space reflections will take a big chunk of the FPS

For some reason when vehicle details are set above "low" in VR, the cars light will cause the frame rate to stutter and drop; especially in area's with lots of trees. I found it to be the worst on Scotland, but can happen at any location.

On top of these things, you can also turn off the advanced lighting and camera effects that are all locatated at the bottom of the graphical options. These items can eat into the FPS also.

Share this post


Link to post
Share on other sites

Thanks but this isn't a performance issue. I can set things very low and still have dropped frames, whereas with the Vive Pro or Quest 2, both running at a higher resolution than the G2, the issue is not there.

Share this post


Link to post
Share on other sites

Yes - that is true, it is not performance issue - I am getting the same results on high and very low

Share this post


Link to post
Share on other sites

Hi,

I remember that I had to force disable DX12 in WMR for SteamVR because it is causing a regular stutter (about once per second for about a tenth of a second).

In case you haven't tried it might be worth a shot. It should be somewhere in the UI but in case you can't find it there you can also edit "YourSteamlocation"\steamapps\common\MixedRealityVRDriver\resources\settings\default.vrsettings

Share this post


Link to post
Share on other sites

Hi,

 

Similar issue here.  Intel i9-9900KS, NVidia MSI Suprim X 3090, MSI MEG Z390 ACE mobo, 32GB DDR-4000 C19 memory, 2TB EVO Plus NVMe SSD.  Using a relatively fresh install (2 days old) of Windows 10 Pro.  Previously used an HTC Vive (original) and had everything on Ultra, with no issues.

 

fpsVR Report:
App: DiRT Rally 2.0 HMD: HP Reverb Virtual Reality Headset G20 (90.001 Hz, IPD 61.7)
GPU: NVIDIA GeForce RTX 3090 (27.21.14.6140) CPU: Intel(R) Core(TM) i9-9900KS CPU @ 5.1GHz
Delivered fps: 89.15  Duration: 38.9min. Headset was active: 33%
GPU Frametimes:
Median: 5.4 ms
99th percentile: 6.6 ms
99.9th percentile: 7.1 ms
frametime <11.1ms(vsync): 100%
CPU frametime:
Median: 3.7 ms
99th percentile: 5.2 ms
99.9th percentile: 7.4 ms
frametime <11.1ms(vsync): 99.9%
Reprojection Ratio: 0.8% (for Index/Vive/VivePro headsets only)
Dropped frames: 691 or 0.3% (for Index/Vive/VivePro headsets only)
Max. SteamVR SS: 100%
Render resolution per eye: 3160x3088(by SteamVR settings, Max.) (HMD driver recommended: 3159x3089)

 

The Dirt2 Rally Steam VR graphics settings are at their lowest.  CPU usage averages 10% with a short peak of 45%.  GPU usage sits at about 62% with a short peak of about 76%.  It's all well within limits, I'm getting very nearly perfect 90fps indicated yet I regularly get stutters in game.  In game, fpsVR manifests these stutters as purple 'spikes' in its GPU frametime graph, and I see a stutter.  It happens regularly and is easily repeatable.  But the game sees 89.15 fps average with the longest frametimes at 7.1 and 7.4ms, which should be a complete non-issue and not noticeable, but fpsVR records 691 dropped frames after 40mins play.  In game though, it's like someone pressing pause for a tenth of a second, really throws off the immersion and is enough to cause accidents!

I'm using nVidia drivers 461.40 which to my understanding should have incorporated the VR stuttering hotfix driver 461.33.  Suggestions elsewhere have said this might be an issue with reprojection settings, but I'll try the DX12 fix mentioned above.  

Any suggestions welcome.

 

Frametimes # DiRT Rally 2.0 # HP Reverb Virtual Reality Headset G20 # 11_02_2021 09_27_46.png

GPU&CPU # DiRT Rally 2.0 # HP Reverb Virtual Reality Headset G20 # 11_02_2021 09_27_46.png

Edited by Jaggers271
Adding fpsVR screenshots.

Share this post


Link to post
Share on other sites

Having the same issue here. 

Running an MSI 3090 Suprim X and 9700k. Everything was running smooth as glass on my Rift S in Oculus mode. As soon as I upgraded to the Reverb G2 I see intense stutters no matter the video settings. Plenty of headroom available. FPSvr and the SteamVR GPU monitor show many purple spikes corresponding with the stutters. Sometimes it will be smooth for about 10-20 seconds at the start of a race, but inevitably the stutters begin and make the game absolutely unplayable. Such a shame as this was one of my top 3 sims before.

 

I've tried all the fixes linked here and so many more. Reinstalled windows even. Tried multiple nvidia drivers. It has to be something not paying nice with steamvr or WMR. OpenComposite doesn't seem to work whether I try individual or global installation - it makes the game launch in 2D mode every time.

 

I remember hearing that CodeMasters stopped supporting the game so we may be out of luck and have to move on...

Share this post


Link to post
Share on other sites

Just to add my findings, having tried hours of suggested solutions - I found that biggest improvement was when using the nVidia Studio Driver (461.40).  I think the issue is possibly driver related, but I've spent too much time already on this and, as has been mentioned, I think it might be time to move along to another sim as Codemasters are no longer working on it.  It's real shame, DR2 was by far my favourite driving game.  Onto PC2 or AAC perhaps.  

Share this post


Link to post
Share on other sites

To add to the mix, it seems that WMR developers may have identified a performance bottleneck between SteamVR and WMR.  See the link below.

https://www.reddit.com/r/WindowsMR/comments/lmyusg/windows_mixed_reality_for_steamvr_updated_12536/gny2b6p?utm_source=share&amp;utm_medium=web2x&amp;context=3

Hopefully, things might improve when this issue gets sorted out.  Steam and Microsoft seem to be working on it.

Share this post


Link to post
Share on other sites

Yeah be great if that is the issue. I have tried all the recommended steps but no improvement in DR2. 

I'm resorting to downloading DR1 again and hope that runs fine to at least be able to get some rally in. 

Share this post


Link to post
Share on other sites

Unfortunate seeing this. I am running my old Asus WMR with my 3090 (Reverb G2 should be here end of week) and seeing similar problems. 3090 has no problem running my low resolution headset, im only at about 75% usage at high settings but I get those frame drops. I hope it's  steam->wmr problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×