Jump to content Jump to content

Bad Sound Stuttering - tried usual fixes


Recommended Posts

Hi folks,

First post on here, so go easy on me!

Anyway, just got Grid 2019 PC and really enjoying it apart from one problem. I'm getting really bad sound stutters and cutting out during races. The only way I've found to reduce it is to enable Dolby Atmos. Not a very satisfactory solution. Only happening in this game, everything else runs smoothly on my system. Including F1 2019.

Having done some searching online, I find others are having similar issues. I've tried all the suggested solutions, such as changing the sound bit rates etc, but nothing seems to make much difference.

Has anyone found a reliable solution to this?

Thanks for any help, this is bugging me! 😕

Cheers, Frank

 

AMD 3600 on AsRock B450

16GB RAM

RTX 2070 Super

 

 

Link to post
Share on other sites

Well, this is weird.

I don't know what I did, but the problem seems to have gone away! I've changed a few things, such as run with vsync on, max fps off, put PC in Ultra Performance mode (which I didn't know existed!) and the sound stuttering has completely gone away! Even with Dolby Atmos off. However, when I put the settings back to where they were, it still seems to be fine. God knows why, I've not changed any drivers or anything like that, very weird.

Anyway, I'm happy now. Seems to be fine for now.

Cheers 👍

Edited by Frankgw
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...