Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

LAN-game bugged race results

Recommended Posts

  • A detailed description of the issue. Please include any error codes here. 

After a LAN-game with my son, I faced a strange (big) bug about the race results!
It was a 25% race in Austria with 2 human players connected in lan and all the available opponents AI in track too.

We both ended the race with fatal damage: I was on lap 6 or 7 if I well remember, one AI car was retiring, I was very close to another AI car and when it has (heavily) slowed down I couldn't avoid it.
The Safety Car went out, my son still on track, only 5 cars pitted, included my son who was at the bottom as the 2nd car with 1 stop already. I don't remeber all the others but Perez was the one who was ahead of him with pit stop done (this may be important to understand something about, please continue to read). After the race restart in lap 10 or the like, my son had a big accident too, fatal damage and game over.

The podium footage started and I commented about Perez winner with Stroll and Gasly on the podium, while my son told me Hamilton did! :classic_blink:

So that I took the pictures of the race results, this is mine (I was the host) with Perez winner which may have a sense because he was the 1st of pitted cars during lap 8-9:

Img_3888.thumb.jpg.c0d8474219c63d63ef603dce1c18bc90.jpg

This is what my son can see in his PS4, Hamilton winner:
Img_3889.thumb.jpg.ec024bbf45ae0bbe9f484ee7db8e334f.jpg

As you can see the fastest times are exactly the same (e.g. Hamilton 1:09,225 Galsy 1:10,471 etc.) but the ranking is completely messed up!

You can notice also that not only the two final results are different, but they are also both individually wrong!
In the host picture you can see Hamilton in P10 with +3,398 s. which should rather put him in P2 (same for P11-P14).
In the guest picture you can see P11 Stroll (+13,255) and P12 Gasly (+17,186) which should rather be respectively in P10 and P11 ahead of Kvyat.

Besides the final race times are very different and no one matches (22:23,345 vs 22:26,743).

 

  • Platform

2x PS4

  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

2x 1.14

  • Game-mode?

LAN game

  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?

We played 3 races in the same track and same settings, the wrong one was the 2nd, the only one in which we both ended with fatal damage and a SC went on track like described.

  • How do you make the problem happen?

Got one time, perhaps the previous description may help to reproduce the bug. 

  • What troubleshooting have you attempted? Please always try to attempt to fix the issue 

None

  • What peripherals are you are using (gamepad, wheel make & model etc) 

2x Logitech G29

  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

 

Thank you and regards :classic_smile:
Nuv

Edited by Nuvolarix
  • Like 2

Share this post


Link to post
Share on other sites

Hi, I got it once again, having both the players retired from the race. @BarryBLit looks this is the key to reproduce the bug, I did it with the following steps:

1) run a LAN game with 2 human players (and all the others AI);
2) start the race;
3) immediately retire one car, in my case it was the guest car (I went against the wall and a SC came out, not sure if it's necessary);
4) retire also the second car. Before I completed one lap with the host car (probably not necessary), to be more precise I let the AI drive my car after clicking "options" button in my PS4 controller.

These are the race results for the two players:

host

IMG_3946.thumb.JPG.617b52a808ed41106898ebad53c243b0.JPG


guest

IMG_3947.thumb.JPG.4f2d54afcafd301f28120c32316a9cd3.JPG

I reproduced the bug with 2 controllers and 2x patch 1.15.

For a full description everything I wrote in the main post is still valid. I can add that probably there's also something weird about pit stops because (I notice it now) some drivers ended the race with 0 pit stops, while we are in a 25% race in both cases. Unlike the first post, now the race times at least look "the same" among the two players, just in wrong position.

Available for any further clarifications or tests.

Thank you and regards,
Nuv
 

Edited by Nuvolarix
  • Like 2

Share this post


Link to post
Share on other sites
16 minutes ago, steviejay69 said:

@Nuvolarix really excellent bug reporting. Gold standard.

Agreed. Makes my transition to a Internal bug report effortless as I can pass this straight to devs with everything covered. Lovely stuff

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites
39 minutes ago, steviejay69 said:

@Nuvolarix really excellent bug reporting. Gold standard.

 

21 minutes ago, BarryBL said:

Agreed. Makes my transition to a Internal bug report effortless as I can pass this straight to devs with everything covered. Lovely stuff

Thank you to both @BarryBL @steviejay69, professional deformation :classic_rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×