Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
Sign in to follow this  

F1 2020 lagging and frame rate drop issues.

Recommended Posts

F1 2020 on my Pc is lagging like crazy on full screen but on Windowed Mode the game works nicely.

Share this post


Link to post
Share on other sites

Hi,
 
Thanks for adding your issue. However, we require all bug reports to follow the templates below. This is critical information Codemasters needs to be able to see your bug clearly. Link:

 
 

  • Agree 1

Share this post


Link to post
Share on other sites
On 1/9/2021 at 2:04 AM, Simbatron99 said:

F1 2020 on my Pc is lagging like crazy on full screen but on Windowed Mode the game works nicely.

It's your issue.

Share this post


Link to post
Share on other sites

 

1. The whole game in general lags like crazy and when I  go to do the benchmark tests with fps counter on the frame rates would be consistent for a few seconds and then the frame rates would drop for an example it would be 120 and then it would drop to 30.
2. PC/Steam- I5 9400F processor and RTX 2060 graphics card
3. version 1.14
4. I can make the problem happen again by selecting the full screen mode option.
5. I put the graphical settings to ultra Low, I also turned V sync on, an I put the Anti aliasing Off as well. None of them worked.
6. Wheel: Thrustmaster T150 Pro
7.(56) F1 2020 lagging and frame rate Issues PC - YouTube Sorry for the rubbish quality.

Share this post


Link to post
Share on other sites
16 minutes ago, Simbatron99 said:

Direct x12

Not what we are looking for @Simbatron99

Is this the same issue as your previous post? This may be helpful: 

 

Share this post


Link to post
Share on other sites
2 minutes ago, BarryBL said:

Not what we are looking for @Simbatron99

Is this the same issue as your previous post? This may be helpful: 

 

Yeh it's the same and I will have a look now.

Share this post


Link to post
Share on other sites
51 minutes ago, Simbatron99 said:

Yeh it's the same and I will have a look now.

None of it solved the problem

Share this post


Link to post
Share on other sites

Can you please post a DXdiag as well @Simbatron99. How to do so was in the troubleshooting guide previously mentioned. This is vital so we can see your setup. Do other games work fine? Does this only happen in full screen mode?

Share this post


Link to post
Share on other sites
22 minutes ago, BarryBL said:

Can you please post a DXdiag as well @Simbatron99. How to do so was in the troubleshooting guide previously mentioned. This is vital so we can see your setup. Do other games work fine? Does this only happen in full screen mode?

Yes other games such as Nascar Heat 5 , Assetto Corsa and Race Room Experience all work perfectly in full screen mode and yes it only happens in Full screen mode on F1 2020.

DxDiag.txt

Edited by Simbatron99

Share this post


Link to post
Share on other sites

I suspect that this is either a monitor issue or a aspect ratio issue.

From your setup, try turning Dynamic Resolution off and lower your frame rate targets. Also, is 2560 x 1377 Custom correct for your monitor? Try going to more generic settings and see if that works. I suspect it is the dynamic resolution target being 144 FPS.

Share this post


Link to post
Share on other sites
41 minutes ago, BarryBL said:

I suspect that this is either a monitor issue or a aspect ratio issue.

From your setup, try turning Dynamic Resolution off and lower your frame rate targets. Also, is 2560 x 1377 Custom correct for your monitor? Try going to more generic settings and see if that works. I suspect it is the dynamic resolution target being 144 FPS.

I just got this monitor brand new and I still had the same problem with the other monitor.

I have tried every aspect ratio especially the lowest and I also turned off the dynamic resolution and lowered my fps target to 60 and 120 but still kept lagging, I also put it to 1080p and 1440p but it keeps going to 2560 x 1377 for some reason. and I've tried generic and high but I still get the same results 

The funny thing is Full screen mode was working when I first played the game.

 

 

 

Share this post


Link to post
Share on other sites

Can you confirm you have verified the integrity of your Steam files? Can you also consider a uninstall and fresh install, however, I think there is a graphics/screen issue here.

Share this post


Link to post
Share on other sites
7 minutes ago, BarryBL said:

Can you confirm you have verified the integrity of your Steam files? Can you also consider a uninstall and fresh install, however, I think there is a graphics/screen issue here.

Yes I can confirm, I’ve done it twice and I think it has been like this since the recent 1.14 update. can I try delete my data instead because I’ve already tried unistalling and fresh installing

Share this post


Link to post
Share on other sites

Yes. Ensure you create a backup of any save games you value. Also, ensure Asynchronous Compute is turned off and turn your refresh rate to 59hz. Here's my in-game settings that might be worth copying to see if that helps (where your system will allow you)

Oh, and when you change from windowed to full screen, re-boot the game before you go on track. Just to be double sure it confirms the settings.

20210105162714_1.jpg

Share this post


Link to post
Share on other sites

I copied everything, I even tested every Anti-Aliasing setting and made sure that I restarted the game each time. And deleting the data didn't work either.

What about your control panel settings?

2 hours ago, BarryBL said:

Yes. Ensure you create a backup of any save games you value. Also, ensure Asynchronous Compute is turned off and turn your refresh rate to 59hz. Here's my in-game settings that might be worth copying to see if that helps (where your system will allow you)

Oh, and when you change from windowed to full screen, re-boot the game before you go on track. Just to be double sure it confirms the settings.

20210105162714_1.jpg

 

Share this post


Link to post
Share on other sites

Does the game work fine with the windowed mode stretched to emulate a full screen at all? To me, it seems like a system/monitor issue here rather than a game one

Share this post


Link to post
Share on other sites
2 hours ago, BarryBL said:

Does the game work fine with the windowed mode stretched to emulate a full screen at all? To me, it seems like a system/monitor issue here rather than a game one

It was deffo a system/monitor issue because I got it working now, I had to match the refresh rate in the settings of the computer itself with the game but I can only get 60 FPS Max atm. Thank you for taking the time to help me.

  • Like 1

Share this post


Link to post
Share on other sites

Always play at a monitor's default resolution and refresh first.

Then set the desktop refresh at the same frequency as the monitor's highest refresh (unless you can't run at that FPS and need to run lower). Alter the game setting to match (you might not get matching settings in-game, so compromise is needed).

Cap framerates if you are exceeding the maximum (or use V-Sync).

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×