Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×

Voice commands not working on PS4 with Turtlebeach Stealth 600 Gen 2

Recommended Posts

  • A detailed description of the issue. Please include any error codes here: Cannot seem to get the mic on Turtlebeach Stealth 600 Gen 2 working with voice commands on F1 2020 for PS4. Device is connected to PS4 correctly, and is powered up. I can change audio and mic settings in the PS4 setup area. Mic audio is recognised in the PS4 audio menu and I can control the PS4 using voice commands through the headset. Game audio is coming through in the headset perfectly fine. Headset is connected before starting the game. UPDATE: Issue is also present when using the PS4 supplied earphone/mic when connected to controller.
  • Platform: PS4
  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen): 1.15
  • Game-mode? All
  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again? Yes
  • How do you make the problem happen? Start the console. Connect the headset (ensuring mic is active - “flipped down” position). Start F1 2020 and go into any game mode e.g. time trial, Grand Prix, driver career etc. On track the voice command icon is not displayed (see screenshot).
  • What troubleshooting have you attempted? Please always try to attempt to fix the issue: Disconnected and reconnected device to PS4. Turned console off and on. Checked audio and mic settings in the PS4 settings menu. UPDATE: Am deleting and re-installing the game - will let update this post if successful/ unsuccessful. UPDATE 19/01/20: Fresh install of game did not activate mic. This is on both Turtlebeach headset and supplied earphone with PS connected to controller. Mic registers in audio setup area of PS4.
  • What peripherals are you are using (gamepad, wheel make & model etc): Turtlebeach Stealth 600 Gen 2
  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears: see screenshot attached. This is from time trial mode. The voice icon is not displayed.

543A9A6A-73A7-49B5-ABC5-7DA9F40AA208.jpeg

Edited by Monzie83

Share this post


Link to post
Share on other sites
14 minutes ago, Monzie83 said:

Thanks @steviejay69, have tried this but no luck.

Was always worth a shot. The issue is usually the bluetooth connection to the console, quite a lot of headsets seem to be affected.

Share this post


Link to post
Share on other sites
17 minutes ago, steviejay69 said:

Was always worth a shot. The issue is usually the bluetooth connection to the console, quite a lot of headsets seem to be affected.

Absolutely. First port of call is always making sure everything is updated.

It’s interesting because the PS4 recognises the mic, audio plays through the headset etc. Can even control the PS through the mic.

Mic just doesn’t work in the game. Don’t get a “voice commands not activated” on the title screen either. Deleted and re-installed the game as well but no difference.

Edited by Monzie83
  • Thanks 1

Share this post


Link to post
Share on other sites

@steviejay69, any thoughts?
 

Nearly a breakthrough... nearly.

Was doing a practice session for a race in My Career. Jeff randomly comes on ‘if you need anything you can say it over the radio’ or something like that. Amazingly, the mic begins to work. 

I carry on my merry way, and I can request information during the race.

Finished up. Restarted the game. No dice. 

Will see if it happens again, next time when I’m in the garage... if Jeff is generous enough 😂

Edited by Monzie83

Share this post


Link to post
Share on other sites
1 hour ago, Monzie83 said:

@steviejay69, any thoughts?
 

Nearly a breakthrough... nearly.

Was doing a practice session for a race in My Career. Jeff randomly comes on ‘if you need anything you can say it over the radio’ or something like that. Amazingly, the mic begins to work. 

I carry on my merry way, and I can request information during the race.

Finished up. Restarted the game. No dice. 

Will see if it happens again, next time when I’m in the garage... if Jeff is generous enough 😂

You've not uttered the "Shut Up, Jeff" command ever or switched the engineer verbosity to different levels in the in-game menus?

When it worked, did you have game audio via the headset or did you have game audio via the HDMI and engineer audio via the headset. Were you using PSN Party Chat?

  • Thanks 1

Share this post


Link to post
Share on other sites

I just did a clean install, yesterday, and I had just done a clean Windows 10 installation, and had updated EVERYTHING, and all drivers installed and UPDATED... And my microphone is USB... AND WORKING...  Why do artificial techies ALWAYS assume THEY are the only ones who know anything, when they clearly know nothing, except how to read the troubleshooting guide in the user manual ??? Is it any coincidence that they JUST dropped Ver 1.15, which supposedly fixed the Benjamin Park Ferme problem, which I never experienced, even though I've changed setup MANY times... DURING QUALIFYING... ???

The attached screenshot shows, in the bottom left, that voice commands aren't working, this is immediately after launching the game, and then "Press Any Button", and it's transitioning to the Main Menu (screen)

 

No Voice.jpg

Edited by DiverSteve
Added ScreenShot

Share this post


Link to post
Share on other sites
1 hour ago, steviejay69 said:

You've not uttered the "Shut Up, Jeff" command ever or switched the engineer verbosity to different levels in the in-game menus?

When it worked, did you have game audio via the headset or did you have game audio via the HDMI and engineer audio via the headset. Were you using PSN Party Chat?

@steviejay69 you might be on to something here...

I’ve not uttered “shut up Jeff”, but I did have engineer verbosity turned to reduced frequency. Changing it to “everything” did activate the mic for the remainder of a race that I was in (race was restarted from a mid-session save and I changed the engineer verbosity setting while in the flashback area when you load a mid-session save). It did not turn off after that - was able to go into time trial and it worked also.

However, after shutting down and restarting the game (without shutting down PS4 or disconnecting the headset - and with verbosity kept on “everything” setting), it didn’t re-active. Toggled the engineer verbosity up and down a few times in time trial mode but still nothing.

Game audio comes through the headset perfectly - that has never been an issue. And the mic seems to work OK everywhere else, just F1 2020 has the issue that I’ve noticed. Never used game audio via HDMI and engineer audio through headphones /controller - everything is set to headphones. Never used PSN party chat either.

Have shut it all down now, but will see if toggling the engineer verbosity does anything, after it’s had some rest lol. Will also try to see if I can recreate the latest time it worked when I next do a race.

There is some hope given the mic has worked (albeit sporadically). Does seem like some kind of bug in the game, however deleting and re-installing had no effect either.

 

Edited by Monzie83
  • Agree 1

Share this post


Link to post
Share on other sites

@steviejay69, OK so went into Driver Career mode and into the practice sessions for my race, and sitting there for a few minutes, Jeff comes on the radio again and lets me know I can use voice commands. 

Seems like if Jeff doesn’t want it to happen, it won’t 😂.

Luckily it looks like if I enter Grand-Prix mode, it activates, and consistently so. Time trial mode it doesn’t.

Good to have a workaround, although it’s definitely a bug.

Edited by Monzie83
  • Agree 1

Share this post


Link to post
Share on other sites
On 1/18/2021 at 5:33 PM, Monzie83 said:
  • A detailed description of the issue. Please include any error codes here: Cannot seem to get the mic on Turtlebeach Stealth 600 Gen 2 working with voice commands on F1 2020 for PS4. Device is connected to PS4 correctly, and is powered up. I can change audio and mic settings in the PS4 setup area. Mic audio is recognised in the PS4 audio menu and I can control the PS4 using voice commands through the headset. Game audio is coming through in the headset perfectly fine. Headset is connected before starting the game. UPDATE: Issue is also present when using the PS4 supplied earphone/mic when connected to controller.
  • Platform: PS4

 

Hi @Monzie83, I have to thank you because your topic and more precisely your quoted UPDATE, helped me to solve my problem and finally get the radio working on the PS4, even using a steering wheel! In fact I did several attempts in the past but, I don't know why :classic_rolleyes:, I was always using my own headphones, mics, etc. rather than trying with the supplied earphone/mic. Now it works like a charme! :classic_cool:

In case other steering wheel players are in trouble with the radio controls on PS4, here my steps:
1) turn on the PS4 with the steering wheel already plugged in;
2) click the steering wheel "PS" button and enter the account (the PS4 mainscreen appears);
3) with the supplied earphone/mic already connected to a controller, click the "PS" button of the controller, after few seconds it will say the mic has been connected;
4) now it's enough to normally play F1 2020 with the steering wheel, the radio commands will be recognized through the controller's microphone (which should be positioned close to the driver, mine is right behind the steering ring).

Cheers,
Nuv

  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, steviejay69 said:

@BarryBL if this can be replicated it should be in the FAQ or basic troubleshooting 

Makes a lot of sense. I've added it to the Basic Troubleshooting section, crediting all 3 of you (only fair). Once I have access to a PS4 (or someone that does), we'll test to make absolutely sure.

  • Thanks 1
  • Agree 1

Share this post


Link to post
Share on other sites
25 minutes ago, BarryBL said:

Makes a lot of sense. I've added it to the Basic Troubleshooting section, crediting all 3 of you (only fair). Once I have access to a PS4 (or someone that does), we'll test to make absolutely sure.

@BarryBL, I would also add in the troubleshooting to go into Grand Prix mode and start a race (making sure mic is activated before starting the game). I’ve found this is the only consistent way I can activate the mic with my 3rd party headset, for race voice commands in Driver Career and may help others in the same situation.

Edited by Monzie83

Share this post


Link to post
Share on other sites

@Nuvolarix, glad I could help.

With your 3rd party headset, do try to activate it before starting the game and go into Grand Prix mode and start a race. Then switch back to My Team, Driver Career etc. It works for me and might get you 3rd party stuff working.

For your scenario, you may also want to set the controller to never turn off (if you play longer races).

Good luck!

Edited by Monzie83

Share this post


Link to post
Share on other sites
9 minutes ago, Monzie83 said:

@Nuvolarix, glad I could help.

With your 3rd party headset, do try to activate it before starting the game and go into Grand Prix mode and start a race. Then switch back to My Team, Driver Career etc. It works for me and might get you 3rd party stuff working.

For your scenario, you may also want to set the controller to never turn off (if you play longer races).

Good luck!

@Monzie83, my 3rd party headsets actually have never been recognized (about mic), but I understood it only yesterday by using for the first time the supplied earphone/mic and I saw that "working" message for the first time :classic_rolleyes:
Yes, my controller is set to never turn off (I play 100% distance), this may also be added in the
troubleshooting maybe @BarryBL
 

15 minutes ago, Monzie83 said:

@BarryBL, I would also add in the troubleshooting to go into Grand Prix mode and start a race (making sure mic is activated before starting the game). I’ve found this is the only consistent way I can activate the mic with my 3rd party headset, for race voice commands in Driver Career and may help others in the same situation.

25 minutes ago, BarryBL said:

Makes a lot of sense. I've added it to the Basic Troubleshooting section, crediting all 3 of you (only fair). Once I have access to a PS4 (or someone that does), we'll test to make absolutely sure.

I did it again today and from my side I can confirm 100% working so far both in Driver Career and in GP-mode, not only race but also practice, just perfect! I love this stuff :classic_cool:

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Nuvolarix said:

I did it again today and from my side I can confirm 100%

Good to hear. Much better to use voice commands rather than fiddling with the MFD!

  • Agree 1

Share this post


Link to post
Share on other sites

New update to my issues. I, unlike most of the kids on this board, USE A PC (details in my profile)... I've tried all of the tips above, and nothing has changed anything. Something else I tried, was changing the "Sound" option in "Settings" to show my actual sound chip set, instead of the generic Windows drivers... NOTHING WORKS !!! Started with 1.15, and just like everything else at codemasters... They'll get to it when they get to it... I've done all the "GP" mode tips, reinstalled my sound drivers, reinstalled f1 2020, cleaned my registry... And EVERYTHING else... Any other computer professional would do... Driving a full GP and then going to Career Mode did nothing, and the microphone DOESN'T work IN ANY MODE... While it works IN EVERYTHING TO DO WITH MY OPERATING SYSTEM...

Share this post


Link to post
Share on other sites
11 hours ago, DiverSteve said:

New update to my issues. I, unlike most of the kids on this board, USE A PC (details in my profile)... I've tried all of the tips above, and nothing has changed anything. Something else I tried, was changing the "Sound" option in "Settings" to show my actual sound chip set, instead of the generic Windows drivers... NOTHING WORKS !!! Started with 1.15, and just like everything else at codemasters... They'll get to it when they get to it... I've done all the "GP" mode tips, reinstalled my sound drivers, reinstalled f1 2020, cleaned my registry... And EVERYTHING else... Any other computer professional would do... Driving a full GP and then going to Career Mode did nothing, and the microphone DOESN'T work IN ANY MODE... While it works IN EVERYTHING TO DO WITH MY OPERATING SYSTEM...

Well, thanks for the ranting. Post the bug in your own thread with all the dxdiag and video of it not working (from you starting up the PC).

Unless....you don't want it fixing.

Share this post


Link to post
Share on other sites
11 hours ago, DiverSteve said:

microphone DOESN'T work IN ANY MODE

Have you tried installing Kinect? I remember reading somewhere on these forums you need this for voice commands to work on PC. It doesn’t work using native Cortana on PC.

Sorry I can’t help you further as I’m not on PC

Share this post


Link to post
Share on other sites

I had this working on 2.18, 2019, and 2020 since July 2020. I've never heard about installing Kinect, but I'll try it and let you know. Thank You Monzie 🙂

 

Share this post


Link to post
Share on other sites

Ooooo Poor little steviejay 😞 hasn't got the backbone for criticism... Waaaaaaaaa Oh Yeah mr. I'm so smart... I did post a bug report... How many answers do you think I've gotten ??? WHY DO YOU THINK I'M ON THIS THREAD ??? Boy... they didn't hand out any extra points for you did they ???

Share this post


Link to post
Share on other sites

After looking into Kinect, it's only for people who have X-Box, and requires a sensor be installed for it to work. Not for a PC without an X-Box. Thank You Monzie, for your kindness and consideration, and for TRUELY trying to help, unlike the people who THINK THEY'RE THE SMARTEST PERSON IN THE ROOM... With NOTHING to back them up.

Share this post


Link to post
Share on other sites
3 minutes ago, DiverSteve said:

After looking into Kinect, it's only for people who have X-Box, and requires a sensor be installed for it to work. Not for a PC without an X-Box.

I found this online - something about installing Kinect for windows components: https://amp.reddit.com/r/F1Game/comments/hmgxvg/voice_commands_f1_2020/And https://www.reddit.com/r/F1Game/comments/hmsk50/voice_control_unavailable_f1_2020/ and 

I’ve also seen somewhere that in the windows settings you need to choose your mic input device.

I have no idea about all these Kinect voice packs and file edits, but hopefully something in there will work for you.

Share this post


Link to post
Share on other sites

Thank You Monzie !!! You gotta be the nicest person on this forum. I've done all that, and as I said, everything was working fine before steam updated my F1 2020 to 1.15 ... Been broken ever since. Thanks Again !!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×