Jump to content
DiRT Rally 2.0 - New Player Guide Read more... ×

Archived

This topic is now archived and is closed to further replies.

Issues iwth Fanatec pedals clutch

Recommended Posts

So i have selected H pattern with clutch and re selectec my fanatec presets at options and still i cant assing my clutch pedal..
i have searched around these forum for an answer with no success. Wheel i am using is Fanatec Porsche 911 Turbo S and same pedals as that picture. Thank you all for advantage Cheers!

Share this post


Link to post
Share on other sites
I think the input assigned to the clutch pedal for many wheels, di_slider_0, is broken in the game at the moment. Game has no knowledge of the input at all, so pressing it in-game or configuring it via the config files does nothing. Not sure if this has always been the case or if it's just a recent issue from the latest update.

Share this post


Link to post
Share on other sites
Hello,
I have the same problem with a Fanatec GT2 connected to a G27 pedal.
It seems it's from the begining, but I was thinking it was because I used the Fanatec wheel connected to the G27 pedal.
In the Fanatec wheel properties I can assign the clutch pedal, but it's not possible in the game...... Too bad. :s
Hope it will be fix soon.

Share this post


Link to post
Share on other sites
Hey,
Thank you for bringing this to our attention :-)

We have a potential fix for this problem coming in the next update, once it has gone live I will let you know.

Share this post


Link to post
Share on other sites
The problem is not fix with the latest update V0.7. :'(
During configuration, after making the wheel fully turn,  I press a button, 90° turn, then I press a button, and start  to assign accelerator, brake and clutch. Then I press  accelerator (ok), brake(ok) and clutch.
Instantly when I press the cluctch it close the window like if I hit a button to valid it.... So it looks like the clutch is recognize like a button... 
Is there sommething to change it somewhere else in the menu to set the cluch manual and not automatic ??
Thanks in advance for your support. 
Best regards.

Share this post


Link to post
Share on other sites
Hi all, 
here is a solution which is very simple, in fact.
I don't think the clutch has to be turn on in the preference settings menu, before configuring the wheel system...  :#
Hope it will help and solve some issue. :)
Thanks to kbital ital for his video:
https://www.youtube.com/watch?v=cVausCSWbsc

Share this post


Link to post
Share on other sites
I had a problem with my GT2 and elite pedals running through the wheel base. It's fixed now, but before I could use the clutch if I plugged my pedals in to its own USB port.

Share this post


Link to post
Share on other sites

×