Jump to content Jump to content

Logitech Gaming Force Pro - not recognized in game


badnatey

Recommended Posts

Hey everyone!

I've bought a bunch of F1 games in the past but have only ever had a controller. I bought a cheap wheel to see how the experience was but I'm having some issues getting them to detect.

It's a Logitech Driving Force Pro. It's a pretty old wheel, but the quality seems pretty good and it's officially supported. Everything works in Logitech Gaming Software & Hardware - Game Controller.

I have only tried F1 2013 so far, which also says it's supported, but I'm getting nothing in game.

The only other game I've tried, is Assetto Corsa Competizione, which I had to disable Steam Input via right clicking the game and going to properties and disabling steam input to get the wheel to recognize. After that all inputs worked great and I was able to drive (poorly hahah).

I tried this for F1 2013 but the game immediately crashes if I disable those settings.

I have F1 2018 and F1 2020 installing, but haven't got to try them yet.

So in long - I know the wheel works, it's officially supported, but F1 2013 is having issues. I'm hoping the new ones don't have an issues. I just sucks cause 2013 is my favourite because it has my favourite old-time driver - Berger.

Link to comment
Share on other sites

  • 2 weeks later...

It's on the supported list for F1 2013 - Driver is here.

I don't think the Steam Controller Input is good for F1 2013, it's not recommended for the newer games, certainly.

I would uncheck the Steam setting and verify your game files on Steam and delete the hardware_settings_config.xml before launching.

From memory a link needs to be made to the F1 2013, F1 2018 and F1 2020 exe's and the profile settings should be good for both games (360 DOR etc.) or a Persistent Profile may be good for them all.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...