Jump to content

Archived

This topic is now archived and is closed to further replies.

Problem with graphics, massive fps drop

Recommended Posts

I recently bought a Nvidia MSI gtx 970 which allowed me to play Dirt Rally over 80 fps in ultra settings. But since the last update, I've had a massive fps drop. I'm playing under 40 fps and it is very unplayable in RX. When I'm behind another car in the gravel the fps drop to 30 and when I hit a barrier they drop even to 15. It's really annoying because the game isn't smooth at all and it is unplayable. I feel I can't extract all of the fun of this game. Any solution? I'd be very grateful. I play on Windows 7.

Thanks

Share this post


Link to post
Share on other sites
Any other graphics settings I can use to gain significant performance?  Version 0.5 was a constant 60 fps on on ultra with my gtx 770 with core i5, and now I'm battling to keep any kind of smoothness on the high preset.  It's not just the RX tracks that are performing badly, forest sections in rally Germany are also dropping fps.  Advanced blending is already turned off (it totally kills performance).

Share this post


Link to post
Share on other sites
dont use the presets, manually set up the graphics, sometimes allowing NCP to control the AA and AF can give you a bump but thats swings n round abouts. medium/high shadows, AO off, advance blending off, rock n roll with the rest

MM

Share this post


Link to post
Share on other sites
Advance Blending is the bad guy there.

However, I do get some random drops from 60 (vsync) to 55-57 in 0.1-0.2 seconds, while it doesn't record more than 45% GPU usage, not maxing out on Memory Usage (VRAM), and fairly low temp on the GPU as well. I cannot understand why it drops (without vsync it flows between  125-140)

Share this post


Link to post
Share on other sites
I'm having fps drops in RX too. In rally I run on High with 2x MSAA, VSync on. with Ultra it sometimes dips a few fps below 60 on some maps. In RX I keep it at High, but turn off AA, it drops to about 45 fps, when drivin behind someone in the dirt. Once I hit the tire wall in Lydden jocker and had a 17 fps slideshow. The framedrops wouldn't be that bad, if it wasn't for the massive stuttering. Basically the game only looks good, when it's running 60 fps with vsync. Below or above 60 without vsync and it microstutters like crazy

Share this post


Link to post
Share on other sites
Thanks for your help guys, but it's still the same, here I leave some pics of my settings and performance during a race (sorry for Spanish translation in graphics options). The weird things is that, if I decrease graphics options, the fps and performance don't change and it is very random because sometimes it shows over 40fps, over 50 or under 40.

(alto=high//medio=medium//si=yes//personalizar=custom)







Share this post


Link to post
Share on other sites
Myrvold said:
Advance Blending is the bad guy there.

However, I do get some random drops from 60 (vsync) to 55-57 in 0.1-0.2 seconds, while it doesn't record more than 45% GPU usage, not maxing out on Memory Usage (VRAM), and fairly low temp on the GPU as well. I cannot understand why it drops (without vsync it flows between  125-140)
Stutters like that tend to be either a result of the way V-Sync works, which is by dropping frames in order to prevent screen tearing, or to hard drive read/write.
If you prefer consistent framerate and don't mind some possible screen tearing, enforcing a fps cap that is equivalent to your monitors refresh rate through advanced graphics card driver settings can be used instead.
If it's HDD related, then turning off replays may help considerably.

Didzis said: Below or above 60 without vsync and it microstutters like crazy
If your monitor/TV is only 60hz, then microstutters above 60fps is completely normal and is being caused on the monitor/output side, rather than the GPU/game itself. Having a framerate higher than your monitor/TV's refresh rate is always a detriment.

Share this post


Link to post
Share on other sites
BrySkye said:
Didzis said: Below or above 60 without vsync and it microstutters like crazy
If your monitor/TV is only 60hz, then microstutters above 60fps is completely normal and is being caused on the monitor/output side, rather than the GPU/game itself. Having a framerate higher than your monitor/TV's refresh rate is always a detriment.
In other games it's not that bad, I might get a bit of tearing, but otherwise no problems. Here the microstutters are very noticable and quite distracting

Share this post


Link to post
Share on other sites
Didzis said:
BrySkye said:
Didzis said: Below or above 60 without vsync and it microstutters like crazy
If your monitor/TV is only 60hz, then microstutters above 60fps is completely normal and is being caused on the monitor/output side, rather than the GPU/game itself. Having a framerate higher than your monitor/TV's refresh rate is always a detriment.
In other games it's not that bad, I might get a bit of tearing, but otherwise no problems. Here the microstutters are very noticable and quite distracting
Doesn't matter. That can be a perception thing as much as anything else.
Micro stutters caused by exceeding your monitors refresh rate are unrelated to the game itself.

Share this post


Link to post
Share on other sites
Lowered settings to medium and still the same. In Holjes sometimes it raises to 54 fps and sometimes it drops to 26 fps. CPU usage is around 60-70% and GPU usage around 40-50%. Please @justbiglee, I would like to know if this is a problem related to the last update and it can be fixed or if it's a problem of my pc. Before the last update it was a pleasure tu drive. It's not only in RX, I have some stutter in rally too. 

Share this post


Link to post
Share on other sites
Myrvold said:
Advance Blending is the bad guy there.

However, I do get some random drops from 60 (vsync) to 55-57 in 0.1-0.2 seconds, while it doesn't record more than 45% GPU usage, not maxing out on Memory Usage (VRAM), and fairly low temp on the GPU as well. I cannot understand why it drops (without vsync it flows between  125-140)
Just like to point out that my issues is not in RX, but Rally.

Share this post


Link to post
Share on other sites
Advanced Blending - generally, as mentioned before, leave it off at all costs (it's off by default even on ultra).
Ground Cover (grass) - turn it off. It's not pretty, but currently it's a massive framerate killer like Advanced Blending. It hardly makes a difference if you have it on low or ultra, you must turn it off. I believe that's a technical issue that's hopefully going to be fixed. You mentioned that Germany is hit badly too, which suggests ground cover may be the culprit. It does little in Monaco or Greece, but a lot in Germany.
Crowd - makes quite a difference where there's a lot of them. That means, especially in RX.
Particles - big issue in RX on gravel. Turning it off makes opponents not throw up dust anymore, which feels a bit like cheating, but it's a framerate heavy-hitter.
Cloth - can be a problem where there's a lot of it, again mostly in RX
Vehicle Reflections - causes a noticeable hit, and imo doesn't do much that justifies that.
Vehicle Details - set to lowest will increase FPS, but looks a bit poor.

Setting Shaders and Shadows to lowest settings also improves FPS, but it really looks shit, you don't want that.

And of course consider your AA settings.

Share this post


Link to post
Share on other sites
Another word:

imo this game's biggest problem currently is the awful stutter when vsync is turned off (at least I have that with Intel and Nvidia, and many others seem to have it too). It's painfully jittery and sluggish here with framerates below 100, and it's only really fluent with some 120+ fps (and I have an ordinary 60Hz screen!). Of course you have to turn down settings a lot for that, so it's far from ideal.

Turning on Vsync eliminates that and it's smooth as long as it holds up to the 60fps cap. Which allows much higher graphics settings. The downside of that is that you get the typical input lag. But there's a trick for that: having your framerate just below the Vsync cap largely eliminates the lag. You can do that by using a program like MSI Afterburner (works with non-MSI cards too) to cap the framerate at 59fps if the game's vsync cap is at 60, or 58 if it's at 59. Now you should have very little input lag and it should run smooth. Problem then again: you're going to have a dropped frame regularly, resulting in a micro-pause every 1-2 seconds, which is pretty annoying. Solution for that: using Nvidia's Adaptive Vsync instead of the game's Vsync, which will allow a tear instead of dropping a frame. To do that, open Nvidia Control Panel, find Dirt Rally in the list and force Adaptive Vsync (and turn the in-game Vsync off). Now you should have smooth 59fps, little lag, and a tear here and there, which is better than a dropped frame imo. It's still not ideal, but I think the best solution so far.

So to recap:
In-game: Vsync off
MSI Afterburner/similar program: 58fps cap
Nvidia Control Panel: Adaptive Vsync on

Share this post


Link to post
Share on other sites
Didzis said:
BrySkye said:
Didzis said: Below or above 60 without vsync and it microstutters like crazy
If your monitor/TV is only 60hz, then microstutters above 60fps is completely normal and is being caused on the monitor/output side, rather than the GPU/game itself. Having a framerate higher than your monitor/TV's refresh rate is always a detriment.
In other games it's not that bad, I might get a bit of tearing, but otherwise no problems. Here the microstutters are very noticable and quite distracting
I agree, it's a very minor issue in other games, in DR it's horrid.

Share this post


Link to post
Share on other sites
Malyngo said:
I suspect this has more to do with the CPU struggling with RX. Especially the hitting the tyre barrier is pointing in that direction, imo. The tyres flying around will probably be heavy on the CPU, because of the physics stuff.
First thought so too, but at least my monitoring tool suggests otherwise. It notices neither GPU nor CPU load increase when hitting the tyre walls, so I don't know what's going on really, but it doesn't seem to be a CPU bottleneck. Might be an optimisation issue rather than hardware limits.

Share this post


Link to post
Share on other sites
Didzis said:
BrySkye said:
Didzis said: Below or above 60 without vsync and it microstutters like crazy
If your monitor/TV is only 60hz, then microstutters above 60fps is completely normal and is being caused on the monitor/output side, rather than the GPU/game itself. Having a framerate higher than your monitor/TV's refresh rate is always a detriment.
In other games it's not that bad, I might get a bit of tearing, but otherwise no problems. Here the microstutters are very noticable and quite distracting
I agree, it's a very minor issue in other games, in DR it's horrid.
One solution for the stuttering would be an option to select borderless windowed mode. Also, would help with alt+tabbing. 
I did also posted that in the suggestions, with some people agreeing :) http://forums.codemasters.com/discussion/7158/improvement-add-borderless-windowed-mode-to-graphic-options?new=1

Share this post


Link to post
Share on other sites
Yesterday I played the game launched through Razor Game Booster and I was playing between 50 and 60 fps in RX and 90-100 in rally. It's not perfect but a lot better than before. 

Share this post


Link to post
Share on other sites
I was getting major FPS hit in VR since the RX update but, using RTSS to lock the frames helped. Image quality is poor though in VR since the update (Direct Mode).

Win7 // Intel i7 // GPU - GTX 980 Ti // SB ZX Soundcard

Share this post


Link to post
Share on other sites
After this update it's still the same problem. I'm playing with Game Booster which allow me to play with higher fps buy I'm usually between 55 and 65 fps in RX in high graphics settins (not even in ultra). In normal rally mode I'm at 90 fps easily. I don't understand what is the problem because with a gtx 970 should be enough to play it in ultra, isn't it? The graphics card drivers are updated. Help me please  :(

Share this post


Link to post
Share on other sites
RX really stresses the hardware, at least in the current version of the game. Try these graphics settings:

A) particles off--particles really hit framerates in RX, sadly turning it off removes all dust etc., so it's a bit of a cheat
B ) ground cover off--an issue in the entire game
C) if you use the mirror, set its settings very low
D) crowd lower--there's a lot of crowd in RX
E) cloth lower/off--there are also lots of flags etc.
F) car detail/reflections lower

Share this post


Link to post
Share on other sites
one of my pcs has a 970 gtx in and rx is fine dont have advanced blending on though normal rally is about 120 fps avg about 90+

in rx 70-90 fps avg

i record on it sometimes at 60 fps capped .

so something not quite right if you under that unless you have a slower cpu. is it a amd cpu ? also you may want to try another nvidia driver.also dont use game booster programs they are pointless.

Share this post


Link to post
Share on other sites
There's a lot of factors that impact framerates, like CPU and background processes (antivirus!) and so on. You might also try driver cleaner or something to get rid of old graphics drivers before installing the current one again, that helped a lot for me too.

Share this post


Link to post
Share on other sites
There's a lot of factors that impact framerates, like CPU and background processes (antivirus!) and so on. You might also try driver cleaner or something to get rid of old graphics drivers before installing the current one again, that helped a lot for me too.
Usually those cleaners do more harm than good

Share this post


Link to post
Share on other sites

×