Jump to content

Archived

This topic is now archived and is closed to further replies.

Problem with graphics, massive fps drop

Recommended Posts

Particles combined with ground cover is the biggest fps thief for me. Choose one and turn off and it should be butter smooth.

Share this post


Link to post
Share on other sites
Didzis said:
There's a lot of factors that impact framerates, like CPU and background processes (antivirus!) and so on. You might also try driver cleaner or something to get rid of old graphics drivers before installing the current one again, that helped a lot for me too.
Usually those cleaners do more harm than good
Got me some +10-20% fps after installing my 970

Share this post


Link to post
Share on other sites
I recently found the "Advanced Blending" in the graphics options and turned it on... big FPS drop especially noticeable in helicam replays. Not sure what Advanced Blending does and didn't notice  much difference, so I turned it off and FPS is great again.

Share this post


Link to post
Share on other sites
I found the source of my problem; Advanced Blending was already set to off.  Under "Video Mode", the AA settings were set to max.  Dropped it down to 4xMSAA, and all fine and back to normal again. :D

Share this post


Link to post
Share on other sites

×