Jump to content Jump to content

Logitech G923 and TRUEFORCE issues after 1.17


Recommended Posts

1 hour ago, BoringDamo said:

If you are on PC look at my post on page 1. 
Basically start DR then stop GHub. 

Thanks, stopping GHub did the trick. Everything back to normal.

BTW I'm also on the XBox version of the g923 (using it on PC). I guess I can consider this just another addition to the endless troubles I had with GHub before. Great Hardware, but their software...

Link to post
Share on other sites

after the latest update, the leds started lighting up in my g923, however its not synced with ingame rev lights and lights up just before and right after the ingame shift light.

is it possible to fix/adjust this somehow or maybe just disble the leds for now, as its currently just an annoyance and is seriusly triggering my ocd.

im on pc btw

Edited by Halvhjearne
Link to post
Share on other sites
On 2/17/2021 at 7:58 PM, LogiUK said:

Thanks.  We think that this should actually only be affecting the Xbox version of the G923 so I'm definitely interested to hear more from the G29 users.

I have a G29 and PS4.  After the last update, the steering wheel started crashing and indeed the FFB is not working.  What can I do? Oh and still the kind of note that in a DR2 game, the steering wheel settings should read ”logitech ...”, but I only read ”steering wheel” in it.  How do I get the game to recognize the right steering wheel?

In fact, I have had a problem with the FFB in the past.  When I start the PS4 the steering wheel calibrates itself and it works properly, but when I start any rally game, then the steering wheel disappears from the FFB.  The FFB only works when the game is started from power save mode.

 But really, now after the last update, the steering wheel is rattling, as I wrote at the beginning.

Edited by MistJo
Link to post
Share on other sites
  • Social Media & Community Team
On 2/19/2021 at 6:42 PM, ale16horizon said:

Do you have any remote clue on when a Hotfix will be released?
Thank you

Nothing to report as of now.

If and when I get a date for a hotfix I'll share it 🙂 

Link to post
Share on other sites

After the last update I had an issue with my shifter not working on my logitech g29 for ps4. I thought it might have been pulled out of the plug under the wheel so I went into the game settings to see if it was reading the shifter inputs and alas it was! I reads all gears correctly, all pedals and steering inputs and everything, however no matter what kind of race I start when I try to use the H pattern shifter it acts like it isn't reading, I just bang out whatever gear I start in and it won't go into any other gear or neutral. Can anybody help me? Or is this a bug anyone else is experiencing?

 

Edit: I forgot to add that this only happens in Dirt rally 2.0, all other sim racing games that can read the shifter work perfectly fine so I have narrowed it down to an issue with the game.

Edited by dkp103
  • Agree 2
Link to post
Share on other sites

I had the same issue with Ps4. After the update is installed, H shifter or paddles in G29 wheel stopped working for me as well. I re-installed the dirt rally 2.0 but H shifter or paddles in G29 wheel is still not working. I have other game that uses H-shifter function, and this game is working without any issue.

  • Agree 3
Link to post
Share on other sites

Hi all, carrying over the post I made on the Dirt Reddit: https://www.reddit.com/r/dirtgame/comments/llz15q/if_you_are_having_problems_with_your_g29920923/

The FFB on my G29 (PC) has felt weak and vague since the update and I think I found why. 

After some searching I found that the ffb_force parameter for the G29 in the device_defines.xml file was missing for some people after an update back in 2019. I checked this file and sure enough that parameter is missing for the G29. Actually its not there for any of the defined wheels (Fanatec etc.). I added ffb_force=5.0 and the feeling in my wheel is back. Bumps are magnified and there is way more FFB. 5 times as much, I suspect. I hope I haven’t done this mistakenly and the gearing in the wheel is being driven too hard now or causing clipping.

Sounds like this may have been a problem in 2019 as well. Why isn’t this an in-game parameter that can be changed? And if it’s supposed to be there, why is it gone again after the update? Needless to say I’m relieved that I wasn’t imagining things after all but this is frustrating to say the least. Maybe the ffb_force=5.0 line was never in the devices_defines.xml for the G29 before the update by default. Either way the FFB feels much better to me now that I've added it.

 

EDIT: I found a .pdf from Codemasters explaining how to edit this .xml file and an explanation of optional parameters that may be added to enhance the FFB of input devices (Section 6).

Here are other posts from users regarding the same:

https://steamcommunity.com/sharedfiles/filedetails/?id=1663123655

https://steamcommunity.com/app/690790/discussions/0/1843566500527591542/

https://www.reddit.com/r/dirtgame/comments/atojsm/ffb_issue_lack_of_textureroad_feel_ffb_force_ffb/

 

Edited by PavkoVicious
improve clarity, add detail
Link to post
Share on other sites

Finally im not alone with this issue . I have had the same issue sine the 1.28 update .Dirt 2.0 is all i play with the G29 and so notice this issue instantly. I have since been able to prove it is the update by temporarily deleting both the game and my game profile data and reinstalling the game from the dics . thus allowing temporary play of the game in a previous version without installing the 1.28 update, and guess what . YES the shifter works perfectly (but i cannot access my game profile because this is now saved as 1.28 version or play online activate unless i reinstate the 1.28 update , and as soon as the 1.28 is reinstated the shifter stops functioning)

I have tried contacting both PSN & codematers over th is issue. I am still await a proper reply from PSN . but codmaster have literally just replied today with a "wash their hand of it" cop-out email. 

image.png

  • Agree 2
Link to post
Share on other sites
16 hours ago, LogiUK said:

What happens if you unplug/replug the wheel whilst in the game? 

Thank you for your answer and your question.

Once the steering wheel is connected it calibrates itself. After pressing the PS button, a couple of things happen there, either so that the game crashes and a blue screen appears, error code CE-34878 ... or the FFB just disappears from the wheel.

Link to post
Share on other sites

I should mention that after playing for a couple hours last night my wheelbase got pretty warm and there was a plastic-y smell. Maybe ffb_force=5.0 is too high or I need to lower in-game FFB settings now. There is a bit too much rumbling/road feel.

Link to post
Share on other sites
16 hours ago, BoringDamo said:

There is already a topic on G923 and potentially the Logitech software which might also affect the g29. 
Take a look because there is a workaround there that might help. 
 

 

Thanks, I saw that post and tried closing GHUB as was suggested for G923 users. It didn't change anything.

Link to post
Share on other sites

I have an Xbox G923 on DR 2.0 (PC).

Since version 1.17, it's unplayable. Steering is unresponsive and vague. FFB is totally broken. Wheel being loose one second and wrenching me to the left or right the next. 

Should I reinstall the game? What is the fix? Disabling G Hub (pressing Close on sys tray) does not improve things at all.

Is anything being done about this?

Patiently I await response.

 

Edited by MaverickMitch84
Link to post
Share on other sites

Today came a GHUB update 2021.1.1363

In the notes for that update it is written that they fixed the bug with disappearing FFB when the steering wheel comes out of the "sleep mode".

I haven't try new update with DR2.0 yet. And anyway I didn't have any issues with my G29 before.

Bot for those of you who had, it may be a fix. Update your GHUB.

Link to post
Share on other sites
8 hours ago, Tigron said:

Today came a GHUB update 2021.1.1363

In the notes for that update it is written that they fixed the bug with disappearing FFB when the steering wheel comes out of the "sleep mode".

I haven't try new update with DR2.0 yet. And anyway I didn't have any issues with my G29 before.

Bot for those of you who had, it may be a fix. Update your GHUB.

I updated Ghub and was still exactly the same, still have to exit ghub after starting the game then back to normal. 

Link to post
Share on other sites

im not exactly sure what happend within the last few days (i suspect it might have been the ghub update), but for some reason the rev lights has now stopped working again.

not that i think its a bad imo, but thought i would mention it anyway.

Link to post
Share on other sites
On 2/16/2021 at 8:20 PM, BoringDamo said:

It broke for my G923 too. I first went to do a time trial (I’d earlier watched a Jon Armstrong video of Rosebank Farm in Scotland and wanted to see how far off I was on pace) and it felt different than normal as well as the Rev lights on the wheel now lit up, 2 corners in and FFB all disappeared to nothing. 
The game is now unplayable and I’m gutted as I love this game (admittedly a later comer so still working through CM flat out scenarios on lvl91). 

Just out of interest, have you managed to get DR2.0 working with your G923 yet?

Link to post
Share on other sites
20 minutes ago, MaverickMitch84 said:

Just out of interest, have you managed to get DR2.0 working with your G923 yet?

Yes. I posted later on from that one with some steps I followed. 
Basically shutdown GHub whilst DR is running. That got it working back to how it was (ie no rev lights but FFB was fine). 

Link to post
Share on other sites
11 minutes ago, BoringDamo said:

Yes. I posted later on from that one with some steps I followed. 
Basically shutdown GHub whilst DR is running. That got it working back to how it was (ie no rev lights but FFB was fine). 

Thanks for the quick reply! Yeah I’ve tried that. Made sure GHub is totally closed in sys tray, but for me the steering is still totally wrong. Have to spin the wheel about 300degrees to get round any corners. Pretty sure there’s input lag as well as I can’t make small corrections meaning I crash pretty quickly. Have you changed anything else? Are your saturation and linearity set to 100? I’m not getting any help from Codemasters or Logitech on this.

Asseto Corsa Comp plays amazingly well on the same wheel / pc so this is defo a DR2.0 issue.

Link to post
Share on other sites
10 hours ago, MaverickMitch84 said:

Thanks for the quick reply! Yeah I’ve tried that. Made sure GHub is totally closed in sys tray, but for me the steering is still totally wrong. Have to spin the wheel about 300degrees to get round any corners. Pretty sure there’s input lag as well as I can’t make small corrections meaning I crash pretty quickly. Have you changed anything else? Are your saturation and linearity set to 100? I’m not getting any help from Codemasters or Logitech on this.

Asseto Corsa Comp plays amazingly well on the same wheel / pc so this is defo a DR2.0 issue.

Don't know if its limited to codemasters games but ever since I got my G923 and GHUB the wheel degrees of rotation settings I configure in GHUB just does not work. Starting a game just resets the wheels rotation settings etc to factory default (i.e. 900 degrees) no matter what's set in any profiles. Trying to manually switch GHUB profile in game via a button assignment will fix the rotation but then all FFB drops. I just gave up with trying to use GHUB to set it, my workaround is to leave all wheel settings at default in GHUB and then use in game saturation to configure the rotation I want, I don't get a hard lock at full rotation (480 for me), but it does the job.

 

Link to post
Share on other sites
  • Social Media & Community Team
10 hours ago, MaverickMitch84 said:

Any update on this investigation?

Nothing that's come as far as my inbox anyways. That doesn't mean nothing is being done, just that I don't have confirmation on anything final as of yet.

When that changes I'll post an update.

Link to post
Share on other sites
1 hour ago, Bynar said:

Don't know if its limited to codemasters games but ever since I got my G923 and GHUB the wheel degrees of rotation settings I configure in GHUB just does not work. Starting a game just resets the wheels rotation settings etc to factory default (i.e. 900 degrees) no matter what's set in any profiles. Trying to manually switch GHUB profile in game via a button assignment will fix the rotation but then all FFB drops. I just gave up with trying to use GHUB to set it, my workaround is to leave all wheel settings at default in GHUB and then use in game saturation to configure the rotation I want, I don't get a hard lock at full rotation (480 for me), but it does the job.

 

For me it doesn’t pick up the GHub settings when I start DR. I have to alt tab out of DR (sometimes a couple of times) before it will pick those settings up. This was the same before the recent DR or GHub updates. 
I do that and once DR has the settings (you can tell because the rotation stops are now there when turning the wheel on the DR menu screen) I then alt tab again and close GHub from the sys tray. Once that’s done everything works fine. 

Link to post
Share on other sites
1 hour ago, BoringDamo said:

For me it doesn’t pick up the GHub settings when I start DR. I have to alt tab out of DR (sometimes a couple of times) before it will pick those settings up. This was the same before the recent DR or GHub updates. 
I do that and once DR has the settings (you can tell because the rotation stops are now there when turning the wheel on the DR menu screen) I then alt tab again and close GHub from the sys tray. Once that’s done everything works fine. 

Yeah alt-tabbing in and out is another "solution" but I do the saturation approach as I'd rather have something that doesn't involve messing about. This issue isn't restricted to DR2.0 either, happens in Grid Autosport and Dirt 4 as well, I put it down to being GHUB being bobbins. My G25 and the old gaming software just worked for the most part, its a little frustrating having a far more modern wheel and lots more issues.

Link to post
Share on other sites
  • PJTierney changed the title to Logitech G923 and TRUEFORCE issues after 1.17
  • PJTierney featured this topic
  • PJTierney pinned this topic
  • PJTierney unpinned this topic
  • PJTierney unfeatured this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...