Jump to content
Sign in to follow this  

T500 no H-Shifter (resolved)

Recommended Posts

Sorry but perhaps I am doing something wrong but my Thrustmaster T500 does get recognized but I never get the advanced Wheel options nor am I getting any posibility to choose H-Shifter. (Sequential etc works). If it helps I do have different pedals attached via USB (Heusinkveld).

Share this post


Link to post
Share on other sites
Transmission change setting is in preferences.

If the Anvanced Wheel setting is missing then there something wrong with the game, I think. Is your game 0.6 version/latest version?
Verify the game files in steam.

Share this post


Link to post
Share on other sites
Thx Karik, but I have reinstalled twice already and my version is 0.6 but still. Also the directional steering is not showing a wheel icon but rather the joystick identification icon.

PS I know it's in preferences since that's where I was able to change to sequential shifting.

Share this post


Link to post
Share on other sites
OK, I "solved" it myself by removing the T500 profile and going the "unknown" wheel route and now I can configure the game with all of my devices. Apparently the T500 profile for me was a mismatch with all the various inputs I have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×