Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×

Constant game crashes within a few minutes

Recommended Posts

Posted (edited)

A detailed description of the issue. Please include any error codes here. 

After starting up the game it will crash within 2 minutes of it running. Whether I'm browsing the menu for too long or starting a benchmark. Game is extremely unplayable at this moment.

Platform

Steam on Windows 10 2004 Pro

What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.17

Game-mode?

All single-player modes including main menu & benchmark

We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?

Every single time.

How do you make the problem happen?

Starting the game, browsing the menu starting any race and starting a benchmark.

What troubleshooting have you attempted? Please always try to attempt to fix the issue 

  • Simple reboot
  • Steam
    • Reinstalled the game via Steam
    • Validated game files via Steam
    • Turned off the in-game overlay
  • Removed hardware_settings_config.xml 
  • Drivers are up-to-date
  • Both DX12 & DX11 are crashing

What peripherals are you are using (gamepad, wheel make & model etc) 

Xbox Series X Controller

Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

Game closes on crash, see crash report in the attachments.

 

 

Edited by Tacico
Deleted memory dump & system information

Share this post


Link to post
Share on other sites
Posted (edited)

I've narrowed the issue down to the following. The issue only occurs when my Xbox controller is connected to my PC. When disconnected I'm able to run the benchmark just fine with an average of 165FPS and 5 rounds in wet conditions. I'm using the official Microsoft Wireless Adapter.

I have no clue on how to fix the issue since reinstalling the needed drivers does not seem to help. Using another USB port doesn't work either.

Edited by Tacico

Share this post


Link to post
Share on other sites
22 hours ago, Tacico said:

I've narrowed the issue down to the following. The issue only occurs when my Xbox controller is connected to my PC. When disconnected I'm able to run the benchmark just fine with an average of 165FPS and 5 rounds in wet conditions. I'm using the official Microsoft Wireless Adapter.

I have no clue on how to fix the issue since reinstalling the needed drivers does not seem to help. Using another USB port doesn't work either.

F33g UEFI BIOS (AGESA Combo v1.2.0.1 patch A).

You are also using a USB 2.0 hub, please remove it and connect your devices (Microsoft Wireless Adapter) to your motherboard ports.

Try to introduce things in order of necessity (USB 3.0 will accept mech keyboard and Logitech gaming mouse dongle), try to place the XBox SX controller in a USB 2.0 port (in the bank of four).

Unsure as to which of the USB 3.x ports are CPU (Red?) and chipset (others inc. white and Type C?) The significance of the white port is it is the Q-Flash Plus port (for UEFI without CPU).

If you can try the without the Arctis SteelSeries Wireless, do so. Process of elimination, but the Arctis kit is very nearly a bespoke audio system.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, steviejay69 said:

F33g UEFI BIOS (AGESA Combo v1.2.0.1 patch A).

You are also using a USB 2.0 hub, please remove it and connect your devices (Microsoft Wireless Adapter) to your motherboard ports.

Try to introduce things in order of necessity (USB 3.0 will accept mech keyboard and Logitech gaming mouse dongle), try to place the XBox SX controller in a USB 2.0 port (in the bank of four).

Unsure as to which of the USB 3.x ports are CPU (Red?) and chipset (others inc. white and Type C?) The significance of the white port is it is the Q-Flash Plus port (for UEFI without CPU).

If you can try the without the Arctis SteelSeries Wireless, do so. Process of elimination, but the Arctis kit is very nearly a bespoke audio system.

 

Thanks for the tips. I'll try them out later today and let you know if it helped 🙂

Edited by Tacico
  • Thanks 1

Share this post


Link to post
Share on other sites
On 4/2/2021 at 7:00 PM, steviejay69 said:

F33g UEFI BIOS (AGESA Combo v1.2.0.1 patch A).

You are also using a USB 2.0 hub, please remove it and connect your devices (Microsoft Wireless Adapter) to your motherboard ports.

Try to introduce things in order of necessity (USB 3.0 will accept mech keyboard and Logitech gaming mouse dongle), try to place the XBox SX controller in a USB 2.0 port (in the bank of four).

Unsure as to which of the USB 3.x ports are CPU (Red?) and chipset (others inc. white and Type C?) The significance of the white port is it is the Q-Flash Plus port (for UEFI without CPU).

If you can try the without the Arctis SteelSeries Wireless, do so. Process of elimination, but the Arctis kit is very nearly a bespoke audio system.

 

Unfortunately the tips did not work. The issue still occurs when using a controller, the game is unplayable right now. I've tried the following:

  • Updated the BIOS to the latest version (1.2.0.1A)
  • Connected the wireless adapter to a motherboard port
    • Connected to different USB 2.0 ports
    • The USB hub is inside my case; removed the physical connection to the hub
  • Disconnected the Arctis Steelseries
  • Tried using a different monitor
  • Tried using another XSX controller
  • Tried using a XS1 controller
  • Thanks 1

Share this post


Link to post
Share on other sites

Try setting the monitor to 75Hz mode and enable V-SYNC. The Freesync of the monitor should pick up, but if you enable a 75FPS cap with V-SYNC OFF that might also work.

You need to lower the framerate as 165FPS is way out of this monitor's rated refresh.

However, consider running the benchmark to achieve a constant 75FPS at all tracks (the 2080S should score this in Ultra). I have a RX5700XT that I run at 120FPS (High) at WQHD so the 2080S should do UWQHD.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, steviejay69 said:

Try setting the monitor to 75Hz mode and enable V-SYNC. The Freesync of the monitor should pick up, but if you enable a 75FPS cap with V-SYNC OFF that might also work.

You need to lower the framerate as 165FPS is way out of this monitor's rated refresh.

 However, consider running the benchmark to achieve a constant 75FPS at all tracks (the 2080S should score this in Ultra). I have a RX5700XT that I run at 120FPS (High) at WQHD so the 2080S should do UWQHD.

I've tried both settings and even turned the game settings to low but this doesn't seem to fix the issue. The issue also occurs when using a virtual controller (so without the Microsoft Wireless adapter) plugged in. 

I should also mention that F1:2020 is the only game that has any issues on my setup. I do not own earlier F1 games so I'm not able to test those. The game itself was running great in december last year, I think it was patch 1.13. Is it possible to try older patches (without MP of course) through an official channel like Steam?

Edited by Tacico

Share this post


Link to post
Share on other sites
2 minutes ago, Tacico said:

I've tried both settings and even turned the game settings to low but this doesn't seem to fix the issue. The issue also occurs when using a virtual controller (so without the Microsoft Wireless adapter) plugged in. 

I should also mention that F1:2020 is the only game that has any issues on my setup. I do not own earlier F1 games so I'm not able to test those. 

Turning the game settings to Low just increases the framerate, the opposite of what you want. Not sure what else to suggest.

There is no need to disable the Steam overlay. What is the desktop refresh set to? Try matching to 75Hz.

  • Thanks 1

Share this post


Link to post
Share on other sites

So I've taken a look at your crash dump @Tacico and it does seem to be input related. Have you tried just connecting the controller via a cable so that it is not using the wireless adaptor? 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, RedDevilKT said:

So I've taken a look at your crash dump @Tacico and it does seem to be input related. Have you tried just connecting the controller via a cable so that it is not using the wireless adaptor

Thanks! 

I'll try to connect the controller via a cable when I get home later today. Another thing I have in mind is my new Wooting Keyboard which has a Gamepad mode (interacts as an Xbox Controller when using Analog mode). Could this possibly be the problem? I've tried analyzing the dumpfile as well, but only found a generic `xinput1_4.dll` exception.

Share this post


Link to post
Share on other sites
5 minutes ago, Tacico said:

Thanks! 

I'll try to connect the controller via a cable when I get home later today. Another thing I have in mind is my new Wooting Keyboard which has a Gamepad mode (interacts as an Xbox Controller when using Analog mode). Could this possibly be the problem? I've tried analyzing the dumpfile as well, but only found a generic `xinput1_4.dll` exception.

Another thing to look at is updating the Wireless Controller (i had issues with a Wireless Display Adapter until I updated the firmware via the UWP app) 🤞

And yes, for troubleshooting also try that.

Update your Xbox Wireless Controller | Xbox Support

  • Thanks 1

Share this post


Link to post
Share on other sites
9 minutes ago, Tacico said:

The wireless controllers already where up-to-date. This was something I should've mentioned 🙂

The issue has been resolved.

The Wooting keyboard was registered as primary controller and when using a normal Xbox controller in-game caused it to crash. The solution is to set the "Gamepad mode to No Gamepad. I do think this is a (small) bug in F1:2020 but I've mailed the manufacturer of the keyboard that's it's possibly something they could look into as well. Thanks @steviejay69 and @RedDevilKT for the support.

Fantastic! And yes, sometimes the responsibility for issues is shared 🙂 Devs don't go looking to make the game incompatible 👍

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×