Jump to content Jump to content

F2 Time Trial Leaderboard Resets Every Day


Recommended Posts

Dear Codemasters,

I am encountering a bug in the F2 time trial modes. It does not matter if I choose F2 2020 or F2 2019, the only drivers that appear in the leaderboard are people that have set laps on that day. All other times disappear the next day just sometimes there are 1 or 2 laptimes that are from yesterday or a day before. I am also very confident that more than 22 people have set a lap in time trial mode in Hungary (see attached picture). This issue is independent of track or car that I select. I am playing on Win10 PC with version 1.17 but I have seen the same issues since the release of the F2 2020 feature. Even though I do not believe that it matters, I am playing the game with the Fanatec Elite Wheelbase and the official F1 licensed Esports wheel from Fanatec. I would appreciate any help because without a leaderboard the whole time trial mode is pointless.

Thank you for your help.

 

Or in TLDR format:

  • Description: F2 time trial shows only lap times from today
  • Platform: Win10 PC
  • Version: 1.17
  • Game-mode: Time Trial F2 2019/2020
  • Reproduce: There is no way how I can prevent this nad it happens 100% of the time. Every leaderboard looks like that. I start the game, go to Solo - Time Trial - select a random car - select a track - check the leaderboard. There is also inconsistency between the friends leaderboard and the all leaderboard - my friends lap times are not shown in the "all" leaderboard. I have checked the ingame leaderboards and the one that you can access while selecting the track. Since my leaderboard time is in a few cases faster than all other lap times driven today, I am appearing on top but not with position 1 but sometimes with position 0. I have also installed the game on my other laptop, I encounter there the same problem so it is probably linked to my account or something like that.
  • Troubleshooting: Switch cars, track and play on another day. Doesnt help
  • Peripherals: Fanatec Elite Wheelbase with F1 Official Esports Wheel
  • F1bug.thumb.jpg.8a859e62314b6c98ddd780e82fecc1d6.jpg

 

 

Edited by F1Slamtrax
Link to post
Share on other sites
5 hours ago, steviejay69 said:

Thanks for the report. This looks like one to try to replicate.

I haven't been able to replicate this one. 

You are probably correct it is a connectivity or account issue. Are there any problems using multiplayer sessions or F1 TT sessions?

 

Link to post
Share on other sites
Posted (edited)

Hey,

Unfortunately not. I can join unranked and ranked sessions just as normal. I also don't have the spinning wheel on the top left longer than a few seconds when it loads the leaderboard, it absolutely behaves and look like just 20 people have set lap times. I also wanted to test if it has anything to do with steam, but apparently you cannot connect to the codemasters server in Steam offline mode.

F1 TT is fine, there everything works like intended.

 

Edit: I have an idea. I've set a slow disqualified laptime in F2 2020 Bahrrain short. That should appear near the bottom of the leaderboard. Can you check if that time was even uploaded to the server and shows up in your leaderboard? I have attached a screenshot and I received for this incredible time a 50 credit bonus - so the super license stuff works as well.F1bug2.thumb.jpg.ff35f7b9cc703fe7b95f9ca3a354019e.jpg

Edited by F1Slamtrax
Link to post
Share on other sites
25 minutes ago, F1Slamtrax said:

Hey,

Unfortunately not. I can join unranked and ranked sessions just as normal. I also don't have the spinning wheel on the top left longer than a few seconds when it loads the leaderboard, it absolutely behaves and look like just 20 people have set lap times. I also wanted to test if it has anything to do with steam, but apparently you cannot connect to the codemasters server in Steam offline mode.

F1 TT is fine, there everything works like intended.

I would suggest some basic troubleshooting first, like verifying your game files or a reinstall.

If you want to play offline a lot, don't use the Steam cloud for sync. If you're playing offline whilst actually being connected the whole time then that's odd. Online services will only update your game when you are connected but IDK if the concurrent connection to Steam is required or even a factor.

A little more information of how and when you disconnect, what and when would be helpful to replicate.

I don't use Steam Cloud but I do use File History, but I rarely play offline so unless Steam has an outage or the Online Services are down then they are always available to me.

Link to post
Share on other sites
Posted (edited)

I've checked the game files with Steam twice and installed the game on my other computer where I see the same problems. Would be weird if both independent installations have the same files missing or corrupted and not detected via Steam.

Quote

A little more information of how and when you disconnect, what and when would be helpful to replicate.

I usually don't play offline. I just wanted to test if it makes a difference. I'm always connected to Steam and their online services.

To be honest, I have never changed any settings for F1 2020. By default it has Steam Cloud activated with 50MB/299.45MB occupied. Maybe the App-ID and Build-ID of the game files help? I have App-ID 1080110 and Build-ID 6373901 which were last updated on 23.3. - I think that was the release of v1.17.

I've now attached a video. I've just started the game at the point when the videos starts. What I have not seen before is that Australia and Bahrrain show probably all players that have set a time there. But going to the next tracks makes this bug appear again. E.g. I bet that at least someone has set a time in China and for Zandvoort and Silverstone I'm again P0.. And of course you can see that the Leaderboard in Hungary is now different from the screenshot that I posted on friday.

Edited by F1Slamtrax
Link to post
Share on other sites
1 hour ago, F1Slamtrax said:

I've checked the game files with Steam twice and installed the game on my other computer where I see the same problems. Would be weird if both independent installations have the same files missing or corrupted and not detected via Steam.

I usually don't play offline. I just wanted to test if it makes a difference. I'm always connected to Steam and their online services.

To be honest, I have never changed any settings for F1 2020. By default it has Steam Cloud activated with 50MB/299.45MB occupied. Maybe the App-ID and Build-ID of the game files help? I have App-ID 1080110 and Build-ID 6373901 which were last updated on 23.3. - I think that was the release of v1.17.

I've now attached a video. I've just started the game at the point when the videos starts. What I have not seen before is that Australia and Bahrrain show probably all players that have set a time there. But going to the next tracks makes this bug appear again. E.g. I bet that at least someone has set a time in China and for Zandvoort and Silverstone I'm again P0.. And of course you can see that the Leaderboard in Hungary is now different from the screenshot that I posted on friday.

 

1.17 is sufficient but I am going to tag @BarryBL in this one as it could be account related.

Have you tried sharing the game to another account e.g. a family share where you could try another account to play the game?

Link to post
Share on other sites
2 hours ago, steviejay69 said:

Have you tried sharing the game to another account e.g. a family share where you could try another account to play the game?

That's a good idea. I have to wait until Tuesday, but then I will let someone else play with my account and vice versa. I will keep you updated. Thanks 🙂 I really appreciate your help

Link to post
Share on other sites
Posted (edited)

Update:

Turns out my friend has the same problems. We have exchanged our accounts and we see the same leaderboards. I have attached screenshots. Screenshot 1 is the leaderboard of his account that I have taken, Screenshot 2 and 3 are made with my account for the leaderboard for the same track. You can see that his time is listed in the friends section but isn't listed in the general leaderboard. I conclude from that, that if the game does not find your lap time in the data base, it will set you on P0. Unfortunately I don't know other people that own the game that I can ask or share accounts with.

F1bug3.thumb.jpg.0e9a67cadeee4e2a3c52858dca0e873d.jpg

 

 

F1bug4.jpg

F1bug5.jpg

Edited by F1Slamtrax
Screenshots were cut off
Link to post
Share on other sites
  • F1Slamtrax changed the title to Updated Feedback: F2 Time Trial Leaderboard Resets Every Day
  • 2 weeks later...

Sorry for the triple post - but apparently I need to do this to bring the thread again to the front-page because nobody saw that I have updated the feedback and I haven't heard back from you for over a week now.

I have posted above the tests that I have done - any ideas or solutions to this problem? I am mostly playing F2 so it is important to me to fix this issue.

Link to post
Share on other sites

To make sure this doesn't get written off as "guy has connectivity issues1":
I know this exact issue happens for at least 5 people, including myself.
If you need more data, I'll ask around in the league, but everyone in there I've talked to so far has this exact behaviour.

Link to post
Share on other sites
2 minutes ago, Schneepflueg said:

DxDiag is attached, motherboard is an Asus Prime X570-P.
If you need more data I can ask around in the league for others to get you the same info, but hopefully this is sufficient.

DxDiag.txt

The more the merrier, diagnostic codes may also help. As in my previous post, I've been unable to replicate so if there is a commonality anywhere we need to be given the chance to spot it.

Link to post
Share on other sites
39 minutes ago, Schneepflueg said:

DxDiag is attached, motherboard is an Asus Prime X570-P.
If you need more data I can ask around in the league for others to get you the same info, but hopefully this is sufficient.

DxDiag.txt

3801 Beta UEFI (including AMD AGESA 1.2.0.2 - doesn't look to be any newer firmware for Vermeer CPUs since last August)

Updated LAN driver

AMD Chipset driver never hurts

Link to post
Share on other sites
1 hour ago, steviejay69 said:

3801 Beta UEFI (including AMD AGESA 1.2.0.2 - doesn't look to be any newer firmware for Vermeer CPUs since last August)

Updated LAN driver

AMD Chipset driver never hurts

The time trial leaderboards are implemented as a simple REST api over the HTTPS stack, that's really not something that should break from outdated drivers.
Another pointer that it's not client related is that it works flawlessly for the entire friends leaderboard, which uses the exact same REST api, except a different endpoint of course.

On a separate note, I'd really suggest you NOT to recommend updating BIOSs in a forum where you have no idea if people know what they are doing, much less BETA versions of it.
In the end you accidentally have some kid brick their parents PC.

Anyway, to not get into lengthy arguments about why updating won't help, I updated the drivers you requested anyway, the only exception being I went to the latest stable BIOS, that is 3603.
And, as expected, same behaviour as before: Global F2 2020 TT leaderboard is empty, friends leaderboard is populated.

Link to post
Share on other sites
57 minutes ago, Schneepflueg said:

The time trial leaderboards are implemented as a simple REST api over the HTTPS stack, that's really not something that should break from outdated drivers.
Another pointer that it's not client related is that it works flawlessly for the entire friends leaderboard, which uses the exact same REST api, except a different endpoint of course.

On a separate note, I'd really suggest you NOT to recommend updating BIOSs in a forum where you have no idea if people know what they are doing, much less BETA versions of it.
In the end you accidentally have some kid brick their parents PC.


Anyway, to not get into lengthy arguments about why updating won't help, I updated the drivers you requested anyway, the only exception being I went to the latest stable BIOS, that is 3603.
And, as expected, same behaviour as before: Global F2 2020 TT leaderboard is empty, friends leaderboard is populated.

Hmmm. Don't update W10 or play the latest build of F1 2020?

If there are chipset level issues, it could manifest itself in all sorts of ways. 

I'm glad you updated but BETA just means "try this more widely before we make it official / stable (because official and stable are interchangeable terms nowadays)"

Link to post
Share on other sites
36 minutes ago, Ultra3142 said:

This may be a dumb thought, but is there any chance that it makes a difference where in the world someone lives?

Possibly. Some German ISPs have been problematic but I don't recall the names and pretty much that's an entirely different issue outside the scope of the game.

Link to post
Share on other sites
Posted (edited)
19 minutes ago, steviejay69 said:

Possibly. Some German ISPs have been problematic but I don't recall the names and pretty much that's an entirely different issue outside the scope of the game.

I was just asking as from the posts in this thread it looks like there may be some geographical commonality for the people affected...

(I'm guessing you're in the UK @steviejay69?)

Edited by Ultra3142
Link to post
Share on other sites
Posted (edited)

I know people in Switzerland, Germany and UK who it happened to.
But again, since the friends leaderboard works, it's really unlikely (the ISP reason), since it's essentially an HTTPS request, and both go to the same server, so an ISP cannot even distinguish between them.
That doesn't exclude that it's a regional thing server-side, though, it just excludes the clients as a source I think.

Edited by Schneepflueg
Link to post
Share on other sites
Posted (edited)

Hey,

DxDiag attached. I'm using an ASRock Z390 Pro4 on my Desktop PC, the laptop is an XPS 9560. Me and my friend are both playing from Germany.

On 5/7/2021 at 2:23 PM, steviejay69 said:

Some German ISPs have been problematic but I don't recall the names

I can exclude that as a reason because I have tried the local internet provider, my mobile internet from a completely different provider and my friend has a completely different provider, too. I would be surprised if it's therefore somehow client based.

I think that the best starting point for analysis is the fact that this (at least for me) occured first, when the F2 2020 season was introduced. During the last week I have also started to look on the leaderboard on a daily basis. I unfortunately did not make any screenshots but I had the impression if you load the leaderboard on a daily basis, then the 'old' leaderboard information from the days before stays in the database while if you don't do anything then all information gets deleted. I also dont understand the selection of data that makes it to my leaderboard. It's usually just the lap times of that day + a few additional ones, sometimes from the day before but sometimes I see times set before Christmas. Really weird.

 

 

DxDiag.txt

Edited by F1Slamtrax
  • Thanks 1
Link to post
Share on other sites
10 hours ago, F1Slamtrax said:

Hey,

DxDiag attached. I'm using an ASRock Z390 Pro4 on my Desktop PC, the laptop is an XPS 9560. Me and my friend are both playing from Germany.

I can exclude that as a reason because I have tried the local internet provider, my mobile internet from a completely different provider and my friend has a completely different provider, too. I would be surprised if it's therefore somehow client based.

I think that the best starting point for analysis is the fact that this (at least for me) occured first, when the F2 2020 season was introduced. During the last week I have also started to look on the leaderboard on a daily basis. I unfortunately did not make any screenshots but I had the impression if you load the leaderboard on a daily basis, then the 'old' leaderboard information from the days before stays in the database while if you don't do anything then all information gets deleted. I also dont understand the selection of data that makes it to my leaderboard. It's usually just the lap times of that day + a few additional ones, sometimes from the day before but sometimes I see times set before Christmas. Really weird.

DxDiag.txt

Do you have Steam installed to your C drive? 

Link to post
Share on other sites

Same issue here. I'm in the UK and have a B450 Tomahawk Max motherboard. I'm not comfortable sharing the DxDiag publicly (I don't have enough knowledge of what information is contained within it) however am happy to share it privately if wanted. I would add that the DxDiag I have generated is for DX12, but I run the game with DX11 (I crash frequently with DX12 in F1-2020) so it may not be too helpful? Here's a couple of screenshots from the Austria F2 2020 TT leaderboards - you will note that my friends times are not appearing in the global leaderboard that is only 100 users long.

20210509102942_1.jpg

20210509102954_1.jpg

  • Thanks 1
Link to post
Share on other sites
  • F1Slamtrax changed the title to F2 Time Trial Leaderboard Resets Every Day

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...