Jump to content Jump to content

SF1000 Wheel Settings Reset Every Time Game Starts


Recommended Posts

A detailed description of the issue. Please include any error codes here. :

When setting the angle of rotation on the Thrustmaster SF1000 wheel to 180 from the default 360 the wheel picks this up and is applied through the TM control panel. However when starting F1 2020 these settings are immediately set back to the defaults and cant even be changed within the game.

 

Platform - Steam

What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) - 1.18

Game-mode? - All

We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again? - Any time wheel is plugged in and the game is started or running.

How do you make the problem happen? - Launch game 

What troubleshooting have you attempted? Please always try to attempt to fix the issue - wheel firmware reset, fresh game install and tried on another PC 

What peripherals are you are using (gamepad, wheel make & model etc) Thrustmaster TX base - Thrustmaster SF1000 rim

Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.  N/A

Link to post
Share on other sites

maybe this is by design as the 1:1 steering lock is 360? but i can see if some people want to use less lock how this is a problem. could be an issue with how the new api has been implemented?

i haven't checked it myself as f1 2020 is the main game i play and my wheel angle rotation is set to 360 and i change it if i decide to drive on something else but i can check this later this evening and see if i get the same behaviour

Edited by cearp8858
  • Thanks 1
  • Agree 1
Link to post
Share on other sites
  • Moderator
5 hours ago, lewisc2000 said:

A detailed description of the issue. Please include any error codes here. :

When setting the angle of rotation on the Thrustmaster SF1000 wheel to 180 from the default 360 the wheel picks this up and is applied through the TM control panel. However when starting F1 2020 these settings are immediately set back to the defaults and cant even be changed within the game.

Platform - Steam

What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) - 1.18

Game-mode? - All

We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again? - Any time wheel is plugged in and the game is started or running.

How do you make the problem happen? - Launch game 

What troubleshooting have you attempted? Please always try to attempt to fix the issue - wheel firmware reset, fresh game install and tried on another PC 

What peripherals are you are using (gamepad, wheel make & model etc) Thrustmaster TX base - Thrustmaster SF1000 rim

Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.  N/A

Please check you are running the v57 wheelbase firmware and the 2021_TTRS_1 driver package

Link to post
Share on other sites

so i just tried the following with sf 1000 rim and TX base on PC

-thrustmaster control panel set rotation to 900 degrees

-started game 

-wheel soft locks to 360 degrees


-close the game 


-wheel allows 900 degrees again 

i am on driver 2.10.47.0 (1.TTRS.2021), wheelbase on base on firmware 57, rim on firmware 5.42

i had the control panel open on a 2nd monitor and the rotation angle didn't change on there so i can only assume the game now has a soft lock to 360 degrees, not reakky a problem but if someone wants to use less rotation angle than 360 degrees then they would be unable to do so.

btw soft locks in game i.e setting wheel rotation from within the game would be a nice thing to add for all wheel users as it saves the need to keep changing the rotation at driver level each time you want to play on other games and is a feature most other sims have , it's something that console players of the f1 games have had for a while now too 

  • Thanks 1
Link to post
Share on other sites
12 hours ago, cearp8858 said:

so i just tried the following with sf 1000 rim and TX base on PC

-thrustmaster control panel set rotation to 900 degrees

-started game 

-wheel soft locks to 360 degrees


-close the game 


-wheel allows 900 degrees again 

i am on driver 2.10.47.0 (1.TTRS.2021), wheelbase on base on firmware 57, rim on firmware 5.42

i had the control panel open on a 2nd monitor and the rotation angle didn't change on there so i can only assume the game now has a soft lock to 360 degrees, not reakky a problem but if someone wants to use less rotation angle than 360 degrees then they would be unable to do so.

btw soft locks in game i.e setting wheel rotation from within the game would be a nice thing to add for all wheel users as it saves the need to keep changing the rotation at driver level each time you want to play on other games and is a feature most other sims have , it's something that console players of the f1 games have had for a while now too 

The reason I normally do this is too increase the FFB strength - I know I could set the "steering saturation"  to 50 and that would technically make the wheel turn half of 360 but in doing this the FFB is no where near as strong when the angle is set to 180 

Link to post
Share on other sites
52 minutes ago, lewisc2000 said:

The reason I normally do this is too increase the FFB strength - I know I could set the "steering saturation"  to 50 and that would technically make the wheel turn half of 360 but in doing this the FFB is no where near as strong when the angle is set to 180 

force feedback shouldnt be any stonger with less rotation

Link to post
Share on other sites
1 hour ago, cearp8858 said:

force feedback shouldnt be any stonger with less rotation

Something definitely feels off, possibly just in my head 🤣 although would be nice to have the same features as console !

Link to post
Share on other sites
  • Administrator

What are your in-game wheel settings @lewisc2000. Can you post screenshots please?. Very high FFB levels can cause 'clipping' in some instances, as wheels are meant to be run at max FFB to get optimal performance. 

Link to post
Share on other sites
5 hours ago, lewisc2000 said:

Something definitely feels off, possibly just in my head 🤣 although would be nice to have the same features as console !


I know that David Greco uses 100% overall in the control panel and to not use over 75% with this in control panel in game with thrustmaster wheels as it induces clipping. 

i personally use default contol panel settings and small tweeks to the in game settings and it Doesnt matter if my wheel is set to 180 degrees or 900 degrees FFB always feels the same so unless your base overheats after a while and fades/reduces power in which case you can try turning forced cooling mode on for your base

of course this is diffrent to the original issue of the game soft locking to 360 degrees no matter the control panel setting for wheel rotation :classic_smile:

default for the TM contol panel is as below which is what i use
75% overall 
100% constant
100% periodic
100% spring
100% damper

in game i use
65% overall
35% off track
40% rumble strips
10% damper
understeer enhance off

 

Edited by cearp8858
  • Like 1
Link to post
Share on other sites

Hello together,

are there new information on this case? I also have the new Thrustmaster SF1000 Wheel and use it together with the TS-XW Wheelbase. 

For me its the same problem, the Thrustmaster Software wouldnt let me lower the wheel rotation more than 360 degrees. Also when you tab out of the game to do some stuff on the desktop and go back in, FFB is gone.

I would love to use the Wheel with 300 degree wheel rotation but for now i cant get it to work. Its so frustrating spending a lot of money if it doenst work like intended...

Greetings.

  • Agree 2
Link to post
Share on other sites

Hello everyone,
I get the exact same issue:
TS-XW wheelbase with the SF1000 rim and latest firmware on both as well as thrustmaster drivers.

FFB seems to get weaker after starting a new session, I have to test later if this is only after alt-tabbing however.
And even if I increase the FFB ingame it feels "wrong" somehow, even though I use the exact same settings as with the other rim a couple hours before.

  • Agree 2
Link to post
Share on other sites
15 minutes ago, Schneepflueg said:

Hello everyone,
I get the exact same issue:
TS-XW wheelbase with the SF1000 rim and latest firmware on both as well as thrustmaster drivers.

FFB seems to get weaker after starting a new session, I have to test later if this is only after alt-tabbing however.
And even if I increase the FFB ingame it feels "wrong" somehow, even though I use the exact same settings as with the other rim a couple hours before.

Definitely doesn't feel correct when the angle of rotation changes back to 360 - as said it's like the FFB is weaker ?

  • Agree 1
Link to post
Share on other sites

Do you guys have this problem only in F1 2020 or also in other games? Would be nice to know who is to blame for this. Thrustmaster or Codemasters?
I also feel like the FFB isnt constant, sometimes its stronger, sometimes its lighter, sometimes its gone...

 

Link to post
Share on other sites
15 minutes ago, ManOfTheHour said:

Do you guys have this problem only in F1 2020 or also in other games? Would be nice to know who is to blame for this. Thrustmaster or Codemasters?
I also feel like the FFB isnt constant, sometimes its stronger, sometimes its lighter, sometimes its gone...

 

For me it is just F1 2020 I have tried project cars 2 which doesn't seem to have the issue. Its also definitely not down to the base as it happens right away - there for not overheating I would say 🤷

Link to post
Share on other sites

I did not test with other games, and even if you tried the results would not be very useful, since the SF1000 is supposed to be more closely integrated with F1 2020 than other games, thus likely using either a custom or at least different API.

Based on the quality of their work in the past: Probably Codemasters at fault.

Link to post
Share on other sites
Posted (edited)

I did some more testing.
One way to reproduce it reliably is alt-tabbing, then FFB is completely gone and the wheel as to be rebooted to work again.
One would think that with all the issues F1 2020 has with alt-tabbing they'd test these things by now, but once more, there is either insufficient funding or noone gives a ****.

There also seems to be an issue with starting a new session, but I cannot reproduce it reliably.

Apart from this, the overall FFB seems to be weaker compared to the other rim, I went up from 55 with the "Open Wheel" rim to now 70 with the SF1000 to get the same strength.
This part may well be on Thrustmasters end however.

Edited by Schneepflueg
  • Agree 1
Link to post
Share on other sites
  • Moderator
14 hours ago, Schneepflueg said:

I did some more testing.
One way to reproduce it reliably is alt-tabbing, then FFB is completely gone and the wheel as to be rebooted to work again.
One would think that with all the issues F1 2020 has with alt-tabbing they'd test these things by now, but once more, there is either insufficient funding or noone gives a ****.

There also seems to be an issue with starting a new session, but I cannot reproduce it reliably.

Apart from this, the overall FFB seems to be weaker compared to the other rim, I went up from 55 with the "Open Wheel" rim to now 70 with the SF1000 to get the same strength.
This part may well be on Thrustmasters end however.

Yes. I've found the workaround to any of the ALT-TAB issues is to run Windowed (Fullscreen), however I think this is an issue with the FFB and at least one of the Thrustmaster wheelbases that the FFB is lost when not running in Fullscreen exclusive.

However, it warrants some investigation as apparently FSO (Fullscreen Optimisations) is a thing in Windows 10 and it's not tied to DX11 or DX12. And apparently, seeing it's a Microsoft feature it's reportedly been buggy in some builds of W10.

Perhaps Codemasters could give some guidance as to whether or not the game is designed to use FSO (I suspect not, given all the 'Lost Focus' bugs I posted over the years before basically giving up on FSE to run Borderless and switching to AMD GPUs and Freesync). @BarryBL

The thorny question of issues with Nvidia GPUs and non-G-SYNC displays is another kettle of fish altogether.

How To Set VSYNC The Right Way In Your Games (wccftech.com)

Adaptive VSync | Technology | GeForce (nvidia.com)

Link to post
Share on other sites
Posted (edited)

I got the same problem with my t-gt base and the sf1000. It keeps resetting to 360 degrees. All other tm wheels (e.g. the open wheel) behave as expected. For this reason i tried to contact the TM support and they replied like they where not able to detect any "malfunctions", further they stated that the rotation is reset by the game (and this behavior should be "normal" - (which is NOT the case)). I'm not sure who is in charge here, but tm as well as codemasters should get things fixed - please.

Edited by z0mt3c
Link to post
Share on other sites
21 minutes ago, z0mt3c said:

Regarding the lost FFB: My workaround is to disable and re-activate the control schema once. => ffb comes back

Regarding the rotation, i didnt find any workaround yet.

My workaround for that is to Change the saturation ingame. You have to try a bit, but now i matched the wheel rotation to my old setting.

But in the end, i want to change it in the Software like for every other Thrustmaster wheel..

  • Thanks 1
Link to post
Share on other sites
1 hour ago, z0mt3c said:

Regarding the lost FFB: My workaround is to disable and re-activate the control schema once. => ffb comes back

Regarding the rotation, i didnt find any workaround yet.

Yes i occasionally lose ffb between races and or sessions and this does get it back again 

Link to post
Share on other sites
  • Administrator

Hi everyone,

Thanks for the response on this.

I'll get this over to the testing guys who are lucky enough to have received this rim for testing. Not that I'm jealous at all 😛 

  • Like 1
  • Thanks 3
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...