Jump to content
Bug Reporting - PLEASE FOLLOW RULES AND COMPLETE REPORTS Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×

[PC Steam] Low FPS on all game modes after latest game and Windows updates

Recommended Posts

  • A detailed description of the issue. Please include any error codes here. 

I'm having massive FPS drops everywhere in the game, on all tracks. I played the game for over 130 hours with no problems at all, managed to finish 3 career mode seasons. After finishing season 3, I put the game down for a couple of weeks, and when I came back to start season 4, the problems started. I made absolutely no in-game setting changes between these events. Before I could play with constant 60 FPS, now it fluctuates between 12 and 30, making the game unplayable (slowdown also causes the FFB to do weird things). I looked around and apparently the culprit was a Windows 10 update (KB5001330), and when Microsoft released a hotfix for that on Monday the issue went away completely - I managed to do two races with excellent performance. Then one day later (yesterday) the issue came back, again with no setting changes. I've verified that my Windows is in the latest build, with the KB5001330 fix applied in the Registry, and drivers are all up to date.

  • Platform

Windows 10 PC

  • What version of the game you are using (Shown on the start screen in the bottom left corner of the screen) 

1.18

  • Game-mode?

Haven't tried all of them, but happened in My Team Career, Time Trial and Benchmark

  • We need to be able to make your problem happen internally so we can fix the issue. Can you make the problem happen again?

Problem happens all the time on my system

  • How do you make the problem happen?

Just need to boot the game... it happens everywhere, all the time

  • What troubleshooting have you attempted? Please always try to attempt to fix the issue 
  1. Tried reinstalling the game (twice)
  2. Tried to roll back my Windows to a previous version (which I knew worked). Didn't help.
  3. Tried uninstalling only KB5001330. Didn't work.
  4. Tried to roll back my graphics card driver to a previous version (which I knew worked). Problem got even worse
  5. Tried lowering some settings (such as Post Process, Ambient Occlusion, Skidmarks, AA, Asynchronous Compute) gained at most 10 FPS, still bad
  6. Tried both DX12 and DX11 - DX11 also gains me a couple FPS, but still unplayable
  7. Ran the game on all kinds of screen modes - Windowed is by far the best, but I can get at most 45 FPS. Running the game on Fullscreen or Borderless Window tanks the FPS to 20-25
  8. Would have loved to downgrade my game to version 1.17 to see if that helps, but couldn't find that option on Steam

 

  • What peripherals are you are using (gamepad, wheel make & model etc) 

Logitech Momo Racing wheel, but the issue happpens with just keyboard as well

  • Any screenshots or video of the issue? If the video is long, please include a timestamp for when the issue appears.   

DxDiag.txt

20210429105011_1.jpg

20210429105030_1.jpg

20210429105624_1.jpg

20210429105633_1.jpg

Share this post


Link to post
Share on other sites

Turn Vehicle Reflections down, frame rate limit off, dynamic resolution off and update your graphics drivers.

Share this post


Link to post
Share on other sites

Did everything you asked, but it didn't improve the performance at all. Still getting 20-30 FPS (see screenshots below).

Carried out a couple more experiments. I tried setting everything to the lowest possible setting again to start with a clean slate. Rebooted by PC, tried the benchmark at Australia and the FPS shot up to 80. Then I decided to modify only one graphics setting at a time to see if I could isolate their effects, see if any one in particular was causing most of the problems. Started with shadows, then lightning, and FPS was still good. Then I enabled particles (medium) and the frame rate tanked to 24. So then I turned particles off again, see if it would improve, but it didn't - after the performance dropped for the first time, it stayed low no matter what graphics settings I tried. So I don't think that just fiddling with graphics settings is going to solve the issue.

Also tried a couple more circuits - with minimum graphics, Australia and Bahrain were good, but China and Netherlands were very slow.

Here's the screenshots taken with the configurations you asked for

20210429131238_1.jpg

20210429131526_1.jpg

20210429131539_1.jpg

Share this post


Link to post
Share on other sites

Sounds silly, how does it perform if you turn the refresh rate 1 to the right, so you get a value. I've always had it on that and seems to work well. I've added mine to copy for reference. Maybe you could copy mine as a experiment perhaps.

20210429180543_1.jpg

20210429180722_1.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
19 minutes ago, GuilhermeMach said:

That didn't make any difference, unfortunately. I'm kinda at a loss on what do try next.

Windows 10 build number 19041/19042.928 is fixed for NV framedrops (KIR)

UEFI 1.D (still quite old, but important fixes)

Edited by steviejay69

Share this post


Link to post
Share on other sites
Just now, steviejay69 said:

Windows 10 build number 19041/19042.928 is fixed for NV framedrops. 

It's the version I'm currently running - which is what is bugging me, because two days ago when I got this build it was running fantastic, but yesterday the stuttering came back

Capture.PNG

Share this post


Link to post
Share on other sites
Just now, GuilhermeMach said:

It's the version I'm currently running - which is what is bugging me, because two days ago when I got this build it was running fantastic, but yesterday the stuttering came back

Capture.PNG

Still quite a lot of old drivers and maybe USB devices could be re-connected in other ways.

Share this post


Link to post
Share on other sites
52 minutes ago, steviejay69 said:

Still quite a lot of old drivers and maybe USB devices could be re-connected in other ways.

I actually didn't realise I had never updated my BIOS... 😳 Thanks for the heads-up. I went around and updated all my drivers, again. Still, no difference for the game, still running slow. I'm gonna attach a new DxDiag file after all those changes.

I don't understand what you mean regarding the USB devices, though. The only things I have connected now are my keyboard and mouse (but the stuttering also happens with the wheel). I never really change which ports things are plugged to.

DxDiag.txt

Share this post


Link to post
Share on other sites
12 hours ago, GuilhermeMach said:

I actually didn't realise I had never updated my BIOS... 😳 Thanks for the heads-up. I went around and updated all my drivers, again. Still, no difference for the game, still running slow. I'm gonna attach a new DxDiag file after all those changes.

I don't understand what you mean regarding the USB devices, though. The only things I have connected now are my keyboard and mouse (but the stuttering also happens with the wheel). I never really change which ports things are plugged to.

DxDiag.txt

Okay if you've not changed or introduced any USB devices or how they're connected they're unlikely to be related to the issue.

Thanks for the new dxdiag, I can see you've updated the GPU driver. There is a USB device belonging to Micordia (vendor ID 0x0C45) with three entries?

Can't hurt also to update the Magician software in case the 840Evo needs a firmware update.

Also, please download these UAD drivers, uninstall your existing HDA audio drivers whilst disconnected from internet and then install the UAD version.

Also the TP-LInk adapter, try getting an updated driver here Download Center | TP-Link United Kingdom (you will need to know the model number, as it detects as a generic Broadcom device)

The MOMO wheel works with the older LGS software. It also works best in USB 2.0 (the two groups of  USB ports nearest the PS/2 connector are USB 2.0)

This article explains how you can check that the Windows update KIR has been installed and therefore will not be the issue

Microsoft pushes emergency fix for Windows 10 KB5001330 gaming issues (bleepingcomputer.com)

Share this post


Link to post
Share on other sites
8 hours ago, steviejay69 said:

Thanks for the new dxdiag, I can see you've updated the GPU driver. There is a USB device belonging to Micordia (vendor ID 0x0C45) with three entries?

I'm not sure what those are, but looking at the logs it seems to be related to my keyboard (but know very little about this tbh).

8 hours ago, steviejay69 said:

Can't hurt also to update the Magician software in case the 840Evo needs a firmware update.

Done, firmware was already up to date.

8 hours ago, steviejay69 said:

Also, please download these UAD drivers, uninstall your existing HDA audio drivers whilst disconnected from internet and then install the UAD version.

Done. I don't know if I did it correctly, but it didn't help. Also there's an nVidia audio driver that I could not remove for some reason

8 hours ago, steviejay69 said:

Also the TP-LInk adapter, try getting an updated driver here Download Center | TP-Link United Kingdom (you will need to know the model number, as it detects as a generic Broadcom device)

I've checked, and the version I'm using is the latest release for my card model (latest version in from 2015).

8 hours ago, steviejay69 said:

The MOMO wheel works with the older LGS software. It also works best in USB 2.0 (the two groups of  USB ports nearest the PS/2 connector are USB 2.0)

I'm already using the old LGS, the new one doesn't work at all for my wheel model.

8 hours ago, steviejay69 said:

This article explains how you can check that the Windows update KIR has been installed and therefore will not be the issue

Microsoft pushes emergency fix for Windows 10 KB5001330 gaming issues (bleepingcomputer.com)

Yeah, I had already checked that before asking for help here... it's installed.

I've been asking around the Steam Discussion Forums and at least one other person seems to have the same problem... they've tried even a clean Windows reinstall, and it did not work. TBH I think I'll just play F1 2017 (it's the latest I own before 2020 and it works fine) for a couple of weeks and wait for a new update from either Microsoft, Nvidia or Codemasters...

Capture.PNG

Share this post


Link to post
Share on other sites
28 minutes ago, GuilhermeMach said:

Done. I don't know if I did it correctly, but it didn't help. Also there's an nVidia audio driver that I could not remove for some reason

Yeah, I had already checked that before asking for help here... it's installed.

I've been asking around the Steam Discussion Forums and at least one other person seems to have the same problem... they've tried even a clean Windows reinstall, and it did not work. TBH I think I'll just play F1 2017 (it's the latest I own before 2020 and it works fine) for a couple of weeks and wait for a new update from either Microsoft, Nvidia or Codemasters...

Capture.PNG

Okay you can tell if the UAD driver is installed by the device listed in Device Manager as 'Realtek(R) Audio' rather than 'Realtek High Definition Audio'. You will also have a companion UWP app 'Realtek Audio Console'

And the patch is for DX12 games only, not DX11 so make sure you run the game in DX12.

Share this post


Link to post
Share on other sites
18 minutes ago, steviejay69 said:

Okay you can tell if the UAD driver is installed by the device listed in Device Manager as 'Realtek(R) Audio' rather than 'Realtek High Definition Audio'. You will also have a companion UWP app 'Realtek Audio Console'

And the patch is for DX12 games only, not DX11 so make sure you run the game in DX12.

Ok, seems like the UAD driver was installed correctly, everything is as you described. And yes, I'm running the game on DX12.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, so I decided to test some more. Turned all graphics options to their lowest possible setting and put the game on windowed mode, which is running better for me. FPS was around 100 (tested on Monaco with heavy rain).

Then I went to China, on my career save, to drive a couple of laps. The second I activated a replay, FPS dropped from 100 to 24. Then I restarted the game (this time with texture streaming on "low" instead of "ultra low"), loaded China again and tested the replay issue. FPS again started on 100, and the first 6 or 7 replays nothing happened, but on the 8th or so the FPS tanked to 24 and never recovered. Repeated the experiment a second time, and managed to trigger it with the first replay.

By the way, I really just need to trigger the replay. Triggering flashbacks is not necessary.

Can anyone of you guys help me with this? Everywhere I look it seems like I'm the only one having the issue, which is quite disheartening. I guess I could play without flashbacks, but I play with no assists and 100 difficulty... could bump it down to 95 or 90 to give me some wiggle room for mistakes, but -sigh- really wish I didn't have to, just want to play the game with decent graphics, decent framerates and not having to lock myself out of features

 

Edit 1: typo

Edit 2: lag can also start at the end of sessions. Just did practice 1 and 2 with good FPS, then when looking at the results screen at the end of FP2 the lag started. Restarted the game and it's back to working fine.

Edited by GuilhermeMach

Share this post


Link to post
Share on other sites
18 hours ago, GuilhermeMach said:

Ok, so I decided to test some more. Turned all graphics options to their lowest possible setting and put the game on windowed mode, which is running better for me. FPS was around 100 (tested on Monaco with heavy rain).

Then I went to China, on my career save, to drive a couple of laps. The second I activated a replay, FPS dropped from 100 to 24. Then I restarted the game (this time with texture streaming on "low" instead of "ultra low"), loaded China again and tested the replay issue. FPS again started on 100, and the first 6 or 7 replays nothing happened, but on the 8th or so the FPS tanked to 24 and never recovered. Repeated the experiment a second time, and managed to trigger it with the first replay.

By the way, I really just need to trigger the replay. Triggering flashbacks is not necessary.

Can anyone of you guys help me with this? Everywhere I look it seems like I'm the only one having the issue, which is quite disheartening. I guess I could play without flashbacks, but I play with no assists and 100 difficulty... could bump it down to 95 or 90 to give me some wiggle room for mistakes, but -sigh- really wish I didn't have to, just want to play the game with decent graphics, decent framerates and not having to lock myself out of features

 

Edit 1: typo

Edit 2: lag can also start at the end of sessions. Just did practice 1 and 2 with good FPS, then when looking at the results screen at the end of FP2 the lag started. Restarted the game and it's back to working fine.

HDD space looks low. Which drive has the swap file, Steam and the game? 

The HDD is only 320GB and SSD only 120GB?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×