Jump to content Jump to content

G29 Racing Wheel Throttle at Calibration Always 100%


LucVO

Recommended Posts

Hi, Just a few day's ago, I bought a logitech G29 steering wheel and F1 2020 (in Steam) very nice of course, only the steering wheel was mainly bought to race in F1 2020. . After some hassle with all the settings, it turned out that it is only possible to drive racing laps with 100% gas (fortunately the brake works). That cannot be the intention. By the way, it is a very good exercise and it is almost possible on 1 circuit. In the attachment you can see where the settings problem is (however, this is a setting that I cannot go to).

I think the problem is Steam. G-Hub is working, firmware is updated, G29 hardware is working in win 10.

Can somebody help

 

Kalibratie setting F1 2020 gas 100% - kopie.jpg

Link to comment
Share on other sites

I found the solution.   After looking at the lg_g29_xone.xml file in the \Program Files\Steam\steamapps\common\F1 2020\actionmaps directory it appears that the accelerate action is incorrectly mapped by default to the "di_y_axis".    It should be "di_z_axis".    If you just search and replace instance di_y_axis with di_z_axis by ....... (see attach file) in that file you can then go to the control menu in the game and choose load device preset for your G29 wheel.   This fixed my issue with the accelerator stuck at 100%. N

path.PNG

lg_g29_xone.jpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...