Jump to content Jump to content

[Dirt Rally] Game hangs when wheel is connected


Recommended Posts

System Spec
   Processor: AMD Phenom(tm) II X4 965 Processor (4 CPUs), ~3.4GHz
   Memory: 4096MB RAM
   AMD Radeon HD 7800 Series
   Microsoft Sidewinder FFB wheel

Steps to reproduce
This wheel used to work fine with dirt 3 and since a few updates ago it worked with dirt rally too.
Topic title says it all, game hangs on splash-screen when the wheel is connected and the task manager will say the process is not responding. 
Disconnect the wheel and it starts to run fine again. Plug it back in and the game freezes.

Had dxdiag make a thing but I can´t seem to attach the file anywhere.. And yes I know the wheel is old.

Edit; So far I've tried:
-verifying game files
-deleting settings and verifying then running game
-deleting game exe, verifying and running it
-reinstalling the game
-resetting wheel to default parameters/calibration
-reinstalling device drivers
Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...