Jump to content Jump to content

[SOLVED] Massive imput stutter with t500rs


Recommended Posts

Hey Everybody.
I've enjoyed my time with dirt rally so far, but about 85 hours in i ran into my first gamebreaking issue, basically my inputs just cut randomly for no apparent reason, its not a performance problem as i am pretty much always at around 120 to 144 fps with no drops, hence the title, in the menu and in stages, in the menu sometimes keys also get stuck, but all of this only happens when my t500rs is plugged in.
Here is a video i did showing my issue pretty well: https://youtu.be/XcyGoEdEIwo
i'll now do the quick bug report and post a brick of additional inf down below

System Spec
Silverstone raven rv03
Corsair HX850 80+ silver
Asrock EXTREME 6
Noctua nh-d14
Intel I7 3820@ 4,4 ghz
Asus Xonar D2/PM
Gskill ripjaws Z 4*4 go 2133 mhz
Gigabyte windforce gtx 970 g1 2x sli
Western digital black 2 tb
Plextor 128 gb ssd
Windows 10 pro 64 bits
all drivers up to date

Qpad MK80
Logitech g500
Audio-technica ATH-AD700X , beyerdynamic dt 770 pro
BenQ XL2420T
Iiyama Prolite GB2488HSU
Thurstmaster t500rs + 458 gte rim
Fanatec Clubsport Pedals v2 + tilton pedals pads
Thrustmaster Th8rs
DSD Short Throw Pro Sequential Shifter
Fanatec Clubsport Handbrake

Steps to reproduce
all game modes , all stages , all cars

Your recent history of races 
Gave the 208 on lydden hill a try , as well as the manta on a welsh stage ,i cant for the life of me remember which one though

Which stage were you within the championship\custom event?
I think it was a monaco stage , i cant really remember as i started having this issue at least 3 weeks ago

What were you doing specifically when the crashed occurred?
Doesnt apply

How long was your current session?
I just started it

Which graphics preset were you using?
Tried all of them, to no avail

here is some more detail

This started happening one day for no apprent reason ,and on dirt rally only, assetto corsa and rfactor 2 work fine, at the time i was running windows 8.1 , i tried pretty much anything i could think of to fix this issue:
-tried all the workarounds i could find on the web
-checked integrity of the files on steam
-did a full reinstall with all traces of dirt rally wiped from the computer
-tried with my cpu overclock and without it
-tried with and without multithreading
-tried with and without sli
-tried installing the game on all my different drives
-closed all software that could possibly interfere with the game (i.e msi afterburner and co)
-checked thoroughly for any malware, found none
-rolled back wheel, pedal, audio and video drivers
-tried with only the t500rs plugged in, nothing changed
-tried with all peripherals but the t500rs plugged in, using a xbox one pad to steer , this fixes it, which means something with the t500rs isn't checking out, so i tried other games with it but i had no issue

During this time windows 10 came out, so i did a fresh install of it hoping this would fix the issue , but you are reading this , so clearly it didn't, and i am at wits end, its been three or four weeks now and i just want to try the worldrx update !

Thanks for slogging through the post and i hope there'll be a fix for this.

Link to post
Share on other sites
  • 5 weeks later...
Hey guys ,
So after almost 2 month of trying out absolutemy everything i could think of i finnaly found the solution to this issue, the troublemaker was my usb hub , even though only my keyboards and mice are plugged into it it seemed to confuse the game big time, with the hub unplugged the game works like a charm, hope this helps other people that face a similar issue !
Now i'm of to finally bloody try the rallycross update(s).

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...