Jump to content Jump to content

PS4 - Sponsors intermittently appearing on race suit in Ranked MP


Recommended Posts

Recently (after patch 1.18 was released I think), I noticed my character having my car sponsors appearing on my race suit, helmet, gloves etc. when customising the character, and I don’t think they appeared before that.

I play a lot of ranked MP - sometimes when on the podium, these sponsors on my suit are shown, other times not.

Have I got a bug? If you’re on PS4 what are your experiences of this?

Edited by Monzie83
Link to post
Share on other sites
  • Monzie83 changed the title to PS4 - Sponsors intermittently appearing on race suit in Ranked MP

This whole area of the game on Ps4 has been bugged since release, it's not likely to be a priority to fix now. Even the colours are wrong still, we're talking a year into the cycle. 

I have no idea if they're supposed to show in ranked MP or not? Usually they don't, a couple of times I've seen them on my suit only, so I assume that was a glitch. 

I don't see why they wouldn't as they at least add some detail to the suits but alas, no idea. 

They should show when customising a character, as that could be for career or MyTeam etc. and I believe that's as designed, but as you noted even that is inconsistent, sometimes it does sometimes it doesn't. 

Let's hope it's working properly for 2021. 

Edited by KNT2011
  • Thanks 1
Link to post
Share on other sites
20 minutes ago, KNT2011 said:

This whole area of the game on Ps4 has been bugged since release, it's not likely to be a priority to fix now. Even the colours are wrong still, we're talking a year into the cycle. 

I have no idea if they're supposed to show in ranked MP or not? Usually they don't, a couple of times I've seen them on my suit only, so I assume that was a glitch. 

I don't see why they wouldn't as they at least add some detail to the suits but alas, no idea. 

They should show when customising a character, as that could be for career or MyTeam etc. and I believe that's as designed, but as you noted even that is inconsistent, sometimes it does sometimes it doesn't. 

Let's hope it's working properly for 2021. 

Seems like inconsistent behaviour is normal - wanted to make sure it wasn’t only me.

As you say, hopefully it will be sorted in 2021.

  • Agree 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...