Jump to content Jump to content

Thrustmaster Force Feedback Issue Master Thread


Recommended Posts

The recommended fix of complete uninstall then new driver install has worked for me as well. Still think it’s a bit much hassle for a new game but nothing’s perfect.

  • Agree 1
Link to post
Share on other sites
1 hour ago, ollys101 said:

The recommended fix of complete uninstall then new driver install has worked for me as well. Still think it’s a bit much hassle for a new game but nothing’s perfect.

Still think this is a driver install issue.

Windows 101 is to install/uninstall/upgrade in an administrative account and then should work fine without any elevation.

Mind you, security 101 says don't use an administrative account when using the machine except when administering.

Link to post
Share on other sites
  • thrustmaster T300 no FFB
  • Report Code : none
  • Platform : STEAM PC
  • Game-mode : all 
  • tried 
  1. restarted PC alot
  2. restarting game several hundred times
  3. reinstalled game
  4. verified integrity of game
  5. reinstalled thrustmaster t300 drivers
  6. updated firmware to latest version 0.33
  7. tried every USB port on PC 
  8. updated drivers for USB ports on PC
  • How do you make the problem happen? I start the game as soon as the game starts to load FFB is shut off.... i did try reloading game with t300 set to PS4 mode and it did not turn off FFB it stayed on the whole time of loading however it is not possible to use the wheel in ps4 mode.. its like the game is thinking PS4 mode is PS3 mode and visa versa
Link to post
Share on other sites

Ok so I recently bought the T80 wheel and pedals and it turns out it dosen't have force feedback available. I downloaded that 1 single driver and that was it, my wheel worked, pedals also worked but fb was absent. So I did some research and it turns out it did not have fb installed in the wheel.

Link to post
Share on other sites
  • Administrator

Update here, as I've been testing the FFB on my TMX and got back some much improved results. 

To update, its 2 fold. You need to update your firmware AND your drivers. You will need a PC for this.

Updating to Firmware 15 is critical. If you don't know if you have this, go to Start > Control Panel > Devices and Printers > Wheel > Right Click > Game Controller Settings > Properties. You'll see this screen:

image.png

Make sure you are updated to the latest Firmware. To find this, visit here: https://support.thrustmaster.com/en/cat-wheels-en/ and select your wheel, and a yellow toolbar comes up telling you the latest firmware.

Once this is completed, update drivers too. 

Having the latest firmware and drivers is a massive help, and resolved the issue my side.

 

Link to post
Share on other sites
  • Administrator
1 hour ago, Jserox said:

First time launched the game the other day i had ffb but it was very weak even on max in gam settings and now there is none at all

Hi @Jserox , please read the above post.

Link to post
Share on other sites

No force Feedback Thrust Master TMX

  • No Force feedback in any mode
  • SJHR-BBDG-GVAC-CSJE
  • PC (steam)
  • All of them (Report code from time trials)
  • Offline
  • Update drivers, firmware, reinstalled FF, restarted PC, tried all suggestions above, nothing works so far

 

Nothing has solved my problem yet, still would really appreciate assistance 

Untitled.png

Edited by KaapoXII
Link to post
Share on other sites

I have the Thrustmaster TS-PC and also the FFB problem.

I've already tried all the suggeestions posted above and it still does not work.

 

  • When I race in-game, there is no force feedback with my Thrustmaster TS-PC Wheel.
  • Report Code: XXJA-CCPA-ESES-JMMG
  • Windows 10, fully-updated
  • All game modes
  • Offline
  • Offline
  • Updating Thrustmaster firmware and drivers, making sure all other USB peripherals were unplugged. Tested FFB in other games like F1 2019 and 2020, AC, ACC, and so on. Also tried all the other suggestions who have worked for some of the other guys.
  • No video, since the problem is with hardware
  • Load into the game, go into any game mode with a Thrustmaster FFB wheel enabled, and there is no FFB presented through the wheel.
Link to post
Share on other sites
4 hours ago, MattE said:

I have the Thrustmaster TS-PC and also the FFB problem.

I've already tried all the suggeestions posted above and it still does not work.

 

  • When I race in-game, there is no force feedback with my Thrustmaster TS-PC Wheel.
  • Report Code: XXJA-CCPA-ESES-JMMG
  • Windows 10, fully-updated
  • All game modes
  • Offline
  • Offline
  • Updating Thrustmaster firmware and drivers, making sure all other USB peripherals were unplugged. Tested FFB in other games like F1 2019 and 2020, AC, ACC, and so on. Also tried all the other suggestions who have worked for some of the other guys.
  • No video, since the problem is with hardware
  • Load into the game, go into any game mode with a Thrustmaster FFB wheel enabled, and there is no FFB presented through the wheel.

You might need to try going into your device manager - human interface devices - than completely uninstall your wheel so that the PC does not recognise it. Do a reboot of your PC then plug the wheel back in so that it does a download of the latest firmware and then do the latest driver download through the Thrustmaster website. This worked for me so hopefully with work for you as well.

  • Like 1
Link to post
Share on other sites

Ok so an update on my end i tried again a uninstall and reinstall of my wheel drivera2and it bloody worked lol..

 

I basicly uninstalled wheel drivers and did not remove wheel usb rebooted reinstalled with latest firmeware an happy to say ita now working.. There is another issue iv found with the mclaren lol.

  • Haha 1
Link to post
Share on other sites
3 hours ago, ollys101 said:

You might need to try going into your device manager - human interface devices - than completely uninstall your wheel so that the PC does not recognise it. Do a reboot of your PC then plug the wheel back in so that it does a download of the latest firmware and then do the latest driver download through the Thrustmaster website. This worked for me so hopefully with work for you as well.

Edit: so far no luck 😔

Edited by MattE
Link to post
Share on other sites
  • A detailed description of the issue.
    Simply, no force feedback at all.
  • Report Code
    ?
  • Platform?
    PC
  • Game-mode?
    Every single-player game mode
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
  • [ONLINE] Were you the host?
  • What troubleshooting have you tried? Please list everything you tried.
    tried updating my wheel' firmware. did nothing
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
     
Link to post
Share on other sites
  • Administrator

Hi all,

When reporting, can you add screenshots of your control panel of the wheel, so I can confirm your on the latest firmware.

Link to post
Share on other sites

I am using a thrustmaster TX servo base with the f1 add on, playing on a Xbox series x. On both MyTeam and Braking Point races, my wheel has either lost the strength of the force feedback, or the force feedback has turned off completely. I have tried restarting the game and the issue is resolved for a few minutes, only to return after a few laps each time. 

Report Code: XSAJ-EGHA-GBER-GBJG

Link to post
Share on other sites
  • Codemasters Staff

@samlh44 - Merged into this thread. Please note that Xbox users will need to update the firmware on their wheels to be compatible with the latest Xbox system software used in F1 2021. See the recommended posts in this thread for more info. 

Link to post
Share on other sites
  • No FFb with the Thrustmaster TMX. Updated the firmware, restarted the pc and there is still no FFB.
  • HCHE-THXC-PRPJ-MMMG
  • PC.
  • TT
  • Offline
  • Offline
  • Firmware and driver update. Unplug - wait for disconnect - plug in worked for me, but that's not a viable solution.

BUG THRUST.PNG

Link to post
Share on other sites

@HooI've made sure that all drivers and firmware are up to date and have restarted the game to come back to the same issue. I have run the wheel on many ofher games (including f1 2020) to see if the hardware was the issue, and have found no problems. However I am yet to play more than 30 minutes of the new game without running into the problem. 

Link to post
Share on other sites

well i thought id solved it but 

 

  • thrustmaster T300 no FFB
  • Report Code : none
  • Platform : STEAM PC
  • Game-mode : all 
  • tried 
  1. restarted PC alot
  2. restarting game several hundred times
  3. reinstalled game
  4. verified integrity of game
  5. reinstalled thrustmaster t300 drivers
  6. updated firmware to latest version 0.33
  7. tried every USB port on PC 
  8. updated drivers for USB ports on PC
  • How do you make the problem happen? if i tab out of the game and tab back in i loose all FFB untill i restart the game 
Link to post
Share on other sites

FFB has been broken since the Thursday update. I either get no FFB at all or it cuts in and out, making the game unplayable. Works with Iracing and F12020

  • thrustmaster Servo base with F1 add-on
  • Report Code : MMKX-MBHH-KMTJ-MRMG
  • Platform : STEAM PC
  • Game-mode : all 
  • Worked for one day till update ; uninstalled firmware and drivers then reinstalled. 

 

 

Link to post
Share on other sites
27 minutes ago, Ghoose13 said:

Hello, the firmware is up to date but the problem continues (even though it seems less regular than before the update). Report code : GAPP RASX THDR GTEG. Thanx for the help.

I can't be anymore help to anyone on this thread as I can't replicate. I never had the FFB issue in the released game. Before I installed the game my firmware was updated. Try deleting your controller profiles with the wheel disconnected. Then restart the console, plug the wheel and relaunch the game. There was a problem in beta and it was fixed.

I don't have a console to replicate issues there either. It works on PC as expected, given caveat is that it isn't active until you get control and make steering input (known issue in previous games, never really fully fixed AFAIK). 

7 hours ago, DoitToitLars said:

FFB has been broken since the Thursday update. I either get no FFB at all or it cuts in and out, making the game unplayable. Works with Iracing and F12020

  • thrustmaster Servo base with F1 add-on
  • Report Code : MMKX-MBHH-KMTJ-MRMG
  • Platform : STEAM PC
  • Game-mode : all 
  • Worked for one day till update ; uninstalled firmware and drivers then reinstalled. 

The Thursday update did cause a 'first run' condition (reloaded dependencies). I suggest this is where the issue is. Dependencies may well be broken in your installation. Try the W10 MCT and reinstall keeping apps and files?

Link to post
Share on other sites

@steviejay69I think anyone who plays on a thrustmaster base and has the sf1000 rim don't have any issues with ffb?

i own said rim and not had 1 issue with ffb on my TX base so its probably something with the new api implemented to drive the screen and leds that older rims or bases without the sf1000 rim dont like 

Link to post
Share on other sites

I have had an issue with the force feedback on my tx base since the patch at the end of day one. I have since updated all of the drivers and firmware and everything is as up to date as it can be and yet the issue persists. Whilst the FFB hasn't completely dropped out (as it did yesterday), it remains at a very low and hardly noticeable level, even when turned up to the highest setting in game. I am racing on the xbox series x and this has now occurred in Braking Point, My Team and Time Trial. 

Report code: CSHR-VKCJ-BAVV-GTJG

  • Agree 1
Link to post
Share on other sites
  • steviejay69 changed the title to Thrustmaster Wheels No Force Feedback
  • BarryBL locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...