Jump to content Jump to content

Thrustmaster Force Feedback Issue Master Thread


Recommended Posts

I found the problem/solution for me. Maybe it helps some of you too.
 

I just started the game like i always does. Double-click on the desktop icon, FFB resistance is noticeable and i wanted to skip the intro etc. it didn't worked because the game tab wasn't selected but still in full screen. As i clicked with the mouse in the window to be able to skip/press any button to get to the game, the FFB was gone and didn't came back.

I exited the game and startet again but this time the game tab was selected and as i clicked any button to get to the game, the FFB worked as long as i played the game.

I recreated it a lot of times and for me it worked all the time. Out tabbing was not a problem, pressing any button on start up (keyboard or Wheel) wasn't a problem etc.

 

I hope this helps some of you and some of the dev's can figure it out why this occurs and fix this.

Link to post
Share on other sites
  • Administrator
On 7/17/2021 at 11:25 PM, levosz123 said:

Thanks for the advice i will try BUT i'm pretty sure the issue is with the game. I don't have this issue with any other games (raceroom on pc, f1 2020, acc)

Have you updated your firmware and drivers via a PC @levosz123. This is key to fixing the issue.

Link to post
Share on other sites
  • Administrator
On 7/13/2021 at 3:44 AM, Zephyr43 said:
I have the same issue. Have tried everything posted here: Fully updated drivers and firmware, unplugged and plugged back in, no alt-tab etc. but i still dont have any FFB.

Im on PC with a Thrustmaster TX

Please add a image of your Thrustmaster control panel @Zephyr43 to confirm you are on the latest firmware.

Link to post
Share on other sites

Im on xbox one and i updated my wheel, but it was before on latest firmware...i have the trustmaster tmx...so i can confirm, that it is not helping with force feedback at all...every 45 minutes its gone and only with reconnecting its working for next 45 minutes...and im pretty sure its a game issue...tried acc and other racing games for hours and i had never an issue!!!!!!

 

2021-07-16.thumb.png.6e138e83988d18d48f1df237c8ca7ea8.png

Edited by MarcWoitschoell
Link to post
Share on other sites
16 minutes ago, MarcWoitschoell said:

Im on xbox one and i updated my wheel, but it was before on latest firmware...i have the trustmaster tmx...so i can confirm, that it is not helping with force feedback at all...every 45 minutes its gone and only with reconnecting its working for next 45 minutes...and im pretty sure its a game issue...tried acc and other racing games for hours and i had never an issue!!!!!!

It’s not the Firmware that’s causing the issue it’s the new Driver for 2021. You need to update the driver not the firmware.

Link to post
Share on other sites

I did the update and it helped with the force feedback but occasionally it downshifts randomly without me pressing anything and the wheel disconnects also. Anyone else share this issue I have the thrustmaster tx with f1 wheel add on

Link to post
Share on other sites
  • Administrator

Hi everyone,

I just want to provide a update here, and some extra information on reporting this issue.

At this moment in time, we've been unable to reproduce this issue on any wheel with the correct firmware and drivers installed. This has been tested first-hand and the FFB since my firmware and driver update has been fully restored. When reporting if you are experiencing this, please:

  1.  Specify Platform
  2.  Specify wheel
  3.  Check my recommended post on how to update your drivers and firmware
  4.  Add a screenshot of what you see on your control panel like:

image.png

This will help us in our investigation. I understand that for console players its unusual to have to connect to a PC to update your drivers and firmware too, but please attempt to do so.

Link to post
Share on other sites
  • Administrator
On 7/18/2021 at 2:41 PM, xXEL1M1NATORXx said:

When thousands of people complain about the same issue, do you not think it’s common sense to go to the devs and say hey plug a thrustmaster wheel in and see if the dam thing works or not? 
Obviously, and very clearly that you don’t have any common sense. 

@xXEL1M1NATORXx I have a Thrustmaster TMX , so I'm one of the testers for the devs. I've made them aware, and I'm part of the group testing it. 

No need to be aggressive on this. This is of critical importance and we are working on it.

Link to post
Share on other sites
  • Administrator
On 7/15/2021 at 11:52 PM, KaapoXII said:

No force Feedback Thrust Master TMX

  • No Force feedback in any mode
  • SJHR-BBDG-GVAC-CSJE
  • PC (steam)
  • All of them (Report code from time trials)
  • Offline
  • Update drivers, firmware, reinstalled FF, restarted PC, tried all suggestions above, nothing works so far

 

Nothing has solved my problem yet, still would really appreciate assistance 

Untitled.png

@KaapoXII click 'check for update' please and check if you need a update.

Link to post
Share on other sites
  • Administrator
2 minutes ago, MarcWoitschoell said:

yes thats it...after 45 minutes its away...a friend of mine has the thrustmaster tx with same problem, he has the latest version aswell

I've added this directly into the discussion for the developers now. Thanks for the feedback, appreciate you.

Link to post
Share on other sites

@ BarryBL

Cześć.

 

Barry, moje miejsce jest dokładnie takie samo jak ludzi powyżej. Po 45 minutach gry (testowałem sondę czasu) ffb wyłącza się, ponowne uruchomienie kierownicy pomaga.

Mój przyjaciel ma dokładnie ten sam problem.

Platforma Xbox seria X

Thrustmaster tmx

 

 

 

received_142400144638093~2.jpg

Edited by Verqlan
Link to post
Share on other sites
1 hour ago, BarryBL said:

Hi everyone,

I just want to provide a update here, and some extra information on reporting this issue.

At this moment in time, we've been unable to reproduce this issue on any wheel with the correct firmware and drivers installed. This has been tested first-hand and the FFB since my firmware and driver update has been fully restored. When reporting if you are experiencing this, please:

  1.  Specify Platform
  2.  Specify wheel
  3.  Check my recommended post on how to update your drivers and firmware
  4.  Add a screenshot of what you see on your control panel like:

image.png

This will help us in our investigation. I understand that for console players its unusual to have to connect to a PC to update your drivers and firmware too, but please attempt to do so.

Hello.

I am having pretty much the same issue as most other people where I have absolutely no FFB in F1 2021 whereas it is prevalent in other games.
I am on PC and I use a Thrustmaster Tx racing wheel with Ferrari f1 wheel add-on

Many thanks for reading and possibly responding.
image.png.8b326b8f75593892299de8a97993197c.png

Link to post
Share on other sites

@BarryBLsimilar thing happened on f1 2020 where users with the tsxw/tspc bases with the ferrari 488 rim had no working ffb after patch 1.18 and then when driver 2022_ttrs_1 and updated firmwares were released for the sf1000 rim their ffb worked again.

i have had working ffb when using the sf1000 and tx base since launch as has @steviejay69 with same rim but different base, where as nearly everyone i know plus other users on this forum have had nothing but issues trying to get ffb to work at all even with the correct  drivers and firmwares and where i can i have been advising people of how to try and get it to work for them with small success 

This is a suggestion for the dev team, maybe in game we need a on/off toggle for the thrustmaster api that drives the lcd display and leds on that rim similar to the sli manager (for leds) and fanatec toggles which toggles between the new thrustmaster api and the old version from f1 2020 pre patch 1.18, also different game/sim but similar happened with iracing where ffb wouldn't work initially with the new Thrustmaster api but difference here was in a .ini file a setting could be changed to disable the screen and leds and got ffb to work again, this got fixed recently tho

Edited by cearp8858
Link to post
Share on other sites

Hello,

New development for the issue, today. Just got on 20 mins ago, and was sitting in my garage in My Team for quali. I pressed the Xbox button to go to the Xbox menus, went back into the game, and my wheel very strongly steered to the right, constantly banging itself off of the max rotation. Tried driving afterwards, and lost ffb. Same thing happened after I restarted the wheel, drove a lap, went back to the pits, and reopened the Xbox menu. 

Error code: RTVK-VSHE-CTRR-GDEG

Edited by Poorsche918
Link to post
Share on other sites

I'm on Xbox, tx updated to the last version yesterday trying to fix this. At first the ffb seem to work fine but as I play for 10-15 minutes it suddenly dissapear or stays with half strength.

Edited by PiterT2
Link to post
Share on other sites
  • A detailed description of the issue. - after I would say 40minutes the force feedback on the T300rs is completly gone. At first I thought it is because of the well known overheating problem from the base engine, but if I start Gran Turismo, F1 2020 all is perfectly fine. Therefore the problem can't be caused by overheating.
  • Report Code : EBDX-JHAA-VKSG-BASC
  • Platform? PS5
  • Game-mode? Every game mode
  • What troubleshooting have you tried? Please list everything you tried. : I updated the Firmware from the Base to the actual V33, I have forced the wheel by the Forced Cooling mode to cool the engine all the time. You can workaround the problem if you pause the game and wait 10minutes... But I think this can't be the solution to this.
  •  
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible. : Start a random race, 50% is enough and Drive. After 20-40 minutes the force feedback is gone

PXL_20210719_143627183.jpg

Link to post
Share on other sites

Hello together,

besides the no FFB problems with Thrustmaster wheels I would also add that there are some other serious FFB/wheel/pedal problems on my side. F.e.: FFB feels completely different between time trial and normal races (same setup), I had to dial down on track, rumble strip, off track settings to 0 because otherwise the FFB wouldn't let me turn the car. Furthermore the steering rotation (I tested everything between 300-360 degree) also feels very off. On top of that I've noticed that the pedal inputs seem to be overly sensitive and/or not accurate. My wheel is not overheating and to be sure I tested the FFB/wheel rotation/pedals in Automobilsta 2, Assetto Corsa Competizione, F1 2020 with no such issues at all. Is this a known issue? Are there other drivers with the same problems?

  • Thrustmaster T300RS GT including the pedals
  • Report Code : PESP-VXMD-XKAT-RVMG
  • Platform? PC
  • Game-mode? Every game mode
  • What troubleshooting have you tried? Upgraded the firmware to v33 with the latest driver, tested the ffb/wheel/pedals in other sim racing games and f1 20202307760_ThrustmasterSoftware_1.jpg.799b0a19699526a7c0dda7a64a290b16.jpg

Thrustmaster Software_2.jpg

Link to post
Share on other sites

well I've tested this a bunch, for whatever reason, for me this is perfectly reproducible every single time with my wheel on it's latest drivers and firmware

FFB DOESN'T work: plug my wheel in, turn it on, launch the game and skip the intros and navigate menus with my wheel, steering works fine but I have no FFB response

FFB still DOESN'T work: plug my wheel in, turn it on, launch the game but skip the intros and navigate all menus using my keyboard, same as above, wheel is functional but no FFB

FFB DOES WORK: I make sure the game is closed, power off my wheel, I launch the game, navigate into a race and then power my wheel on, after the calibration I can steer and I have full FFB, does not seem to drop after time but I can't say for sure as I haven't played for more than 30 minutes at a time

 

Thrustmaster T150 with control panel attached, Windows 10 21H1, game fully up to date, dxdiag attached too just in case anything in there might help 

 

t150.png

DxDiag-smt.txt

Link to post
Share on other sites
5 hours ago, smt923 said:

well I've tested this a bunch, for whatever reason, for me this is perfectly reproducible every single time with my wheel on it's latest drivers and firmware

FFB DOESN'T work: plug my wheel in, turn it on, launch the game and skip the intros and navigate menus with my wheel, steering works fine but I have no FFB response

FFB still DOESN'T work: plug my wheel in, turn it on, launch the game but skip the intros and navigate all menus using my keyboard, same as above, wheel is functional but no FFB

FFB DOES WORK: I make sure the game is closed, power off my wheel, I launch the game, navigate into a race and then power my wheel on, after the calibration I can steer and I have full FFB, does not seem to drop after time but I can't say for sure as I haven't played for more than 30 minutes at a time

 

Thrustmaster T150 with control panel attached, Windows 10 21H1, game fully up to date, dxdiag attached too just in case anything in there might help 

 

t150.png

DxDiag-smt.txt 96.45 kB · 0 downloads

360 DOR is the recommended setting.

Can't ID your board correctly, it seems it's an X470 variant (believe it to be X470 GAMING PRO MAX - UEFI MA

There's quite a lot of non-standard equipment on your PC, can you try removing and reintroducing them one by one until you hit the issue? (Oculus, Behringer).

Here are your DCH audio drivers for onboard.

Also non-standard webcam software (DroidCam) please remove using Geek Uninstaller.

Link to post
Share on other sites
On 7/19/2021 at 6:09 PM, BarryBL said:

Hi everyone,

I just want to provide a update here, and some extra information on reporting this issue.

At this moment in time, we've been unable to reproduce this issue on any wheel with the correct firmware and drivers installed. This has been tested first-hand and the FFB since my firmware and driver update has been fully restored. When reporting if you are experiencing this, please:

  1.  Specify Platform
  2.  Specify wheel
  3.  Check my recommended post on how to update your drivers and firmware
  4.  Add a screenshot of what you see on your control panel like:

image.png

This will help us in our investigation. I understand that for console players its unusual to have to connect to a PC to update your drivers and firmware too, but please attempt to do so.

Hi,

Somehow the game is not running in exclusive full screen. So some apps are allowed to 'take' the foreground. This wasnt the case with f1 2020 which i played with the lates (58) FW on my TX servo base. I noticed this behaviour when some notifications came in. Perhaps you arent seeing these bugs in testing because you are running clean win10 installations. 

 

I have to add that a reinstall of the FW and the drivers did fix this. Which doesnt really make sense tbh. The game still doesnt run in exclusive fullscreen which makes it possible for win10 notifications pop-up in the bottom right of the screen. My guess is that these 2 issue's might be related. 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...