Jump to content Jump to content

Equal Performance stuck on two-player career mode Master Thread


Recommended Posts

  • A detailed description of the issue.

 

Equal performance is stuck on two-player career mode, when on standard and expert modes.

 

  • Platform?

 

Xbox Series X

 

  • Game-mode?

 

Contracts - two player career

 

  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.

 

2 players.

AdamComer

THEFLYINGG0AT

 

  • [ONLINE] Were you the host?

 

Yes

 

  • What troubleshooting have you tried? Please list everything you tried.

 

Changing the game to casual fixes the issue.

 

  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 

 

N/A

 

  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

 

Start two-player career mode on Standard or Expert modes. Set it up to have realistic performance. In the lobby it will still say equal performance.

Link to post
Share on other sites
  • A detailed description of the issue.
    • Playing only coop career with a friend and the car performance seems to be stuck on equal although the menu shows realistic car performance.
    • All timings seems to be odd with Haas on P1 and P2 and all AIs driving a similar time.
  • Report Code
    • Currently none, because we're waiting on a fix.
  • Platform?
    • PC
  • Game-mode?
    • Coop 2-Player Career
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    • 2 real players, 18 AIs
  • [ONLINE] Were you the host?
    • Yes
  • What troubleshooting have you tried? Please list everything you tried.
    • Changing the race style to "Casual" rather than "Standard" or "Expert" seems to fix the issue, but than you have to stick with the default settings. 😞
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    • None. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    1. Start a 2-Player Coop Career.
    2. Set everything up with race style set to "Standard" or "Expert".
    3. Drive a Qualifying or Race and notice the odd timings.  
Link to post
Share on other sites
  • Description:
    I can't change my career mode back to realistic. It randomly changed to "Performance mode" in round 2.
  • Report Code: -
  • PC
  • Mode:
    Career
  • [ONLINE] The amount of players in your session?
    2
  • [ONLINE] Were you the host? No, but he couldn't change it either.
  • What troubleshooting have you tried? Changing the settings.
  • Any screenshots or video of the issue?
    https://i.gyazo.com/e6602ba41cb46bc7212bc641153bc2d8.png
  • How do you make the problem happen?
    We quit a session and tried to start a new one.


    Is there a way to work around this bug?
Link to post
Share on other sites
  • Hoo changed the title to Equal Performance stuck on two-player career mode

I read on Reddit that the bug won't happen if both players do a time trial with realistic performance before joining the coop lobby, but I couldn't check this for now as my coop Mate isn't awake yet. 😄

Will update this post as soon as I tested this. 

//Edit:
Didn't worked, so we need to wait for a fix from Codemasters. 😞

Edited by xMaoam1123
Edited as promised.
Link to post
Share on other sites
  • A detailed description of the issue.
    • In the 2 player career mode lobby screen, equal perfomance is shown on the menu.
    • In the game the laptimes make no sense with some of the slower cars like haas having pole in qualifying
  • Report Code
    • BACP-KMPM-RSEG-VMMG
  • Platform?
    • PC
  • Game-mode?
    • 2-player career mode
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    • 2 players including me
  • [ONLINE] Were you the host?
    • Not at first, but the same issue happens when I'm the host
  • What troubleshooting have you tried? Please list everything you tried.
    • Tried to leave and join
    • Tried switching host
    • Tried making new 2player career mode lobby
    • Tried to join timetrial with realistic perfomance, and then join 2 player coop lobby
    • (New) Having casual mode in the settings instead of standard or expert will put it in realistic performance
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    • Make a 2 player career mode, and in the lobby screen the menu shows equal performance. In the game the laptimes will make no sense as if the cars are equal.
Edited by NativeLog
  • Agree 1
Link to post
Share on other sites
23 minutes ago, TheHellblazer82 said:

We are also having the same issue on PS5. It switches to realistic if we put ourselves in casual mode, but equal performance on standard and expert modes. Surely this should be the other way around?

I can confirm this works. Putting it to casual mode instead of standard or expert in the settings, will change it to realistic performance.

Link to post
Share on other sites
  • @BarryBL
  • Unless in casual settings in coop career you will always have equal performance cars which should not be the case.
  • XPST-BGTG-EKBP-GTEG
  • Xbox
  • Online career
  • What troubleshooting have you tried? Restarting a new career, loading in and out of the game and career, changing host, restarting consoles.
  • How do you make the problem happen? Go into coop career lobby invite your friend and have it on any setting except casual. You can repeat this with multiple saves and it still has the same problem.

Edited by Jammydodger1401
Mentioning staff member so hopefully they can help
  • Agree 1
Link to post
Share on other sites

+2 for PC who are having this issue. 

Same symptoms as already noted about, it seems to be random when you log in to your co-op session if you get realistic or Equal. But more often that not equal.

Ive tried switching to casual and back to expert but it just switches back to equal performance.

Also tried backing out into the main menu and back it, and one once occasion showed realistic performance but when into FP1 and it was equal again (which was then seen once going back to the lobby)

From what i can gather there is not even a workaround we can apply in the interim until this is patched.

Link to post
Share on other sites

so this was an issue for me and my mate to begin with but haven't suffered with it since Wednesday. This is our 3rd session and were into our 4th race. We found that when we restarted the game that it fixed the issue so this means on xbox clicking the home button and making sure to shut the game down fully and reload it. If anyone finds this also a workaround then say so for others cos i think quite a few are having this issue by the looks of this thread and others. I do have a screenshot of us getting the realistic performance setting on Expert as well. All of me and my mates co-op has been completed on Realistic performance and the results have been as they should

Link to post
Share on other sites
  • A detailed description of the issue.
    • Playing coop career with a friend and the car performance seems to be stuck on equal although the menu shows realistic car performance. Also - The first race at Bahrain was ok - In Spain, we had Mazapin at P1, with nearly everyone except us, finishing within 0.2s in Quali. Azerbiajan, same thing happens again.
    • Cant seem to change anything
    • Drive out only in Practice sessions - No Flying lap option? Is that by design?
  • Platform?
    • PS4
  • Game-mode?
    • Coop 2-Player Career
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    • 2 real players, 18 AIs
  • [ONLINE] Were you the host?
    • Yes
  • What troubleshooting have you tried? Please list everything you tried.
    • Tried restarting but didnt help. 
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    • None. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    1. Start a 2-Player Coop Career.
    2. Set everything up with race style set to "Standard" or "Expert".
    3. Drive a Qualifying or Race and issues stated above appear. 
Link to post
Share on other sites

Had this occur this morning so it must still be an issue, although random.

 

This seems to occur more often than not when the lead driver in the team joins the session first, they will initially see realistic performance, but it will switch to equal when the 2nd player joins.

Possible workaround: Have both players back out of the session, the lead drivers first, then rejoin and it seems to go back to realistic.

Like all the possible fixes though this is just what i have seen so far on 2 occasions its fixed it, so others may need to test to see if this workaround occurs for them too, until codies have a permanant fix.

Link to post
Share on other sites
  • Administrator

Confirn @xMaoam1123, this is a offered workaround

After this, the lobby will now have Realistic Performance, which should be visible in the bottom left of the UI when in the 2P career lobby, and when you resume the career the AI performance is no longer Equal.

To make sure you don’t turn a Realistic Performance mode Two Player career into Equal Performance, don’t exit from an Equal Performance multiplayer lobby and go into a Two Player Career lobby (as host).

 

Link to post
Share on other sites
  • BarryBL changed the title to Equal Performance stuck on two-player career mode Master Thread
  • BarryBL pinned this topic
  • A detailed description of the issue.

race two in 2 player career, we saw haas and Williams very high up the grid. This also affected the placing of many other teams. I can confirm all times were set on softs. This was continued within the race where the whole field had an incredibly high performance and drove away (we were in alpine) previously race we finished in P7. 

  • Report Code

XSTM-JHVM-JGTG-BASC

  • Platform?

PS5

  • Game-mode

Two player career

  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.

two

  • [ONLINE] Were you the host?

Yes

  • What troubleshooting have you tried? Please list everything you tried.

we had to quit the mode, and restart the game completely.

  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 

Yes

  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

run a long practice programme, retired from session, skipped sessions 2,3 and raced an 18 minute qualifying.

 

the performance was happening during and was not adjusted at the end of the session for example one point mazepin was on pole for a long period of time 

347E7513-40FD-4DD9-81CA-9459BB8EC135.jpeg

EAA9A9C2-F21A-43E1-A3D3-5E0AFDECA036.jpeg

Link to post
Share on other sites
  • BarryBL unpinned this topic

i accidentally deleted the screenshot, but im sure ill be able to replicate it, this changing of settings that helps fix the bug also bleeds across to a myteam save:

was in coop career and changed the damage and damage rate settings and it changed it on myteam to the same setting it also (im guessing because you cant flashback on multiplayer)

changed my flashback settings so that iwasnt able to use them.

this should definitely be looked at as to why this is happening across gamemodes 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...