Jump to content Jump to content
F1 2021 | Online Services Update 11:00AM UK Time | Expected to last no longer than 2 hours ×

What was your last purchase


Recommended Posts

  • Moderator
On Saturday I decided to finally order myself a new phone, and it arrived this morning! I bought an iPhone 5c in white and I absolutely love it. It cost me £80 and it's £20 a month for 1GB data with 4G internet, plus unlimited minutes and texts, with EE.

It's so good, just as fast as my iPad and I'm actually posting from it now as it's that good. Doing speed comparisons with my old 3GS, this is honestly over 10x faster. And the 4G internet is crazy fast! So pleased I bought it.
Link to post
Share on other sites
Haha, I fan, the one and only :p 

Nah out of the 9 Dead Silence fans I bought before, 5 of them have developed clicking bearings already. So I got some SP120's a few days ago and I love them. To me they're quieter and feel slightly higher quality. Eventually most of my stuff is gonna be Corsair I think :p 
Link to post
Share on other sites
Haha, I fan, the one and only :p 

Nah out of the 9 Dead Silence fans I bought before, 5 of them have developed clicking bearings already. So I got some SP120's a few days ago and I love them. To me they're quieter and feel slightly higher quality. Eventually most of my stuff is gonna be Corsair I think :p 
yeah I think the fans in my system are Corsair as well
Link to post
Share on other sites
I hope you get enough cooling with those fans on the aio cooler bud. The ones that come with it use very high rpm fans and is the only way it beats the best air coolers. When I was using mine the noise was louder than an air cooler. The radiator is designed for high rpm fans because of the fpi, it's needs more pressure to push the air through. It's what actually drove me to a custom loop, as I wanted one with low fpi so I could use lower rpm fans. Static pressure is the most important factor, and the ones that come with it are 3.1 or something on max, whereas the ones you bought are 1. Something 
Link to post
Share on other sites
Hughesy said:
I hope you get enough cooling with those fans on the aio cooler bud. The ones that come with it use very high rpm fans and is the only way it beats the best air coolers. When I was using mine the noise was louder than an air cooler. The radiator is designed for high rpm fans because of the fpi, it's needs more pressure to push the air through. It's what actually drove me to a custom loop, as I wanted one with low fpi so I could use lower rpm fans. Static pressure is the most important factor, and the ones that come with it are 3.1 or something on max, whereas the ones you bought are 1. Something 
Well, I'm gonna give it a try bud and see how it goes. If it is too loud though then I'll send it back and get a refund in the first 14 days :) Should be alright on the fans though, I got a High Performance one on my current cooler and even though it's an entirely different thing it's still quiet :) The other PWM I bought to go with it is a High Performance as well and the Static Pressure on both is 3.1.

Just an experiment for now I'd say, if I'm not happy with the performance-volume ratio then I'll go back to air cooling quick enough to get my money back :)
Link to post
Share on other sites
  • Moderator
mike96 said:
Ι believe this problem has been reported again earlier this year.. and I believe it was you again Matt :p
And I'll keep mentioning it until it gets better! :p It has definitely got better, I mean, at least I can now post  using my iPad (the cursor wouldn't pop up at the start).
Link to post
Share on other sites
Hughesy said:
This stuff is seriously good

http://highlandspring.com/images/993/full/png

Oh ffs, the forum is rubbish on an iPad. Can't embed images, changes the style of the text whenever you use caps lock on a 'b' or an 'i', slow, ugh.


I have the same problem with my IPad bud...
Same here on PC I can get the forum to show vids now but I still can't get the forum to do pics or embed things though
Link to post
Share on other sites
Hughesy said:
Another reason not to buy crApple ;) Video and picture embedding works fine on my phone and tablet. Both Android :p 
Knew you were going to say that, anyway look at the post above by SJ  :p Doesn't work on my Nexus 7 and the last time I checked that was borDroid hehe. I mean Android  o:)
Works on my Nexus 7 :p 
Link to post
Share on other sites
  • UP100 featured this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...