Jump to content Jump to content

F1 2021 pc crashes when using the menus


Recommended Posts

  • A detailed description of the issue

After using the menus for a couple of minutes (sometimes more, sometimes less) the game crashes and i get an egodump report.

  • Report Code
  • Platform

PC

  • Game-mode?

Menus

  • What troubleshooting have you tried? Please list everything you tried.

Updating/reverting graphics cards drivers, updating windows, reinstalling, lower graphics and verifying game files

  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

The problem occurs while using the menus, specifically menus for creating a career, customizing a car livery and also in-race menu (choosing tyre compound)

 

Ive added the DxDiag aswell as the first and most recent crash dump

 

DxDiag.txt crash_dump#794563-20210714-154005-0.zip crash_dump#794563-20210714-213237-0.zip

Link to post
Share on other sites
15 minutes ago, BarryBL said:

Please install the latest drivers @Mharrit 461.92 or later.

I had the latest drivers installed (471.11) and downloaded older drivers to see if it would stop the game from crashing. I have updated my drivers back to the latest (471.11), but the same problem still occurs.

Link to post
Share on other sites
On 7/14/2021 at 9:42 PM, Mharrit said:
  • A detailed description of the issue

After using the menus for a couple of minutes (sometimes more, sometimes less) the game crashes and i get an egodump report.

  • Report Code
  • Platform

PC

  • Game-mode?

Menus

  • What troubleshooting have you tried? Please list everything you tried.

Updating/reverting graphics cards drivers, updating windows, reinstalling, lower graphics and verifying game files

  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

The problem occurs while using the menus, specifically menus for creating a career, customizing a car livery and also in-race menu (choosing tyre compound)

 

Ive added the DxDiag aswell as the first and most recent crash dump

 

DxDiag.txt 108.51 kB · 7 downloads crash_dump#794563-20210714-154005-0.zip 95.27 kB · 1 download crash_dump#794563-20210714-213237-0.zip 135.68 kB · 0 downloads

Can't tell from the dxdiag but latest UEFI BIOS v1l

Delete the ASMedia USB 3.1 driver if you have installed, check the 'Delete the drivers for this device' in Device Manager. Uninstall anything related from Control Panel.

Let WU/inbox driver install, avoid using the ASMedia ports (USB-C and 1x USB 3.1 Gen 2 directly above).

Also DDU and reinstall your GPU driver (471.11 or higher) as it's dumping into the crashdumps.

 

Link to post
Share on other sites
2 hours ago, steviejay69 said:

Can't tell from the dxdiag but latest UEFI BIOS v1l

Delete the ASMedia USB 3.1 driver if you have installed, check the 'Delete the drivers for this device' in Device Manager. Uninstall anything related from Control Panel.

Let WU/inbox driver install, avoid using the ASMedia ports (USB-C and 1x USB 3.1 Gen 2 directly above).

Also DDU and reinstall your GPU driver (471.11 or higher) as it's dumping into the crashdumps.

 

I have done all the different steps successfully, except uninstalling the AsMedia USB 3.1 driver. Every time i uninstall it through device manager it seems to return right after a restart or 5 minutes later. My game still crashes in the same way it did before. 

I have attached a new Dxdiag aswell as my most recent crash dump.

 

crash_dump#794921-20210716-020755-0.zip DxDiag.txt

Link to post
Share on other sites
5 hours ago, Mharrit said:

I have done all the different steps successfully, except uninstalling the AsMedia USB 3.1 driver. Every time i uninstall it through device manager it seems to return right after a restart or 5 minutes later. My game still crashes in the same way it did before. 

I have attached a new Dxdiag aswell as my most recent crash dump.

 

crash_dump#794921-20210716-020755-0.zip 139.12 kB · 0 downloads DxDiag.txt 102.08 kB · 0 downloads

Of course it will. But if you've uninstalled any of the vendor driver packs that can be unreliable in terms of latency, the WU or inbox driver will install. For example, here is my keyboard driver provided by Microsoft.

image.png.be66f243aff21610c8cfda04a3b06978.png

And here is my NVMe storage driver provided by the vendor

image.png.45e2d8e98d445b4e0ba015fb83e60859.png

image.thumb.png.ad955ddf2a1fbc4497f6165c68ed3bcd.png

If you are not using the device (physical ports as highlighted) then it has little chance to introduce latency into your system. The only way to make it disappear is to turn it off at UEFI BIOS level, but after consulting the manual it would appear the only option is to enable/disable ALL USB ports (not desirable) 🙂

The only other thing I've just noticed is your swap file allocation is unnecessarily large. Please ensure the following option is set (automatic swapfile). Start|Settings|System(About)|Advanced System Settings(Advanced|Performance|Settings (FFS Microsoft)

Restart your machine after applying, delete the hardware_settings_config.xml, then relaunch the game.

image.png.938d6261664003cb905335cd87631926.png

 

Link to post
Share on other sites

Also, not sure why your mouse appears as six different entries in your dxdiag. Can you test with another mouse? 🙂

Quote

      Device Name: Model O Wireless
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x258A, 0x2022
        FF Driver: n/a

      Device Name: Model O Wireless
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x258A, 0x2011
        FF Driver: n/a

      Device Name: Model O Wireless
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x258A, 0x2011
        FF Driver: n/a

      Device Name: Model O Wireless
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x258A, 0x2011
        FF Driver: n/a

      Device Name: Model O Wireless
         Attached: 1
    Controller ID: 0x0
Vendor/Product ID: 0x258A, 0x2011
        FF Driver: n/a

 

Link to post
Share on other sites
Posted (edited)
10 minutes ago, RedDevilKT said:

Hey @Mharrit would you be able to try disabling Ray Tracing to see if this helps your issue? 

Hey @RedDevilKT,

Within the games settings I am not able to change ray tracing, but they are already set to off as seen in the screenshot. I am not familiar on how to disable it in any other way.

image.png.b51ae78b8df8dfe547e1363507c37f7b.png

Edited by Mharrit
Link to post
Share on other sites
  • Codemasters Staff
7 minutes ago, Mharrit said:

Hey @RedDevilKT,

Within the games settings I am not able to change ray tracing, but they are already set to off as seen in the screenshot. I am not familiar on how to disable it in any other way.

image.png.b51ae78b8df8dfe547e1363507c37f7b.png

That's odd, the hardware settings config within your crash dump has it sent to on. Can you take a look at your hardware settings config/send it over separately to see if it is the same as the following:

    <rt_shadows enabled="true" />
    <rt_reflections enabled="true" />

If it is, then try setting this to false for both of those.

Link to post
Share on other sites
2 minutes ago, RedDevilKT said:

That's odd, the hardware settings config within your crash dump has it sent to on. Can you take a look at your hardware settings config/send it over separately to see if it is the same as the following:

    <rt_shadows enabled="true" />
    <rt_reflections enabled="true" />

That is quite weird. The hardware_settings_config does say that both the settings are enabled.

hardware_settings_config.xml

Link to post
Share on other sites
Posted (edited)
18 minutes ago, RedDevilKT said:

Can you try setting those to false and see if that helps your issue? Definitely shouldn't be enabled for a 1080

I tried changing the settings to false but the game still crashed.

13 minutes ago, steviejay69 said:

Or they could try deleting the hardware_settings_config.xml because if the game is detecting the card supports RT when it doesn't then that would be an issue.

 

When I delete the file, it creates a new one when I open game where it has both rt settings set to true.

Edited by Mharrit
Link to post
Share on other sites
7 minutes ago, Mharrit said:

I tried changing the settings to false but the game still crashed.

When I delete the file, it creates a new one when I open game where it has both rt settings set to true.

@RedDevilKT then it would seem the game is incorrectly detecting the GTX1080 as RT capable. Is there anyone else with a GTX1080 to disprove or confirm?

There haven't been any other reports AFAIK though.

Link to post
Share on other sites
1 hour ago, steviejay69 said:

I think it would take someone else with a 1080 to test. I have AMD RX5700XT and it correctly doesn’t add RT.

I just had my friend check his game file, and it says the same thing. He has a gtx 1070 (which also doesn't support RT). In the game settings the RT settings are off, but in the hardware_settings_config they are set to true. But his game does not have any issues and hasn't had any for the past 3 days, therefore I am unsure if this is actually the issue causing my game to crash.

Both these screenshots are from my friend

unknown.png

unknown.png

  • Like 1
Link to post
Share on other sites
2 hours ago, Mharrit said:

@steviejay69

Do you see any other factors which could cause this issue? If so I am willing to try anything, as I am quite lost for what to do after having tried so many things.

Please be patient and allow the relevant process to take place with issues with the game.

Link to post
Share on other sites

I am still watching this thread. If you really want to try something, try DDU your GPU driver in Safe Mode and then clean install your game (Steam backup?).

There is an issue (misdetection of hardware) but it does not seem to be causing widespread crashes (no others reported on forum AFAIK).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...