Jump to content Jump to content

[PS4] G29 Clutch release bug precluding the use of the game


MNZN90
 Share

Recommended Posts

1 hour ago, MNZN90 said:

I tried the following steps:

1) wheel and pad Connected: not working with both pad and wheel

2) only pad with wheel physically disconnected: it works 

3) PlayStation switch on with the console button. Wheel connection (pad disconnected): not working 

4) PS4 inizialization: no effect

5) database driver restore: no effect

6) Try to connect a T300: it works

 

THIS IS IMPORTANT:

I tried to unistall the Game (digital copy) create a New profile, install the Game usinh the physical copy (from a friend) and the G29 works!

then a tried to go to a friend with my G29 and the wheel works.

The issue seems related to my profile and copy of the Game. Do you think that could be something wrong due to beta access?

 

clearing your cache and mac address wont fix this then?

Link to comment
Share on other sites

6 hours ago, MNZN90 said:

On PS4?

Yep, I diid a simple google search to be sure you could clear your cache. As I have a xboxs I also have to change my mac address in settings I didnt see anything about if the PS4 has a mac address. If there is corrupt info that should help but no promises. 

Link to comment
Share on other sites

  • Administrator
19 hours ago, MNZN90 said:

THIS IS IMPORTANT:

I tried to unistall the Game (digital copy) create a New profile, install the Game usinh the physical copy (from a friend) and the G29 works!

then a tried to go to a friend with my G29 and the wheel works.

The issue seems related to my profile and copy of the Game. Do you think that could be something wrong due to beta access?

 

This is excellent feedback @MNZN90, passed straight onto the developer team and to the people with the G29

Can players affected try on new profiles please and let me know if it still happens on the new 2nd profile.

Link to comment
Share on other sites

2 hours ago, BarryBL said:

This is excellent feedback @MNZN90, passed straight onto the developer team and to the people with the G29

Can players affected try on new profiles please and let me know if it still happens on the new 2nd profile.

I tried with a new profile and is not working.

I wonder if is a diference between the physical and digital copies? That is another diference @MNZN90 mentioned.
I didn't had Beta access so that should not be the problem.

@BarryBLdo you think that is possible?

Link to comment
Share on other sites

  • Administrator
21 minutes ago, Nefil33 said:

I tried with a new profile and is not working.

I wonder if is a diference between the physical and digital copies? That is another diference @MNZN90 mentioned.
I didn't had Beta access so that should not be the problem.

@BarryBLdo you think that is possible?

It would be more profile based I assume. But could be. BETA won't affect it.

Link to comment
Share on other sites

On 24/09/2021 at 14:39, ChromeHeartDeat said:

Não tenho certeza se você classificou isso, mas nas ligações do controlador, vá para a embreagem manual e desligue-a. Funcionou para mim 

 se você ainda precisa de ajuda eu fiz um vídeo rápido sobre isso

can't add this option in F1 2021 again?  This solved our problem in the previous game... 

Link to comment
Share on other sites

  • Administrator
14 minutes ago, MNZN90 said:

@BarryBL THIS IS A REALLY IMPORTANT POINT FOR THE DEBUG.

I tried disconnecting phisically the pedals and putting the accelerator on the X button with the clutch still on the right paddle. As said by @F1WesleySantana it works! Of course you cannot use the pedals but it seems something in confict with the pedals!

Fantastic feedback. Added to the information for the testers.

Link to comment
Share on other sites

1 minute ago, BarryBL said:

Fantastic feedback. Added to the information for the testers.

Last point, why you cannot simply restore the "manual clutch" option in the setting?

Becasue this issue was present also on F12020 but in the previous version of the game there was the option to by-pass the bug. I don't know how the code is structured bu what do you think?

Link to comment
Share on other sites

  • Administrator
2 minutes ago, MNZN90 said:

Last point, why you cannot simply restore the "manual clutch" option in the setting?

Becasue this issue was present also on F12020 but in the previous version of the game there was the option to by-pass the bug. I don't know how the code is structured bu what do you think?

I don't know how the code works, and I suspect it is more complicated than that. Have to remember that our struggle has been internal replication at this time, not necessarily the issue. Once we can replicate, it could be a easier fix, it could not. 

We've ran extensive testing and one of our QA team runs on a G29 as standard across all platforms, and has not seen the issue. The challenge will be replication. I suspect possibly a firmware update for the wheel via PC. Can you confirm you have done this. Normally console wheels can have updates missed, as they need a PC to do them

Link to comment
Share on other sites

5 minutes ago, BarryBL said:

I don't know how the code works, and I suspect it is more complicated than that. Have to remember that our struggle has been internal replication at this time, not necessarily the issue. Once we can replicate, it could be a easier fix, it could not. 

We've ran extensive testing and one of our QA team runs on a G29 as standard across all platforms, and has not seen the issue. The challenge will be replication. I suspect possibly a firmware update for the wheel via PC. Can you confirm you have done this. Normally console wheels can have updates missed, as they need a PC to do them

I confirm. I download the logitech app, connected the wheel to PC and onces i tried to updated the software inform that I have the Last version

Link to comment
Share on other sites

  • Administrator
2 minutes ago, MNZN90 said:

I confirm. I download the logitech app, connected the wheel to PC and onces i tried to updated the software inform that I have the Last version

Thanks. I'll take a look and have passed on the lack of 'Manual Clutch' option this year. Would be a logical solution without us actually needing to repro it (would be better if we do though)

Link to comment
Share on other sites

I was about to create a bug report for the same issue but then followed the necessary rules and searched. I find this topic.


I am on PS4 and have a digital copy. I use a G29 wheel. Game is up to date. No changes occurred to my wheel or settings. 

This spontaneously started last week Monday. I tried the following steps:

Changed clutch from gear up paddle  to clutch pedal (no conflicts) 

Tested all buttons on G29 work. It also works in other games.
Tested it also on PC and the G29 works.
With Pad plugged in and active without pad. 

When the pad is plugged in by itself and the wheel is OFF then the clutch button on the pad works as normal and you can do manual starts as normal. When both peripherals are plugged in neither of their respective clutch buttons work as they should: 

https://youtu.be/PsbFyBxLIMc

I have now reinstalled the game (will see if that works once done). DO I need to create my own bug report or is adding my voice to this very active thread enough to help get some more action? 
 

EDIT:
This occurs in multiplayer, my team, career and solo GP. Also unable to exit pit box (you have to hold clutch in during pit). I discovered this as I was in a my team race and was unable to start unless I disconnected my wheel and started with pad and then switched to wheel. Then when I went to pit I could not exit because once again the clutch would not work, so I had to switch wheel off, use pad to exit pit and then switch back to wheel. I could also not change manual start to assisted start during the race (like mentioned earlier). 

While it will be good to allow that function to be selectable and then used as a workaround for offline campaigns, this does not resolve issues for multiplayer where the manual start is part of the league/lobby settings. 

Edited by QmanXV
Add information
Link to comment
Share on other sites

Screenshots I took during tests. Tested left paddle and right paddle here, but I also did the test with a button that had no conflict (unassigned the next camera button which was my clutch on the pedal set and set it to clutch) Didn't take a screenshot that time. 

I think it's key to note that in both these situations the gear up and gear down button worked as those functions once I got the car going using the pad like explained before)

EB429E99-8D7F-489B-9C8A-BDFCF0298A0E.png

4B063BC5-1131-43C7-A708-1AB7E18196C0.png

Edited by QmanXV
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...