Jump to content Jump to content

Thrustmaster - Force Feedback - FFB fading across a session


Recommended Posts

25 minutes ago, RLLL said:

Happened today, happens every time I play. Developers only making a breakthrough with this issue now, almost 3 months after release. The bug was originally reported in the BETA 4 months ago. Will we get some sort of credit or refund for being sold an unusable product? How can an A+ racing game not support wheels made by one of the biggest sim equipment companies out there? 

As Barry pointed out above
 

On 9/14/2021 at 12:51 PM, BarryBL said:

We have had some challenges in replicating as some Thrustmaster users were experiencing this internally, and some were not

I have a Thrustmaster T300RSGT on PC using the Rally Sparco rim, with fully updated firmware. No fan mods or anything else. Running on a fully updated version of Windows 10, with all device drivers up to date. I have not personally had any force feedback issues in F1 2021. I do 100% races, and spend a lot of time practicing for my next race in time trial mode. The force feedback has been rock solid for me. This is what Barry is referencing when he says the have had challanges replicating this, because everyones setups have different quirks. Even on consoles.

This is the sort of reason why these things take time to diagnose and fix, because some people will experience the bug, others will not. They have to make sure that whatever they change fixes the bug, while not creating a new one somewhere else.

So would you prefer they rush a fix out that then may or may not solve your issue or create new ones?
Or would you prefer they take their time, work with Thrustmaster, and get the fix right first time?

Link to post
Share on other sites

Bruh the game is 3 months old and this problem was happening in the first BETA version. It's not rushing out a fix is it, it's taking a long time to fix something that should of been fully tested before release. 

Link to post
Share on other sites
15 hours ago, RLLL said:

Bruh the game is 3 months old and this problem was happening in the first BETA version. It's not rushing out a fix is it, it's taking a long time to fix something that should of been fully tested before release. 

But the fact it isn't possible to easily replicate makes the fix difficult. What part do you not understand? It's not like the devs thought "Oh I know, let's stuff the FFB for a percentage of the Thrustmaster users because it will be fun." Obviously the devs weren't aware of the issue during development and it wasn't until beta that the problem became apparent. 

CM are working with Thrustmaster to solve the issue, which indicates the cause (and therefore fix) is not necessarily on one side.

It was worse in beta, so maybe the initial fix wasn't such a good fix.

  • Like 1
Link to post
Share on other sites
2 hours ago, steviejay69 said:

But the fact it isn't possible to easily replicate makes the fix difficult. What part do you not understand? It's not like the devs thought "Oh I know, let's stuff the FFB for a percentage of the Thrustmaster users because it will be fun." Obviously the devs weren't aware of the issue during development and it wasn't until beta that the problem became apparent. 

CM are working with Thrustmaster to solve the issue, which indicates the cause (and therefore fix) is not necessarily on one side.

It was worse in beta, so maybe the initial fix wasn't such a good fix.

Its very easy to replicate, I know so many folk who have this issue. This is just TM I'm on about as well, what about fanatec wheels thinking they are key boards and logitec wheels taking over control of the car by themselves. Come on man.

Link to post
Share on other sites
6 minutes ago, RLLL said:

Its very easy to replicate, I know so many folk who have this issue. This is just TM I'm on about as well, what about fanatec wheels thinking they are key boards and logitec wheels taking over control of the car by themselves. Come on man.

I won't descend to your level. It's fair enough to say that I've had few (but annoying and inexplicable issues) others who have updated their equipment with firmware and drivers are also experiencing either no FFB or more frequent failures. Those that don't update, well good luck because all you do is cloud the issue by getting errors related to the lack of updates. And once again, for the record, Thrustmaster do not issue firmware or drivers for no reason. It is to add functionality, improve compatibility and fix known issues. Otherwise they would not.

I've documented what I can replicate. I don't know what else to say. 

Link to post
Share on other sites
3 hours ago, steviejay69 said:

I won't descend to your level. It's fair enough to say that I've had few (but annoying and inexplicable issues) others who have updated their equipment with firmware and drivers are also experiencing either no FFB or more frequent failures. Those that don't update, well good luck because all you do is cloud the issue by getting errors related to the lack of updates. And once again, for the record, Thrustmaster do not issue firmware or drivers for no reason. It is to add functionality, improve compatibility and fix known issues. Otherwise they would not.

I've documented what I can replicate. I don't know what else to say. 

My wheels firmware is fully up to date, plugged directly into the console. No issues with the wheel itself, it will run 4/5 hours on Assetto with no issue. After 45 mins of use on F1 it cuts outs. If you do an 18min quali and 50% race the wheel will 100% cut out around the halfway point of the race every time. If CM need pointers to help replicate the issue, there you go.

Link to post
Share on other sites
15 minutes ago, RLLL said:

My wheels firmware is fully up to date, plugged directly into the console. No issues with the wheel itself, it will run 4/5 hours on Assetto with no issue. After 45 mins of use on F1 it cuts outs. If you do an 18min quali and 50% race the wheel will 100% cut out around the halfway point of the race every time. If CM need pointers to help replicate the issue, there you go.

If it's replicable, it's a contribution. We can all accept that complaining and ranting about the situation won't change it any faster. Nobody is happy or complacent.

Link to post
Share on other sites
5 hours ago, RLLL said:

My wheels firmware is fully up to date, plugged directly into the console. No issues with the wheel itself, it will run 4/5 hours on Assetto with no issue. After 45 mins of use on F1 it cuts outs. If you do an 18min quali and 50% race the wheel will 100% cut out around the halfway point of the race every time. If CM need pointers to help replicate the issue, there you go.

I'd be fuming in your position too. However, whilst the issue is easy to replicate for you it doesn't mean it will be for others with the same equipment. You didn't mention which console you're using but certainly on PS5 there is an issue like you describe which affects some players but not others with the same kit.

Edit: I believe Barry has posted noting variability like this found amongst Codemasters staff.

Edited by Ultra3142
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...