Jump to content Jump to content

Wing damage not showing


Recommended Posts

Not sure I should post a full issue thread yet but I feel my wings etc get damaged but the hud is still green. I brush the walls and i'm 2 sec off the pace so not sure it's me getting used to the new physics or I am actually damaged.

Has anyone else seen this or am I imagining things?

  • Like 1
  • Agree 8
Link to post
Share on other sites

I can confirm that. I had a slight damage to the front wing, nothing serious but the pace was terrible. Jeff suggested an alternate strategy in response to the damage, but everything was green in the MFD.

  • Like 1
Link to post
Share on other sites

This is happening to me too, not just front wing damage though. I’ve been told I’ve got under floor damage a few times but everything is still green on the MFD. Or sometimes I don’t get told about anything and I get into the garage and I have to wait whilst they repair the car.

Edited by Luke1991
Link to post
Share on other sites

Same... microscopic damage (yet could see it in the video replay) and nothing on the damage screen.  Got notification from Jeff however that a new strategy was available.  That was my hint that I banged something up.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...