Jump to content Jump to content

Stratos gravel rims: is that a bug?


meerkat80

Recommended Posts

I think there's an "ancient" bug on the mapping of the Stratos gravel rim that dates back to Dirt 3.
Basically, all the lateral faces of the spokes are mapped to black, and this is why the rim looks like this when you look at it in-game:

Much more evident at an angle:

Of course if you look at real life picture the rim is not like this. It's completely yellow, not just on the faces facing perpendicular to its axis.
The problem is just in the texture, not in the mapping. If you open any of the str_wheel.tga.dds (any colors), you can see the the alpha shows some area with different reflections for the specular map, and while they are ON on the specular, they are just pitch black into the main RGB texture.
This is a pic with the alpha channel activated:

Painting this area with just yellow rectangles fix the problem, but to be perfect there has to be some kind of gradients. Oh and it's way too reflective for ordinary paint. Looks like a metal-like reflection level. This is with the fix:


How do I point this problem to the devs?
Link to post
Share on other sites
I just wanted to say that it's impressive all the effort you put in your work, going into every detail to get everything perfect. Most of Modder's wouldn't care about this little ( big ) detail, on the Stratos rims, and would move forward... but that's why most Modder's can't achieve the top notch quality and details accuracy, of your Skins. I wish there was more Modder's just like you, Meerkat and i hope you can get in touch with the Devs, to get this sorted. Keep up the good work!!
Link to post
Share on other sites
@RookieOne The speedometer issue is logged on our database but no news on a fix at this time I'm afraid.

@macebig Nope, I'm just a Sega fanboy from back in the day - Sonic the Hedgehog 2 is the reason I became a game designer. We shan't speak of the recent Sonic games, though.
Link to post
Share on other sites
ipicko said:
@RookieOne The speedometer issue is logged on our database but no news on a fix at this time I'm afraid.
@ipicko just making sure you codiemeisters know, the speedometer is forked on all cars, at least the in-car one, and I think it's only during replays. I think I got it working to an extent when I verified the integrity of game cache, so they work in-car as you drive... but they still won't move during replays. This goes for the digital ones as well.
Link to post
Share on other sites
ipicko said:
@RookieOne The speedometer issue is logged on our database but no news on a fix at this time I'm afraid.

@macebig Nope, I'm just a Sega fanboy from back in the day - Sonic the Hedgehog 2 is the reason I became a game designer. We shan't speak of the recent Sonic games, though.
I think you should quite freely speak of Sonic Generations at least. 
Link to post
Share on other sites
@ipicko I don't know if this was already reported, but I just noticed a distortion of the UV mapping around the edges of the Quattro's back pillars. Probably happened something during the update of the model from Dirt 3, because it was perfect in D3 (see the shot at the end).



Link to post
Share on other sites
meerkat80 said:


Painting this area with just yellow rectangles fix the problem, but to be perfect there has to be some kind of gradients. Oh and it's way too reflective for ordinary paint. Looks like a metal-like reflection level. This is with the fix:


Thanks @meerkat80 .
Was changing the paint on the rims of my skin and run into the same problem.
Now I dont need to search where those parts are hidding.  
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...