Jump to content

Archived

This topic is now archived and is closed to further replies.

Refresh rate 60 no longer available... but I need it! Dirt Rally (and also F1 2015)

Recommended Posts

Yesterday everything was fine, but today the game started windowed and when I wanted to correct the settings I couldn't select 60 refresh rate anymore when also selecting 1920x1080, I can only select 50 or 59, which on a 60Hz screen makes you drop back to like 30. My hardware should and did run it easily before (Intel 6600K, AMD R9 380, Windows 10). To test, I put the monitor on my previous almost 4 years old computer with Intel 2400 or so (a Sandy bridge processor), and AMD 6870 and Windows 7, and on that thing, 60 refresh rate was still an option on 1920x1080 resolution. Also F1 2015 doesn't give me the option of 60 refresh rate anymore.

Anyone knows a fix and/or cause?

Share this post


Link to post
Share on other sites
Hi Chicane486 

When the game is set to 50Hz or 59Hz in fullscreen and you have vsync enabled, the monitor is also running at 50Hz or 59Hz.

The game has access to the same refresh rates as windows. 

If you get frame drops to 30Hz try turning down some details of the game or disable vsync.


Share this post


Link to post
Share on other sites
DeputyDiRT said:The game has access to the same refresh rates as windows. 
That should be the case, but it isn't, as I also can't select 60Hz refresh rate even though it is an option in the windows or nVidia control panel. I'm personally running at 70Hz, however the 60Hz option for some reason doesn't appear for 1920x1080 resolution only. All other refresh options do. V-Sync doesn't make a difference regardless of the way it's used or not used.

Share this post


Link to post
Share on other sites
Moreless what G37L057 has said. So I don't have access ingame to the same refresh rates as windows. Vsync also doesn't make a difference either.
I'm lucky to have nice hardware so my fps doesn't get below 60 at any time, but still I have slight doubts if I'm looking at a game showing as fluent on my new hardware compared to my old hardware.

Share this post


Link to post
Share on other sites

×