Jump to content Jump to content

F1 2021 Steam always "Running" after closing the Game


Recommended Posts

No-one's posted a dxdiag, so we can't see if it's related to a particular piece of hardware or a setting, conflicting software, etc.

I suspect it is Steam (overlay?) / driver related.

Can't replicate personally.

Link to post
Share on other sites

 

24 minutes ago, steviejay69 said:

No-one's posted a dxdiag, so we can't see if it's related to a particular piece of hardware or a setting, conflicting software, etc.

I suspect it is Steam (overlay?) / driver related.

Can't replicate personally.

DxDiag.txt

aa, it is most likely steam overlay, since after I enabled that I got the issue to. However, when you don't have the overlay enabled you can't browse setups from steam lol. So that is still a bugg

  • Thanks 1
Link to post
Share on other sites
14 minutes ago, UndercoverNL said:

 

DxDiag.txt 82.96 kB · 0 downloads

aa, it is most likely steam overlay, since after I enabled that I got the issue to. However, when you don't have the overlay enabled you can't browse setups from steam lol. So that is still a bugg

Well this is probably a Steam bug as the software is 

a) permanent beta (like Discord)

b) still 32-bit which is a bit archaic.

c) still possibly driver related as I always have it enabled and don't have the issue.

Link to post
Share on other sites
4 minutes ago, steviejay69 said:

Well this is probably a Steam bug as the software is 

a) permanent beta (like Discord)

b) still 32-bit which is a bit archaic.

c) still possibly driver related as I always have it enabled and don't have the issue.

Well, other games close correctly, and it is not a driver issue since I didn't update any driver, and it did work before, until I switched on steam overlay. Besides that, F1 games always have problems with steam overlay, all games so far are known to causing multiple bugs when having steam overlay enabled.

Link to post
Share on other sites
8 minutes ago, UndercoverNL said:

Well, other games close correctly, and it is not a driver issue since I didn't update any driver, and it did work before, until I switched on steam overlay. Besides that, F1 games always have problems with steam overlay, all games so far are known to causing multiple bugs when having steam overlay enabled.

You have the EyeFinity setup too though, one of the other people said it changed with resolution away from 1080, I'm running 1440 but I think the majority run 1080 most likely and it's not widely reported.

And....we've been through your dxdiag, it might be helpful to see some of the others. Divide and conquer.

 

Link to post
Share on other sites
4 minutes ago, steviejay69 said:

You have the EyeFinity setup too though, one of the other people said it changed with resolution away from 1080, I'm running 1440 but I think the majority run 1080 most likely and it's not widely reported.

And....we've been through your dxdiag, it might be helpful to see some of the others. Divide and conquer.

 

I always use eyefinity, also when it worked. Besides that resolution shouldn't have anything to do with software not closing correctly

Link to post
Share on other sites
On 8/6/2021 at 12:10 AM, BarryBL said:

Thanks for the feedback all, looks like you can close via task manager. I will report it regardless.

I cant close it via the Task Manager. the .exe does not pop up in task Manager even though Steam says it is still running

Link to post
Share on other sites
30 minutes ago, OzzyGamer275 said:

I cant close it via the Task Manager. the .exe does not pop up in task Manager even though Steam says it is still running

Well this points to a Steam issue. Can you run with Task Manager or some monitoring tool open to see the memory load dropping?

Link to post
Share on other sites
1 minute ago, UndercoverNL said:

nope it is not, it still takes over 4G of memory

You’re seeing the executable still running then, not what the other user reported? (No exe and still showing as running in Steam).

Link to post
Share on other sites
1 minute ago, steviejay69 said:

You’re seeing the executable still running then, not what the other user reported? (No exe and still showing as running in Steam).

all other users reported this same issue, or the ex is hidden under the steam dropdown but steam looks if the .exe is running, if not you can lounge it, if so then it says the game is running. There is no other way for steam to report a running game if the exe is running. Which makes it a game issue I believe, since when you use the ingame exit it does not shut down the .exe file. I will try and check if when you close the game using steam itself when the game is running if the game does actually shut down then.

Link to post
Share on other sites
2 minutes ago, UndercoverNL said:

all other users reported this same issue, or the ex is hidden under the steam dropdown but steam looks if the .exe is running, if not you can lounge it, if so then it says the game is running. There is no other way for steam to report a running game if the exe is running. Which makes it a game issue I believe, since when you use the ingame exit it does not shut down the .exe file. I will try and check if when you close the game using steam itself when the game is running if the game does actually shut down then.

Couple of other questions. Are you using Steam Cloud (I don't) and is the game and Steam on the primary storage?

There is a short delay, but it does stop. That would be normal.

Link to post
Share on other sites
Just now, steviejay69 said:

Couple of other questions. Are you using Steam Cloud (I don't) and is the game and Steam on the primary storage?

No I am not using cloud, and I have both the steam and the game on primary storage

  • Thanks 1
Link to post
Share on other sites
1 minute ago, steviejay69 said:

I have Afterburner running when I play. I'll log the RAM usage in tonight's sessions.

 

alr, it may be reduced a bit. But that can also be the case due to running full screen, since when you run full screen and min a game it takes less RAM / CPU / GPU

Link to post
Share on other sites
3 minutes ago, UndercoverNL said:

alr, it may be reduced a bit. But that can also be the case due to running full screen, since when you run full screen and min a game it takes less RAM / CPU / GPU

It should have no effect on whether the executable is quitting correctly when the command is issued. It's my opinion that it's related to some process not being completed in time before the quit command is allowed to kill the exe. Steam Cloud was my first thought, being as I don't use it but it could be overlay / client related and that could be a driver issue. It could be something else, but I've got to see it to be able to try to alleviate it.

Link to post
Share on other sites

Here is my dxdiag. Game installed on sata ssd on primary windows drive, steam cloud enabled. While playing I am running afterburner and rivaturner statistic server.

edit: i also have HDR on

DxDiag.txt

Edited by emons
  • Thanks 1
Link to post
Share on other sites
2 hours ago, UndercoverNL said:

alr, it may be reduced a bit. But that can also be the case due to running full screen, since when you run full screen and min a game it takes less RAM / CPU / GPU

In Ultra I go from a peak of 6600MB to <1000MB in less than 12 seconds but that could be the game at the end of a session (we loaded qualifying but backed out) the instant drop was from 4500 to <1000 in 1s, pretty sure that was closing the game.

Link to post
Share on other sites
1 minute ago, steviejay69 said:

In Ultra I go from a peak of 6600MB to <1000MB in less than 12 seconds but that could be the game at the end of a session (we loaded qualifying but backed out) the instant drop was from 4500 to <1000 in 1s, pretty sure that was closing the game.

Does it change anything about the situation tho? It hasn't nothing to do with the game not closing has it.

Link to post
Share on other sites

This happens to me as well and has only started since the game was patched to 1.05. I can't close it in task manager either @BarryBLand have to either restart the PC or fully close Steam, so I hope this will be investigated accordingly. For what its worth, I've found this year's game riddled with bugs and full of EGO Dumper crashes, although they seem better after the last patch.

 

 

Link to post
Share on other sites
3 minutes ago, kelsh003 said:

This happens to me as well and has only started since the game was patched to 1.05. I can't close it in task manager either @BarryBLand have to either restart the PC or fully close Steam, so I hope this will be investigated accordingly. For what its worth, I've found this year's game riddled with bugs and full of EGO Dumper crashes, although they seem better after the last patch.

 

 

 

17 minutes ago, UndercoverNL said:

Does it change anything about the situation tho? It hasn't nothing to do with the game not closing has it.

Maybe, maybe not but it not happening for everyone means there is a cause that doesn’t effect everyone so I don’t know what you expect when there’s no start point.

I will look at the dxdiags and try to find commonality or suggest changes to your config, but that only adds to the available information.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...