Jump to content Jump to content

F1 2021 Steam always "Running" after closing the Game


Recommended Posts

1 minute ago, steviejay69 said:

 

Maybe, maybe not but it not happening for everyone means there is a cause that doesn’t effect everyone so I don’t know what you expect when there’s no start point.

I will look at the dxdiags and try to find commonality or suggest changes to your config, but that only adds to the available information.

not trying to be mean, but isn't that the task of codemasters? There is a problem reported by many, many users. With dxdiags and full bugg reports with the exact explanation. Which is all code master should need to fix it.

Link to post
Share on other sites
2 minutes ago, UndercoverNL said:

not trying to be mean, but isn't that the task of codemasters? There is a problem reported by many, many users. With dxdiags and full bugg reports with the exact explanation. Which is all code master should need to fix it.

There is lots of information not there session codes before it doesn’t close etc just note it, did you experience connection errors during play etc did you tab out lists of info.

Not trying to be funny but I don’t experience the instability a lot claim. I am not saying there are no bugs. I am just saying I can’t replicate many many issues that people seem to be facing.

Not game play, they’re easy. System or connection issues I struggle with.

But then I know I don’t have garbage installed have good installations and apply all updates.

That’s my experience.

Link to post
Share on other sites

@steviejay69so I tested every situation, and now it seems to be gone on me. But I am 10% sure I did have the issue this morning and all days before.

Currently, I tried running with both steam overlay disabled and enabled, and closing in the game itself and on steam. So now everything closed correctly. Idk why. If I have the issue tomorrow after a session again then I will update you.

Edited by UndercoverNL
  • Like 1
Link to post
Share on other sites
7 hours ago, UndercoverNL said:

@steviejay69so I tested every situation, and now it seems to be gone on me. But I am 10% sure I did have the issue this morning and all days before.

Currently, I tried running with both steam overlay disabled and enabled, and closing in the game itself and on steam. So now everything closed correctly. Idk why. If I have the issue tomorrow after a session again then I will update you.

I don't think closing the game from Steam is wise; just because you can, doesn't mean you should 🙂

I just feel the whole ALT-TAB thing is nasty to do, users probably don't shut down cleanly or just kill processes (it's inevitable if you play online unfortunately due to lobbies hanging but I feel it is the same root cause, people ALT-TAB and quit out because of impatience).

  • Agree 1
Link to post
Share on other sites
Posted (edited)

Ok now i can replicate the problem and fix it.

I tried to disable steam overlay, started F1 2021 and closed it. Its running all the time, need to be closed from task manager.

Same after restarting Steam and so on. Then i thought back when i tested my 49 inch monitor, and i tried F1 2021 without my Logitech G29 connected.

Disconnected the Wheel, started game and closed it and its working now. Its not running anymore.

My Wheel is connected to usb 3.0 frontpanel. It was working before the new F1 2021 Patch.

I will try to connect the wheel directly to the mainboard on different usb ports.

But would be interesting which Wheel everyone is using who has this problem.

 

EDIT: ok tried a few things now. Wheel connected on different ports usb 2.0, 3.0 directly on mainbord at the back and frontpanel. Everytime the same issue if the Wheel is connected at the start of the game. Even when i disconnect it before i close the game. Its everytime running.

I will try now to connect it after starting the game, maybe this works. But wihtout the Wheel connected it works everytime.

 

EDIT2: Ok same problem when i connect it after i started the game. I dont have a different wheel to test it. Maybe with a different software from the logitech hub, but there wasnt a update since last f1 2021 patch, since the problem appears. Hmm when i have time maybe it will try it with different software version.

 

EDIT3: Ok last update on logitech G-Hub to version 2021.8.792 was on July 29 or 30 or something, cause this is what i found in some posts online. When was the update for f1 2021?

 

DxDiag.txt

Edited by L4ps
  • Like 3
Link to post
Share on other sites
2 hours ago, steviejay69 said:

I don't think closing the game from Steam is wise; just because you can, doesn't mean you should 🙂

I just feel the whole ALT-TAB thing is nasty to do, users probably don't shut down cleanly or just kill processes (it's inevitable if you play online unfortunately due to lobbies hanging but I feel it is the same root cause, people ALT-TAB and quit out because of impatience).

 

22 minutes ago, L4ps said:

Ok now i can replicate the problem and fix it.

I tried to disable steam overlay, started F1 2021 and closed it. Its running all the time, need to be closed from task manager.

Same after restarting Steam and so on. Then i thought back when i tested my 49 inch monitor, and i tried F1 2021 without my Logitech G29 connected.

Disconnected the Wheel, started game and closed it and its working now. Its not running anymore.

My Wheel is connected to usb 3.0 frontpanel. It was working before the new F1 2021 Patch.

I will try to connect the wheel directly to the mainboard on different usb ports.

But would be interesting which Wheel everyone is using who has this problem.

 

EDIT: ok tried a few things now. Wheel connected on different ports usb 2.0, 3.0 directly on mainbord at the back and frontpanel. Everytime the same issue if the Wheel is connected at the start of the game. Even when i disconnect it before i close the game. Its everytime running.

I will try now to connect it after starting the game, maybe this works. But wihtout the Wheel connected it works everytime.

 

EDIT2: Ok same problem when i connect it after i started the game. I dont have a different wheel to test it. Maybe with a different software from the logitech hub, but there wasnt a update since last f1 2021 patch, since the problem appears. Hmm when i have time maybe it will try it with different software version.

 

DxDiag.txt 123.2 kB · 1 download

I also had the problem after the last patch. And that may be the case yea, since yesterday when I tested it I didn't have my wheel connected at all, and then it did shut down correctly. While normally when it doesn't shut down correctly I have my wheel plugged in

Edited by UndercoverNL
Link to post
Share on other sites
Posted (edited)

You also have the G29 or a different Wheel or any sort of equipment with the g-hub software? Cause if you have the G29 i will test a older G-Hub Version today or tomorrow and try again.

Edited by L4ps
Link to post
Share on other sites
10 minutes ago, L4ps said:

You also have the G29 or a different Wheel or any sort of equipment with the g-hub software? Cause if you have the G29 i will test a older G-Hub Version today or tomorrow and try again.

nah G920

  • Thanks 1
Link to post
Share on other sites

Ok thanks, thats almost the same i would say 😉

Im interested in the other people who have this issue. If they all use a Logitech Wheel, i think then we come closer to a solution.

  • Like 1
Link to post
Share on other sites
11 minutes ago, L4ps said:

Ok thanks, thats almost the same i would say 😉

Im interested in the other people who have this issue. If they all use a Logitech Wheel, i think then we come closer to a solution.

The issue that was being looked at in GHub was the updater (LG Hub Agent, LG Hub Updater (& service), kill (close in tray) it after you start Windows or you connect the wheel and it hasn't shown updates to GHub or wheel firmware.

Link to post
Share on other sites
3 hours ago, L4ps said:

Ok now i can replicate the problem and fix it.

I tried to disable steam overlay, started F1 2021 and closed it. Its running all the time, need to be closed from task manager.

Same after restarting Steam and so on. Then i thought back when i tested my 49 inch monitor, and i tried F1 2021 without my Logitech G29 connected.

Disconnected the Wheel, started game and closed it and its working now. Its not running anymore.

My Wheel is connected to usb 3.0 frontpanel. It was working before the new F1 2021 Patch.

I will try to connect the wheel directly to the mainboard on different usb ports.

But would be interesting which Wheel everyone is using who has this problem.

 

EDIT: ok tried a few things now. Wheel connected on different ports usb 2.0, 3.0 directly on mainbord at the back and frontpanel. Everytime the same issue if the Wheel is connected at the start of the game. Even when i disconnect it before i close the game. Its everytime running.

I will try now to connect it after starting the game, maybe this works. But wihtout the Wheel connected it works everytime.

 

EDIT2: Ok same problem when i connect it after i started the game. I dont have a different wheel to test it. Maybe with a different software from the logitech hub, but there wasnt a update since last f1 2021 patch, since the problem appears. Hmm when i have time maybe it will try it with different software version.

 

EDIT3: Ok last update on logitech G-Hub to version 2021.8.792 was on July 29 or 30 or something, cause this is what i found in some posts online. When was the update for f1 2021?

 

DxDiag.txt 123.2 kB · 1 download

Patch 1.05 was July 28.

Link to post
Share on other sites
9 hours ago, TwistedWays said:

i cannot close my game unless i force closed i read i had to update my bios but they are up to date how i fix please 

You need to post a dxdiag including make and model of your mainboard for an update. Please familiarise yourself with the update procedure and do not attempt it unless you are confident.

@L4ps Older GHub not sure you can roll back as Logitech have now modified their weblinks to the latest stub (web) installers? So unless you have some kind of offline installer I'm not sure rolling back is even possible.

Last update on ftp.logitech.com is from 2018 (useless because it will only update to current probably) and you need to use a browser that still supports FTP *cough* IE *cough*

ftp://ftp.logitech.com/pub/techsupport/gaming/lghub_installer_2018.9.2778.exe

Link to post
Share on other sites
On 8/8/2021 at 12:59 AM, steviejay69 said:

Well this points to a Steam issue. Can you run with Task Manager or some monitoring tool open to see the memory load dropping?

its only when i force close steam does the executable start to show up on Task manager. and yes its using about 4G of memory. and i know for sure its not Steam as this is the only game this is occuring with and only since the 1.05 patch (still happening in 1.06)

Discord also shows the game is still running until i force close the .exe. Even after shutting down Steam.

 

I've noticed since launch this game is very unoptimised for PC. especially compared to F1 2020.

Link to post
Share on other sites

Yeah i need to do some more testing on the weekend. Maybe i find an older version somewhere. But as you said it will automatically update to latest version.

Maybe i open a supportticket at logitech and they can help 😉

  • Agree 1
Link to post
Share on other sites
1 hour ago, L4ps said:

Yeah i need to do some more testing on the weekend. Maybe i find an older version somewhere. But as you said it will automatically update to latest version.

Maybe i open a supportticket at logitech and they can help 😉

The more people that do, hopefully Logitech fix what they wrote. More the issue is I think the earlier downloaders for GHub are stub installers (they pull the latest version off the web anyway as they are incomplete and it's because people continue to use old versions when the new ones are out. Unfortunately, it means when the upstream versions have issues there's no way to revert except using your own software image and turning the auto update off).

Link to post
Share on other sites

I like to add some info that I noticed but have no proof or something to support then my word for it, cause I do not think it is Logitech GHub fault only/at all as a Logitech G923 owner and having this issue which is annoying cause rebooting the PC nowadays to get other game from steam running or unfreeze PC after closing F1 2021 is ridiculous and frustrating.

When the game was 1.04 patch on 27 july 2021 with GHub NOT updated all worked perfect, then the patch 1.05 released on 28 july 2021 started doing the not closing in steam and that was BEFORE GHub got updated i played the game on 28 july on "old" GHUB version with patch 1.05, and the GHub installed the update on my PC on august 1st.
So from that point of view it is not logitech cause else patch 1.04 would have the problem as well, it all started with patch 1.05 and continues in patch 1.06

Did try to run older version (the version before 29 july) and then the issue is still present with patch 1.06. (couldnt try patch 1.04 and patch 1.05 if it is possible)
With patch 1.04 this was not happening, ergo codemasters has something to check and fix, not logitech?

So I am confused why it is a GHUB problem according to people/moderator(s) cause based on what i noticexd GHub can not be the cause of the problem.
It would be F1 causing it due to some coding and causing confclit with GHub and I lack to see why Logitech has to solve it if it is your patch causing it before Logitech had an update for the public.

Yes wheel unplugged makes the game close as it should, still your patch came first and before the GHub patch came that issue was present.
I can not proof it any longer cause I didnt know this was an issue, it always happens for me with F1 (also with 2020) for 1st time that it hangs/ doesnt wanna launch or doesnt close in steam and keeps running so didnt think of screening it and taking notes and copies of certain files.

So if someone wants to explain why GHub would be the problem and why Logitech has to solve this when F1 updates and immediately this issue occurs please explain cause i really do not see the logic of pushing it to Logitech to solve it, i do see logic in codemasters fixing it cause their patch causes this based from my point of view.

Fun to know that Logitech/Alonso makes the commercial to promote the game and to sell it and now GHub/Logitech gets the blame for this problem... Nice one (not im sarcastic as can be)

Edited by NastyAssassin
forgot some information/worded it better
  • Agree 1
Link to post
Share on other sites
  • Administrator

Thanks for all of the reports everyone. 

This has now been added to our internal report and is with developers. Please continue to post reports so we can add this to our feedback for the team. Can I also ask for you to confirm:

  1.  A lot of players are reporting they issues when a wheel is connected. Can you confirm this issue occurs when you have a wheel connected
  2. Does this happen when you dont have a wheel connected? Can you close the game normally?
  3. Make and model of wheel.

Many thanks.

Link to post
Share on other sites
1 minute ago, BarryBL said:

Thanks for all of the reports everyone. 

This has now been added to our internal report and is with developers. Please continue to post reports so we can add this to our feedback for the team. Can I also ask for you to confirm:

  1.  A lot of players are reporting they issues when a wheel is connected. Can you confirm this issue occurs when you have a wheel connected
  2. Does this happen when you dont have a wheel connected? Can you close the game normally?
  3. Make and model of wheel.

Many thanks.

1. Yes this happens only with wheel plugged in/connected

2. When wheel is unplugged/disconnected the game closes normal

3. Logitech G923 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...