Jump to content Jump to content

Unable to Join Any Online Sessions on Xbox Series X (Error Code WS10047 or NS7)


Recommended Posts

  • Codemasters Staff
2 minutes ago, Veremith said:

I Still have this issue as well. Everytime I try to join a social beginner race I just get stuck in the loading screen forever, I can see all the other players loading but there is always just 1 player that has the loading icon and it never changes to a checkmark. Everyone else including me has a checkmark, its almost as if the person lost connection to the session and it causes the rest of us to get stuck waiting for them It never gets to the point where a count begins and the player who isnt loaded in yet get booted.  I use a wired connection and ive also tried turning off windows firewall but it doesnt make any difference 

Hi @Veremith. This sounds like a different issue. Would you be able to create a new bug report thread for this issue, including the info requested in the standard bug reporting template? Videos and report codes would be particularly useful for this sort of issue.

Link to post
Share on other sites
  • Codemasters Staff

If anyone is unable to connect to a specific host, but can connect to other lobbies normally, then please let us know (@Hoo and @BarryBL). We are keen to identify these players to request their assistance in tracking down the cause of this issue!

We are still investigating this issue as a priority on the team. We have some pending changes to improve the error messaging, plus fixes for other network bugs that are expected to go into our next Xbox patch (v1.05). These changes may improve some instances of players failing to join a session after previously being removed from a session, but we still think there is another underlying cause to the main NS7 issue being reported here. Please continue to provide info in this thread and we will keep feeding this to the dev team. In particular, please look out for particular session hosts that you cannot connect to from a fresh launch of the game. Video footage showing the session joining process from the multiplayer menus would be very useful too, along with report codes for your session.

Thanks.

Link to post
Share on other sites

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

Link to post
Share on other sites
  • Hoo pinned this topic
On 7/24/2021 at 5:20 PM, rubens77 said:

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

 

On 7/24/2021 at 5:20 PM, rubens77 said:

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

I had the same issues for days but I ended up forwarding the following ports on my router for my Xbox ip address, restarted my Xbox and it worked. Never had to do that for f1 2020.

https://portforward.com/f1-2021/

Link to post
Share on other sites
On 7/24/2021 at 5:20 PM, rubens77 said:

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

 

On 7/24/2021 at 5:20 PM, rubens77 said:

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

I had the same issues for days but I ended up forwarding the following ports on my router for my Xbox ip address, restarted my Xbox and it worked. Never had to do that for f1 2020.

https://portforward.com/f1-2021/

Link to post
Share on other sites
On 7/15/2021 at 3:03 PM, BarryBL said:

What is your NAT type @NinjaWarrior281

@Apsapie can you please add a report and some report codes please. This has now been added to our internal report and is with developers. Please continue to post reports so we can add this to our feedback for the team.

 

Any updates on the connection issues for xbox? Almost 2 weeks now and I’ve managed to play 2 online races? Everyone seems to be having the same problem? Your updates are shocking! Any idea when you’re going to fix this? I love single player but online is where I have the most fun! I’ve tried everything imaginable to get online working but always getting hit with the same WSC error code, sort it out!! 

  • Agree 3
Link to post
Share on other sites

same problem.

XBOX SX

NAT: Open

Forwarding ports: Yes, all set.

Error Code WS10047 or NS7

Sometimes I can connect during race to spectate but after race is finished, I`m alone in lobby.

Edited by C4B4
Link to post
Share on other sites
36 minutes ago, C4B4 said:

same problem.

XBOX SX

NAT: Open

Forwarding ports: Yes, all set.

Error Code WS10047 or NS7

Sometimes I can connect during race to spectate but after race is finished, I`m alone in lobby.

It’s so frustrating isn’t it. Like, they haven’t even said it’s their end. They’re constantly saying ‘what’s your error code, do this, do that’ yet no one has said it’s on our end. They’ve completed neglected F1 this year. It’s so sad. Paid £75 for this abysmal ****

Link to post
Share on other sites
15 hours ago, BDARacer said:

 

I had the same issues for days but I ended up forwarding the following ports on my router for my Xbox ip address, restarted my Xbox and it worked. Never had to do that for f1 2020.

https://portforward.com/f1-2021/

Well the problem is most of the users are using routers with UPnP, no manual port forwarding.

This is mostly the problem we have here.

Link to post
Share on other sites
On 7/24/2021 at 9:20 PM, rubens77 said:

Same problem here. Xbox X Series, can't join any multiplayer mode. I always get a WS10047 error after 1-2 minutes stuck un the joining lobby screen.

I have open Nat. No problems in other games so far.

Im having exactly same problems and I've signed upto league races and can't get into any of them 😡😡

Link to post
Share on other sites
On 7/20/2021 at 8:49 PM, Hoo said:

Hi All,

We've been investigating this report, but haven't been able to repeat this issue internally. 

For anyone affected by this issue, please could you provide the following information to help us understand how your network is configured:

  • Your country / region
  • Your ISP
  • Your connection type (phone, fiber, cable, etc.)
  • Your modem / router model
  • A summary of your network setup from your internet socket to your Xbox
  • The reported NAT type on your Xbox  

Additionally, we would like to enable some more logging for users affected by this issue that may help us to locate the cause of the problem. If you are happy to assist us with this then please send me a direct message that references this thread and letting me know that you are able to help. I will then provide you with further details.

Thanks.

Hi, 

My country is The Netherlands.

My ISP is Kpn.

My connection type is wireless.

My router model is Kpn Experia Box V10

I have my router downstairs which just connects via wifi to my xbox

My NAT type is open

Link to post
Share on other sites
58 minutes ago, Brahdz said:

It’s so frustrating isn’t it. Like, they haven’t even said it’s their end. They’re constantly saying ‘what’s your error code, do this, do that’ yet no one has said it’s on our end. They’ve completed neglected F1 this year. It’s so sad. Paid £75 for this abysmal ****

Yes, it is frustrating... Probably I will try for refunding if will not be fixed soon. I playing only breaking point story now... its better then I thought but anyway I bought game only for online playing... 

Link to post
Share on other sites
17 minutes ago, C4B4 said:

Yes, it is frustrating... Probably I will try for refunding if will not be fixed soon. I playing only breaking point story now... its better then I thought but anyway I bought game only for online playing... 

I’m NGL and jinx myself but I’ve just played 2 online races in a row - 0 problems??!!!!!

Link to post
Share on other sites

I have the same issues,

Cannot enter lobbies or get kicked off lobbies within minutes.

 

Now I play more than an hour with these settings

 

1. Xbox has a fixed ip 

192.168.0.17 in my case

In router and in Xbox Settings

2. DNS is 8.8.8.8 and 8.8.4.4 

(Public Google DNS)

3. Alternate Port 

In my case 49606

Screenshot_20210726-154849_Chrome.jpg

Screenshot_20210726-154910_Chrome.jpg

20210726_154921.jpg

  • Agree 1
Link to post
Share on other sites

This is getting ridiculous at this stage, no pit coin compensation could cover the loss of catching up the with community because of this issue. Why not reset the whole server and start again. Do something that will actually solve the problem. If you could do it the last few years with minor issues why now with this one 💁‍♂️

  • Agree 1
Link to post
Share on other sites
On 7/20/2021 at 8:49 PM, Hoo said:

Hi All,

We've been investigating this report, but haven't been able to repeat this issue internally. 

For anyone affected by this issue, please could you provide the following information to help us understand how your network is configured:

  • Your country / region
  • Your ISP
  • Your connection type (phone, fiber, cable, etc.)
  • Your modem / router model
  • A summary of your network setup from your internet socket to your Xbox
  • The reported NAT type on your Xbox  

Additionally, we would like to enable some more logging for users affected by this issue that may help us to locate the cause of the problem. If you are happy to assist us with this then please send me a direct message that references this th

This game is definitely broken. (Except single player) Online doesn't work 7 of the 10 times. We try to start and join and get host migration. And if it works then stupid **** like in this video happens. Or ridiculous penalty's for IA drivers that drive in to you for no reason at all. I'm starting to think to buy F1 2020 if this continues.

 

 

In this video räikkonen IA drives first full throttle in to mazespin. Then it hits me like a maniac and continues to hit people that are following the safety car. It's just ridiculous and it happens often that IA does dumb things like this 

  • Sad 1
Link to post
Share on other sites
On 7/26/2021 at 4:15 PM, Wlad2110 said:

I have the same issues,

Cannot enter lobbies or get kicked off lobbies within minutes.

 

Now I play more than an hour with these settings

 

1. Xbox has a fixed ip 

192.168.0.17 in my case

In router and in Xbox Settings

2. DNS is 8.8.8.8 and 8.8.4.4 

(Public Google DNS)

3. Alternate Port 

In my case 49606

Screenshot_20210726-154849_Chrome.jpg

Screenshot_20210726-154910_Chrome.jpg

20210726_154921.jpg

Doesnt work for me 😒 any other ideas?

Link to post
Share on other sites
6 minutes ago, C4B4 said:

Doesnt work for me 😒 any other ideas?

 

Try Connectivity Hotspot 2021 on your pc

 

Install it, then connect yourself to a vpn

Open a Wifi Hotspot and activate UPnP Server

Connect your Xbox to that Wifi Hotspot 

This also works for me.

Link to post
Share on other sites
On 7/26/2021 at 3:15 PM, Wlad2110 said:

I have the same issues,

Cannot enter lobbies or get kicked off lobbies within minutes.

 

Now I play more than an hour with these settings

 

1. Xbox has a fixed ip 

192.168.0.17 in my case

In router and in Xbox Settings

2. DNS is 8.8.8.8 and 8.8.4.4 

(Public Google DNS)

3. Alternate Port 

In my case 49606

Screenshot_20210726-154849_Chrome.jpg

Screenshot_20210726-154910_Chrome.jpg

20210726_154921.jpg

This has fixed my issue but only tested for a good 20 minutes or so. The issue is definitely related to the port setup with the consoles or something along those lines I don't think the DNS makes much of a difference although I haven't tested on automatic so bravo to this solution from my end 👌

Link to post
Share on other sites

Hello guys

First: I have this issue since 15 days and cannot be connected to any lobby for more than 2 minutes usually.

I also see a lot of WD10048 and ND7 issues errors.

 

If I let all settings on Standard or automatic it does what it does - disconnect and errors sometimes.

But with a few tweaks I was able to play in the last days. I even was able to play for several hours without any issue at all.

I think there could be several issues here.

1. I see most of us are using the Connect Box router. I see mine overheating often and this might cause that the router does not work properly, maybe it affects the UPnP function.

2. I also see that with a private ip you get that issue. Changing your xbox connection and tunneling your traffic through a vpn that uses a public ip does work for me.

3. Installing a hotspot app on the PC, connecting the Xbox with that Hotspot and turning on the UPnP-Server function inside the app does work also. This makes your PC work like a router.

 

Hope I can help you with that.

Link to post
Share on other sites

I "Fix" this problem by creating hotspot by my phone.:classic_mellow:

Router: on cable, 150Mb/s, latency ~28, Nat OPEN, UPnP enabeld, ports forwarded. DNS and port change doesnt help. Can`t play online F1 2021. But 2 years i dont have a problem with any other game... F1 2019 works good.

Phone`s hotspot: Nat MODERATE, UPnP disabled, ports isn`t forwarded. I Can play online F1 2021.

This doesnt make sense.

Edited by C4B4
  • Agree 1
Link to post
Share on other sites

I have tried using a hotspot from my laptop and I am still unable to play online. @BarryBL @Hoo when will you update us on this?! This is the worst experience I have had with a video game in 10 years. I still can’t believe this hasn’t been fixed. At this point I don’t have a choice but to ask for a refund. Unacceptable and what a shame on codemasters for releasing an unplayable mess. Definitely won’t be purchasing another f1 game in the future. Like another person said any compensation at this point won’t make up for it. What a joke 

Link to post
Share on other sites
  • steviejay69 changed the title to Unable to Join Any Online Sessions on Xbox Series X (Error Code WS10047 or NS7)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...