Jump to content Jump to content

Unable to Join Any Online Sessions on Xbox Series X (Error Code WS10047 or NS7)


Recommended Posts

I wanted to drive the weekly event (25% race Hungary)

First everything was fine, but 2 minutes within the race the host changed and I got kicked out of the lobby with Error Code WS10004

Xbox Series X, wired, IPv4 & IPv6, NAT type: open

Link to post
Share on other sites
  • A detailed description of the issue.

I was participating in the latest weekly event (Hungary), the lobby started with 20 racers and was down to 16 when the game kicked me out, citing "Cannot join session, you have no multiplayer privileges. Error code WS10004"  This was despite the fact I had reached lap 6/7 and was in the lead due to pit-stops.  This also happened earlier in the day, in my first attempt at the weekly event and reached lap 4 before it ended with the same message (I was in 2nd at the time).  I won't be trying it again and frankly reinforces my decision to avoid racing online in public lobbies in particular.

  • Report Code

RKJD-HXTG-JSPA-GTJG

  • Platform?

Xbox Series X, with a wired internet connection.  Open NAT.  No issues experienced on the previous F1 games or any other game using online functionality. UK based.

  • Game-mode?

Weekly event - Hungary

  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.

Started with 20 in the lobby, was down to about 15/16 after people started leaving.

  • [ONLINE] Were you the host?

No

  • [PC ONLY] Please post your DXDiag, including the make and model of motherboard.
  • What troubleshooting have you tried? Please list everything you tried.
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

I simply played the game......

Edited by JayWulf
Link to post
Share on other sites

Xbox one x Errorcode ND7. Nat open , all multiplayerstuff in right settings. Updated all i could update. 99% could not open any multiplayer session. 

Worst game ever bought. To many flaws in the normal mode. And Multiplayer weeks after launch is still messed up. How can you bring out a game like this where so many people have issues? The suggestions codemaster brings are a laugh.

Link to post
Share on other sites

Ok so... I bought this game second time as some ppl said its working now. Never had problems with that "game" in 2016, 2017, 2018 ,2019 they started last year after an patch.
I started getting kick off from game with an error code that I don't have access to xbox live don't really remember now. Anyway I bought this game... oh sorry not game.
It's an unfinished product that developers don't know how to fix and finish they only focus how to add stupid 3 colour helmet etc.

So I bought this Unfinished product called F1 2021 on day 1. Day after I claimed refund from Microsoft as had problems with multiplayer.
Just to make it clear I DONT HAVE ANY PROBLEMS WITH ANY OTHER GAME ONLY WITH THIS UNFINESHED PRODUCT SOLD FOR £60. 
Never had disconnections from game such us F1 2016-2019, Halo 5, Forza Motorsports, Forza Horisons, Assetto Corsa including Competizione.
Also on PC don't have any problems with multiplayer games.

So. Before I apply for second refund for this unfinished product I'll share my details so hopefully in 2030 you will fix the problem. 

On day 1 and day 2 had problems with Disconnections from game. Had following errors: 2631071469:S and WS10047 (Xbox Live had no issue that time and could play other games)

Friendly staff gave me refund and I forget about this "game" but have few friends trying to play this and they want me to play with them so I kept looking on issue. 
As I mentioned above I bought this unfinished product once again - you can call me Charles Leclerc as "I am stupid".

Today I can't even connect with lobby because game display Error NS7. I've tried all router settings, with port forwarding, static IP, dns bla bla bla just tried everything.
I don't have to do anything with my router to play other games - just to make it clear.

My all details :

 

  • A detailed description of the issue.
    as above, can't play this £60 unfinished product
  • Report Code
    Only Error Code as I can't get Report Code in game menu. NS7
  • Platform?
    Xbox Series X
  • Game-mode?
    Multiplayer
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    Can't even connect as
  • [ONLINE] Were you the host?
    No
  • What troubleshooting have you tried? Please list everything you tried.
    Everything with my router and xbox - ports,dns,upnp,dmz etc Ofcourse my Nat is open
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    Pointless
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    Turn on xbox - start F1 - social play - beginner friendly/experienced/browse/friend invite  - Unable to connect NS7
  • Your country / region
    UK, Manchester
  • Your ISP
    Three - Mobile 4G (had problem on Plusnet as well)
  • Your connection type (phone, fiber, cable, etc.)
    Wired to router, tried wireless. 
  • Your modem / router model
    Huawei B535-232
  • A summary of your network setup from your internet socket to your Xbox
    Not sure what you need
  • The reported NAT type on your Xbox  
    Open


Some more about my inernet connection
Download avrage speed 48.76 upload 28.17
Latency 28-58
Packet Loss 0%
MTU - 1386 (changed for different values did not help)
IPv4

Update : 
Get another refund from Microsoft. They have to know its an unfinished product so refund took only 5 minutes. Maybe I'll try once again at some point. Good luck fixing issue that not been fixed since 2020.

Edited by Shamball
Link to post
Share on other sites

In ranked play I cannot find any lobby at all now with the new patch 1.05

I see open lobbies, but entering is impossible, too

Will have to keep using the virtual router hotspot method to play

 

EDIT: worked after deleting cache and restart 

Edited by Wlad2110
Link to post
Share on other sites
  • steviejay69 changed the title to Unable to Join Any Online Sessions on Xbox Series X (Error Code WS10047 or NS7)
  • Codemasters Staff
On 7/31/2021 at 8:36 AM, Classicflaw said:

I have tried using a hotspot from my laptop and I am still unable to play online. @BarryBL @Hoo when will you update us on this?! This is the worst experience I have had with a video game in 10 years. I still can’t believe this hasn’t been fixed. At this point I don’t have a choice but to ask for a refund. Unacceptable and what a shame on codemasters for releasing an unplayable mess. Definitely won’t be purchasing another f1 game in the future. Like another person said any compensation at this point won’t make up for it. What a joke 

Hi @Classicflaw - we've got a post here about hotspots not working correctly:
 

Please can you respond on that thread with any additional info to help us track this hotspot issue down? In particular, we'd be interested in enabling increased logging to establish why this is failing for you.

Link to post
Share on other sites
On 7/31/2021 at 8:36 AM, Classicflaw said:

I have tried using a hotspot from my laptop and I am still unable to play online. @BarryBL @Hoo when will you update us on this?! This is the worst experience I have had with a video game in 10 years. I still can’t believe this hasn’t been fixed. At this point I don’t have a choice but to ask for a refund. Unacceptable and what a shame on codemasters for releasing an unplayable mess. Definitely won’t be purchasing another f1 game in the future. Like another person said any compensation at this point won’t make up for it. What a joke 

I have the same issue with my hotspot bud. Unable to play online at all. Know its not my hotspot being an issue as any other game and the previous F1 games its been fine. Have reported but for some reason theres a logging issue possibly because of my hotspot. Hoping next patch may do the trick but unsure as my report couldnt be successful

Link to post
Share on other sites

Xbox is even trying not to refund me seeing as the game does not work as intended and I'm in Australia they are in for a rude ACCC shock. 

I cannot get into any second mp race. It times out and had to be completely restarted after every online race. 

I thought we had another year before the EA became a problem but clearly not. 

I can't wait until ACCC fines both EA, codemasters and Xbox for refusal of refund under Australian consumer Law. I'll post the correspondence as it comes. 

 

 

YOU ARE BETTER THAN THIS CODIES. 

Link to post
Share on other sites
On 7/25/2021 at 10:42 PM, BDARacer said:

 

I had the same issues for days but I ended up forwarding the following ports on my router for my Xbox ip address, restarted my Xbox and it worked. Never had to do that for f1 2020.

https://portforward.com/f1-2021/

 

On 7/26/2021 at 2:20 PM, FentonGibbs said:

Im having exactly same problems and I've signed upto league races and can't get into any of them 😡😡

Solved! Try opening these ports for Xbox Series X.:

  • TCP: 3074
  • UDP: 88,500,3074,3544,4500

Thanks @BDARacer!!

Edit: Not working again. This has to be patched now, it's really frustrating.

Edited by rubens77
Update
  • Haha 1
Link to post
Share on other sites
On 8/3/2021 at 12:32 PM, Hoo said:

Hi All. We have some fixes in test that are scheduled for release in our next patch (v1.06). We believe these should resolve some of the issues around NAT traversal and IPv6 connections that are being reported here. However, we can't yet confirm if this will resolve the NP7 errors. Please continue to provide info in this thread and we will keep feeding this to the dev team. In particular, please look out for particular session hosts that you cannot connect to from a fresh launch of the game. Video footage showing the session joining process from the multiplayer menus would be very useful too, along with report codes for your session.

If you notice that you are unable to connect to a specific host, but can connect to other lobbies normally, then please let us know (@Hoo and @BarryBL). We are keen to identify these players to request their assistance in tracking down the cause of this issue!

Any ideas when this patch will be coming out? Kind of want to play online 💁‍♂️

Link to post
Share on other sites

Can connect manually to every single lobby and not getting disconnected, also other people can join my lobby.

Issue is only if I decide to join by that automatic search, unable to connect and after few minutes display error. NS7.

I don't really care about public random lobby's  so as long manual connection works I'm happy. 

Tested with router settings as requested and with default settings. In both scenario works same way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...