Jump to content

Archived

This topic is now archived and is closed to further replies.

Dirt Rally - GRAPHICS BUG on longer stages

Recommended Posts

Just an info, 15.11 Beta drivers don't fix the problem. It appears that they are even making things worse.

Share this post


Link to post
Share on other sites
This is not an obscure bug,  my PC under windows 10 and incidentally I had to go back to using windows 8.1 and i still get this stuttering in the game under windows 8.1 as well.
Since the game was released as a public beta, I had no problems with the graphics, I've had all settings on ultra and was getting over 80 fps.  Since the last update,  the masters update,  this stuttering has occurred,  no matter if they're short or long stages.  I'm still getting high frame rates, but a constant stutter,  the same as what's happening in the above video clips.

I have already tested the above possible solution in relation to reducing the shader quality,  and it made no difference at all. 

I am also having problems with one of the most common bugs that have occurred in every version of dirt, race driver and grid over the last 15 years, and that is after  you have configured your control presets and have saved them,  the next time you go into the game you have lost your settings and have to reconfigure the controller settings again.

I would've thought you guys at  Codemasters would at least resolve this bug after 20 years of developing racing games.  Where's the quality control and internal testing of the game!

This is definitely a bug or same bad coding since the last update.  I too have installed the latest Nvidia graphics,  and as I mentioned,  I have had no issues with the game up until the last update.

Share this post


Link to post
Share on other sites
Installed latest stable Radeon drivers - Crimson driver.
Tried one long run on Geufron forest, no artifacts, a noticeable 10-20fps boost.

I'll play some more when I find the time, but so far it seems promising, although the [423378] bug wasn't on the resolved list.

EDIT: Spoke to soon, still got artifacts. It looks somewhat better at rally, but still the same at hill climb.

Share this post


Link to post
Share on other sites
UPDATE well i was waiting for something to change. I've been suffering with this graphics glitch for a while. I also installed the newest Radeon Drivers and at first i thought it was fixed. Then into a long run it came back? it seems to be random. can this please be fixed? 

Share this post


Link to post
Share on other sites
It's very hard to play sometimes . Radeon HD 7770, Crimson 15.12 Drivers, Windows 10 64bit. 

Share this post


Link to post
Share on other sites
@buneech there is not

I think this issue is a AMD windows 10 driver bug, does it occur with the latest beta drivers? 
It's an AMD thing, but not just Windows 10, I had occassional transparent textures (and sometimes black textures) back when I still had Windows 8.1

Share this post


Link to post
Share on other sites
Having the same issues, blank textures in some spots of the road, more frecuently in long stages. Very annoying, makes the game unplayable in some stages :(


Windows 10 - Intel i5 4690 - XFX Radeon 7750R

Share this post


Link to post
Share on other sites
I have the same problem with windows 10 to... I found a fix for me, not sure it could helps other. You have to play in windowed mode at the native resolution of your monitor.

I tried many things, sometimes it goes away but come back. Note: you must reload the track in windowed mode, otherwise the corruption will stay (if you try it live).

Maybe there is something different in windows 10 full screen that the developers didn't know about. I have also seen those flickering textures in Fallout 4 with the new Crimson driver, so it could be a combination of two thing. I have kept 15.10 beta driver for now. 

Share this post


Link to post
Share on other sites
(Message repeat from my other discussion)

Last drivers for AMD broke the textures on Dirt Rally. After trying so much, i decided to go back and install last beta drivers of CATALYST, again, last update for catalyst driver. Now exist other name("Crimson"), but for play on DR you need the catalyst drivers, it's fully compatible with W10, W8.1, W7 ...

LINK:http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx
Tell me if it works, i already have some random bugs, but in general works so better than "Crimson" drivers 
Xavier.

Share this post


Link to post
Share on other sites
bamam said:
It's very hard to play sometimes . Radeon HD 7770, Crimson 15.12 Drivers, Windows 10 64bit. 

I have the same issue as bamam. My GPU is too a HD 7 series Radeon.
Playing with
  • GPU: Radeon HD 7870 2GiB VRAM in 1080p and 4K (Dual monitor setup)
  • RAM: 8GiB
  • CPU: Intel Xeon e3-1231v3
  • Driver Version 15.201.1151.1008-151104a. Crimson caps my 4K @ 30fps, idk why...
  • Windows 10 x64 build 10240


Regards.

Share this post


Link to post
Share on other sites
Have the same Problem with the AMD 7770 or R7 200 Series.  

Video Link: http://www.youtube.com/watch?v=-mqM3IkTLlM

In this case I read this card type very often. Radeon Settings Version
2015.1223.1060.19763. Codemasters: "Plz do something, I'm not the only one with a HD 7770."

GPU: HD7770 1GB 
RAM: 8GB
CPU: AMD Athlon x3 440 3Ghz
Crimson 16.1
Windows 10 Pro Upgrade

Share this post


Link to post
Share on other sites
dgr2k8 said:
bamam said:
It's very hard to play sometimes . Radeon HD 7770, Crimson 15.12 Drivers, Windows 10 64bit. 

I have the same issue as bamam. My GPU is too a HD 7 series Radeon.
Playing with
  • GPU: Radeon HD 7870 2GiB VRAM in 1080p and 4K (Dual monitor setup)
  • RAM: 8GiB
  • CPU: Intel Xeon e3-1231v3
  • Driver Version 15.201.1151.1008-151104a. Crimson caps my 4K @ 30fps, idk why...
  • Windows 10 x64 build 10240


Regards.
Have you tried updating GPU drivers / updating Windows? Also, have you overclocked your GPU? (might be an unstable overclock), also what are the temps? I have the same GPU and havent seen so severe glitches, I just have the occasional black/transparent textures

Share this post


Link to post
Share on other sites
I don't have any overclocked components. All Software (WIndow 10, Grafic, etc) is the latest. I will try an older driver version of catalyst now. Maybe I try Windows 7 instead of Windows 10 next.

Share this post


Link to post
Share on other sites
I don't have any overclocked components. All Software (WIndow 10, Grafic, etc) is the latest. I will try an older driver version of catalyst now. Maybe I try Windows 7 instead of Windows 10 next.
I don't think it's a problem with windows. Are you getting these graphic glitches only in DiRT or in other games too? If yes, then there might be something wrong with your GPU. If you can get your hands on another GPU (borrow from someone), you could check to see it it's the gpu's fault

And you said:
  • Driver Version 15.201.1151.1008-151104a. Crimson caps my 4K @ 30fps, idk why...
  • Windows 10 x64 build 10240
The latest AMD driver version is 16.1 and the latest Windows 10 build is 10586.63 (if you have those versions now, then sorry)

Share this post


Link to post
Share on other sites
@Didzis It was said by @DeputyDiRT that this is a bug in the AMD driver for Windows 10, and it apparently doesn't affect all graphics cards, nor all AMD graphics cards used with Windows 10.

And the bug affects only Dirt Rally, other games are fine.

Share this post


Link to post
Share on other sites
buneech said:
@Didzis It was said by @DeputyDiRT that this is a bug in the AMD driver for Windows 10, and it apparently doesn't affect all graphics cards, nor all AMD graphics cards used with Windows 10.

And the bug affects only Dirt Rally, other games are fine.

It's just that I also have a 7870 and havent had anything like that, but maybe it just differs even between different cards of the same model

Share this post


Link to post
Share on other sites
Didzis said:
buneech said:
@Didzis It was said by @DeputyDiRT that this is a bug in the AMD driver for Windows 10, and it apparently doesn't affect all graphics cards, nor all AMD graphics cards used with Windows 10.

And the bug affects only Dirt Rally, other games are fine.

It's just that I also have a 7870 and havent had anything like that, but maybe it just differs even between different cards of the same model
Could be, I have a R9 285, and have that problem.

Share this post


Link to post
Share on other sites


And you said:
  • Driver Version 15.201.1151.1008-151104a. Crimson caps my 4K @ 30fps, idk why...
  • Windows 10 x64 build 10240
The latest AMD driver version is 16.1 and the latest Windows 10 build is 10586.63 (if you have those versions now, then sorry)
@Didzis You quoted from the wrong message. It wasn't me with this constellation, but dgr2k8 on January 13. I have the latest versions.


Share this post


Link to post
Share on other sites
@buneech
So there's no bug using windows 7. Till the problems are solved this would be fine for me. Not the first problem with windows 10.
 








Share this post


Link to post
Share on other sites
Are you using windows 10? Is so its a known AMD driver issue as mentioned in the driver release notes:
  • [423378] Dirt Rally™ may show corruption in game textures after installing the V500 game update
@Stevewonder This was written by DeputyDiRT, so apparently it's Windows 10 related.

Share this post


Link to post
Share on other sites
This is not an obscure bug,  my PC under windows 10 and incidentally I had to go back to using windows 8.1 and i still get this stuttering in the game under windows 8.1 as well.
Since the game was released as a public beta, I had no problems with the graphics, I've had all settings on ultra and was getting over 80 fps.  Since the last update,  the masters update,  this stuttering has occurred,  no matter if they're short or long stages.  I'm still getting high frame rates, but a constant stutter,  the same as what's happening in the above video clips.

I have already tested the above possible solution in relation to reducing the shader quality,  and it made no difference at all. 

I am also having problems with one of the most common bugs that have occurred in every version of dirt, race driver and grid over the last 15 years, and that is after  you have configured your control presets and have saved them,  the next time you go into the game you have lost your settings and have to reconfigure the controller settings again.

I would've thought you guys at  Codemasters would at least resolve this bug after 20 years of developing racing games.  Where's the quality control and internal testing of the game!

This is definitely a bug or same bad coding since the last update.  I too have installed the latest Nvidia graphics,  and as I mentioned,  I have had no issues with the game up until the last update.
Seems to be on windows 8, too. Mmh.

Btw I also have this "not saving control settings, whe using hotkey for pause on the wheel" bug. Is there a connection? ;-)

Share this post


Link to post
Share on other sites
First testing on Windows 7 with older driver 14.12 AMD Catalyst Omega Software. Seems to work without bugs.. I do not dare to install the latest driver.  At least a possibility to play the the game till Codemasters has fixed the problem which I would appreciate. 

Share this post


Link to post
Share on other sites
Any update to this? I too am experiencing the exact same issues where i am not able to complete a longer rally. I have a HD 7790 MSI edition, havent OC'd it, running on Win10Pro. This is completely ruining my gaming experience. Im really not up for reverting back to Win7 just so i can play one game

Share this post


Link to post
Share on other sites
Why-o-why will this game not work. Firstly I had the " Steam servers are busy error code 41" issue. I contacted support and was denied help as I was running Dirt Rally on Mac in Boot Camp. After a lot of forum searching and messing around I got it running. It ran with great graphics on a 27" screen, that is until the stuttering started. I contacted support again and you've guessed it, support was denied. Got on to the forums once more and tried many things, none of which worked. A lot seemed to centre around the steering wheel, I tried using an Xbox controller, no stuttering. Having spent so much time on the forums there are many of us having these issues, and many are on Windows Pc's, so I don't see the difference. Why doesn't support at least try and help us.
I run two other driving games, one is a Codemasters game, and both run silky smooth, so the problem has to be in Dirt Rally. ( Or Windows 10 )
I'm not the only person running Dirt Rally in Boot Camp, I've seen the forums and YouTube clips.
Hopefully one day Codemasters might get their act together and sort it out with an update, anyway in the meantime I'm off to play Asseto Corsa. 

Share this post


Link to post
Share on other sites

×