Jump to content Jump to content

No safety car since patch 1.07


Recommended Posts

Hello ever since patch 1.07 was released I have noticed the safety car no longer comes out and the AI no longer crash I’ve had a couple of big crashes with the AI to test if it would trigger it but I've had nothing. I’m currently in my 2nd season and haven’t had a single safety car, in my first season the safety car came out a lot and it mixed up the race quite a lot. Anyone else noticed this ? I have safety car to increased and collisions on with AI set to 86. 

Link to post
Share on other sites

Yes the same to me. Until 1.07 I have SC and VSC. With this 1.07 patch they ****** up the game and now the game is so boring. I noticed also that after 1.07 the AI is "perfect" no crashes, no collisions, no retirements. For example I will tell you that in Austria I always had 2 Safety cars this was before 1.07 and now nothing, not even one retirement. I am talking and playing career mode. That is why I stopped playing this game.

MASTERS fixed this problem or bug, please!!!

Link to post
Share on other sites
2 hours ago, Silverchris said:

Lucky you I see safety car way too often. Check your settings though cause in 2020 edition the safety car setting kept changing to off for me even though I always had it set to on.

I have checked and it stays on but I was thinking maybe the patch has affected it. Seems to be every time a patch is released it breaks something else 🙄

Link to post
Share on other sites

I have it on reduced and still safety car has deployed with what you would expect.. 

I’m not sure it has same effect on ai as it does me.  but have car damage and damage rate also set to simulation seems to increase ai receiving terminal damage resulting in safety car

  • Agree 1
Link to post
Share on other sites
19 hours ago, mykalboi said:

I have checked and it stays on but I was thinking maybe the patch has affected it. Seems to be every time a patch is released it breaks something else 🙄

Haha . Funny enough . From 17 to 19 game . I had a problem with the safety car and patches . The would fetch a patch out . And I wouldent see a sc till the next patch cane out then I would get it again . It just kept going like that . For some reason . 

  • Agree 1
Link to post
Share on other sites

I've been having rare safety cars since day one. Even on Increased.

Just like 2020.

Just like 2019.

It's clear there's something fundamentally weird in how the SC deployment is programmed.

  • Agree 1
Link to post
Share on other sites
17 minutes ago, Blent said:

I've been having rare safety cars since day one. Even on Increased.

Just like 2020.

Just like 2019.

It's clear there's something fundamentally weird in how the SC deployment is programmed.

Definitely agree I also think they should add the red flag 

Link to post
Share on other sites
On 9/4/2021 at 3:10 PM, mykalboi said:

I have checked and it stays on but I was thinking maybe the patch has affected it. Seems to be every time a patch is released it breaks something else 🙄

Agree totally at times it seems they fix 1 thing and break 2 more

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...