Jump to content

Archived

This topic is now archived and is closed to further replies.

Updated framerate issue -- MS Sidewinder wheel cuts FPS in half

Recommended Posts

Update -- Sorry to change the thread title, but this seems more appropriate now.

I've discovered that unplugging my steering wheel, which is a MS Sidewinder FFB, ups the framerate to 80-85 on average, from 41 average with the wheel plugged in.

I'm suspecting I'm just out of luck here with a nearly-two-decade-old wheel and drivers from 10 years ago, but it's frustrating, because other than this the wheel works really well in game --  good feedback, no input lag.

I've read in forums on some other games that reducing the polling rate for feedback can help with these issues, but that doesn't seem to be an option here.

Original post, mostly irrelevant now, remains below.

--------------------------------------------------

I'm running into a weird FPS "cap" around 41-42 fps, with GPU usage nowhere near maxed.
In fact, with everything on ultra, 1920x1080, advanced blending off, GPU usage is between 45-50 percent.

Lowering settings only reduces GPU usage more.

Thought it was a CPU bottleneck, but increasing CPU clock doesn't give any framerate boost (I actually have significant headroom to OC CPU if it would help). None of the CPU cores is ever above 70 percent usage.

Nothing is hot, in fact, nothing is even near normal gaming temperatures, GPU or CPU.

Specs below, if anyone has a guess where the bottleneck is, or any other ideas what's causing this.

GIBABYTE GA-970A-D3
AMD FX-6300 @ 4.0 Ghz (this is just a straight multiplier overclock, with normal vcore and stock memory and HT speeds)
ASUS Strix GTX960 w/4GB
8GB 1600 DDR3
Win 7 x64

Let me know if I'm leaving anything out that might be relevant.

Share this post


Link to post
Share on other sites
BTW, I can't compare performance to any previous versions, because I just bought the game after the most recent patch.

Share this post


Link to post
Share on other sites
Apparently still not fixed.

Bought the game yesterday and was pretty confident the SideWinder wheel would work since it's officially supported and works fine in Dirt 3. I, too, see the magic 41-42 fps drops when the wheel is plugged in, rendering the game unplayable. Game runs smoothly without wheel connected (90 fps minimum on ultra, no worries there). We're not the only ones having this problem (https://steamcommunity.com/app/310560/discussions/0/523890046868696527/) and it seems to be related to a too high polling rate for force feedback that the SideWinder (or its driver) cannot handle. By the way, I'm on Win 10 x64 using Microsoft's bundled driver.

For now, I play with an Xbox One controller. 

I hope Codemasters are reading this and they either fix the issue or drop official support for the device...

Share this post


Link to post
Share on other sites

I have exactly the same problem. With my wheel connected on LOW settings I got AVG FPS of 73 and MIN FPS of 38. So huge drops.

Without wheel connected on ULTRA settings with 4F8X EQAA Anti Aliasing, I got AVG FPS 92 and MIN FPS of 70. This really makes it impossible to play with my wheel :( Hope they can fix it soon.

Specs:

Core i7 920 @ 3,5GHz (HT on)

12 GB DDR3 1600MHz

AMD Radeon R9 290 @ 1080MHz core/1250MHz mem

Asus P6T

OS installed on SSD (OCZ Vertex 4). Dirt Rally installed on 2 RAID-0 HDD's.

Microsoft Sidewinder Force Feedback Wheel

PS: I have also sent a message to their support mailbox, with the url of this forum link included.

Share this post


Link to post
Share on other sites

×