Jump to content Jump to content

F1 2019 doesn't launch


Recommended Posts

As the title suggests the game doesn't launch at all. I click play on steam a few seconds it looks like it's running and then it says play like i closed the game or something. I'm on latest NVidia drivers and this is the only game which causes me problems. I am not using any accessories and i have tried solutions from this thread F1 2019 won't start / launch *(Solved)* - Technical Assistance - Codemasters Community and i also can't start the game in safe mode. Any tips?

DxDiag.txt

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...