Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×

Archived

This topic is now archived and is closed to further replies.

[SOLVED] G27 suddenly not detected anymore

Recommended Posts

Hi! :)

Now I've got a major issue. I've had the game since Day 1 of early access, my G27 have worked flawless all this time.
Today, DiRT Rally suddenly didn't detect my wheel, and no matter what I do, the game does not detect my steering wheel. It detects my keyboard, it detects any gamepad I plug in, just not my wheel.
This goes for DiRT Showdown as well, but in every other game my wheel get's detected, it can be rFactor, Stock Car Extreme, GTR, Richard Burns Rally, Off-Road Drive etc. Even in F1 2012, but with no feedback.
So the issue is solely for Codemasters games, and just happened today.
There has been no change on my PC from yesterday to today, no drivers, nothing installed, nothing removed.

Share this post


Link to post
Share on other sites
What does device manager show? Select "view" and click "show hidden devices". Open "human interface devices" tree....what do you see? If you see GT or G27 "ghost" items (light grey) select uninstall and check off delete box,...uninstall, Uninstall Logitech Gaming software, then unplug your wheel. Reinstall LGS with the wheel disconnected until it asks you to reconnect (wait for the drivers to reinstall).

Did this help?

P.S. Make sure you are online with Steam before launching DR, select G27 preset, apply and fully calibrate wheel in the in-game menus.

Share this post


Link to post
Share on other sites
No, as I said, every single thing on my PC, except DiRT Rally and DiRT Showdown recognized my G27, the device manager, Gaming Software, any other driving game, even GTA V.
Now, the problem was GeForce Experience that for some reason decided to F things up. I re-installed an older version, and everything works perfect not. I will mark it solved :)

But thanks for your answer anyway :)

Share this post


Link to post
Share on other sites
Good to know.

P.S. FYI Windows 10 "force installs" the oem drivers for your hardware,...so make sure and disable auto driver updates in Advance System Settings when you are uninstalling and installing newer drivers. you can turn it back on after.

Share this post


Link to post
Share on other sites
Glad I'm staying with Win 8 as long as I can then... I don't like all the automagical stuff in Win 10!

Share this post


Link to post
Share on other sites

×