Jump to content Jump to content

Xbox - Logitech G920 - choppy force feedback


Recommended Posts

I am experiencing an issue with my Logitech G920 on Xbox Series X where the force feedback is what I can only describe as choppy and input glitchy. This is only happening in the f1 2021 game of late and has made the game pretty unplayable with the G920. 

love the game and would be thrilled to have this resolved!

Link to comment
Share on other sites

  • Administrator


Thanks for reporting your issue. However, we do need a complete bug report to gain all the details needed to replicate and troubleshoot your issue. Please copy and paste the template from the below and fill in the answers.


Providing this information is vital for Codemasters to be able to investigate, replicate and hopefully solve your issue. Without this, we don't have the necessary information to replicate and diagnose the issue.

have you updated your firmware via a PC

Many thanks

Link to comment
Share on other sites

  • A detailed description of the issue. - the force feedback going to my Logitech g920 has been extremely choppy. The higher the force feedback is turned up the worse it gets. 
  • Report Code - no report code as it is a gameplay issue. 
  • Platform? - Xbox Series X
  • Game-mode? - Every game mode
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
  • [ONLINE] Were you the host?
  • What troubleshooting have you tried? Please list everything you tried. - I have tried to restart the game and my console as well as unplugging the wheel. 
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. - I can record a clip of the problem later today if that helps. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible. - this problem occurs when going into any game mode when on track. My set up is the Logitech g920 plugged into the Xbox series x via USB. 
Link to comment
Share on other sites

26 minutes ago, UltraSwish said:

I have updated the firmware and am still having this issue. Every other racing game I play doesn’t have this issue including the previous title (F1 2020). 

Try changing the performance mode in game.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...