Jump to content Jump to content

Xbox - Logitech G920 - choppy force feedback


Recommended Posts

I am experiencing an issue with my Logitech G920 on Xbox Series X where the force feedback is what I can only describe as choppy and input glitchy. This is only happening in the f1 2021 game of late and has made the game pretty unplayable with the G920. 

love the game and would be thrilled to have this resolved!

Link to post
Share on other sites
  • Administrator

Hi,

Thanks for reporting your issue. However, we do need a complete bug report to gain all the details needed to replicate and troubleshoot your issue. Please copy and paste the template from the below and fill in the answers.

https://forums.codemasters.com/topic/79610-bug-reporting-template-all-modes/

Providing this information is vital for Codemasters to be able to investigate, replicate and hopefully solve your issue. Without this, we don't have the necessary information to replicate and diagnose the issue.

have you updated your firmware via a PC


Many thanks
Barry
 

Link to post
Share on other sites

  • A detailed description of the issue. - the force feedback going to my Logitech g920 has been extremely choppy. The higher the force feedback is turned up the worse it gets. 
  • Report Code - no report code as it is a gameplay issue. 
  • Platform? - Xbox Series X
  • Game-mode? - Every game mode
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
  • [ONLINE] Were you the host?
  • What troubleshooting have you tried? Please list everything you tried. - I have tried to restart the game and my console as well as unplugging the wheel. 
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. - I can record a clip of the problem later today if that helps. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible. - this problem occurs when going into any game mode when on track. My set up is the Logitech g920 plugged into the Xbox series x via USB. 
Link to post
Share on other sites
6 hours ago, UltraSwish said:

 

 

  • A detailed description of the issue. - the force feedback going to my Logitech g920 has been extremely choppy. The higher the force feedback is turned up the worse it gets. 
  • Report Code - no report code as it is a gameplay issue. 
  • Platform? - Xbox Series X
  • Game-mode? - Every game mode
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
  • [ONLINE] Were you the host?
  • What troubleshooting have you tried? Please list everything you tried. - I have tried to restart the game and my console as well as unplugging the wheel. 
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. - I can record a clip of the problem later today if that helps. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible. - this problem occurs when going into any game mode when on track. My set up is the Logitech g920 plugged into the Xbox series x via USB. 

 

On 9/13/2021 at 4:46 PM, BarryBL said:

have you updated your firmware via a PC

Use GHub to update the firmware on a PC. There is an update for the G920 (not recent AFAIK, but lots of wheels never connected to PC won’t have it). 

Link to post
Share on other sites
26 minutes ago, UltraSwish said:

I have updated the firmware and am still having this issue. Every other racing game I play doesn’t have this issue including the previous title (F1 2020). 

Try changing the performance mode in game.

Link to post
Share on other sites
1 hour ago, UltraSwish said:

I have updated the firmware and am still having this issue. Every other racing game I play doesn’t have this issue including the previous title (F1 2020). 

Have you tried completely powering off the console and trying a different USB port? 

Similar to XBox, completely powering down and not snoozing the console can work wonders.

1 hour ago, RLLL said:

Try changing the performance mode in game.

Another good idea. It's basically two different games by the sound of it.

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...