Jump to content Jump to content

SOLVED: Got VR and 4 Buttkickers Working Oculus Bass Shaker


Recommended Posts

Odd title for search terms.

I run an Oculus Quest 2 and a cockpit with 4 ButtKicker Bass Shakers using Simhub software. Yay me (freakin' AWESOME FYI). So When I first install, NO force feedback in Wheel or Shakers even though SimHub has "configured" itself it detected the game once, then zippo. I also run IRFFB software for iRacing. Also getting VR running was a runaround. Finally, once I did get the shakers going, if you Recover your car it stops sending telemetry to the shakers. So here is how I got all three to work consistently.

VR: I run Oculus Quest 2 and use Virtual Desktop to connect to my PC. Very reliable high bandwidth connection. I need to launch Steam VR and launch DR from the Steam VR Home. It is very easy to try to start multiple instances of the game at the "press enter or start" menu. It seemingly just don't work even though you see it in VR. What is happening is the game "surrenders focus" like you alt-tabbed out of it. So you need to peek out under the headset and alt-tab back into the game, or click in its window with your mouse. Now the controller (likely wheel) will work in VR.

FFB: Exit IRFFB from the systray if you run it. Be sure to calibrate your wheel and load the profile for your brand. The profile loading utility is a separate button next to calibrate. Triangle button for Playstation G27.

Bass Shakers: I had to change the UDP port that SimHub Listens for telemetry data on, and set the matching number in the DR config file: hardware_settings_config_vr.xml
found in C:\Users\YOURUSERNAME\Documents\My Games\DiRT Rally 2.0\hardwaresettings
by adding/changing the following line:

<udp enabled="true" extradata="3" ip="" port="20820" delay="1" />

The port is the UDP port and I changed it to 20820 from 20277. It can be any number but I recommend keeping the format. After this, SimHub showed "not configured" error and I figured it was just seeing I changed the UDP port and ignored the message as I figured it would just set it back to default 20277. No worky. So I hit configure and SimHub configured itself and kept my new port.

Once I did that and restarted the system, (shut down IRFFB) and then VR, Wheel FFB and Bass Shaker FFB all working for awesome Rally Action! The shakers only turn on when the event actually starts and now turn on when expected consistently! Hope this helps someone.

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...