Jump to content

Archived

This topic is now archived and is closed to further replies.

v0.80 Stuttering Bug

Recommended Posts

Apologies to all, it would appear we broke some stuff in v0.80! Mostly in the CPU detection and worker map code - and it probably is the cause of a lot of the stuttering problems people have reported in v0.80.

We have a fix for v0.90, but if you're experiencing stuttering in v0.80, and you weren't in v0.70 or earlier, there is a potential fix you can attempt right now.


First of all, only proceed if you:

A - Are confident editing XML files.
B - Know how many physical cores your machine has, (not logical, physical).

If not, just wait for v0.90.


Instructions
Open Steam.
Go to Library.
Right Click DiRT Rally, click Properties.
Open the LOCAL FILES tab.
Click the BROWSE LOCAL FILES... button — this takes you to a DiRT Rally folder.
Open the system folder.
Make a copy of hardware_settings_restrictions.xml — if anything goes wrong, you can just revert to the copy.
Open hardware_settings_restrictions.xml in notepad.

Select all the text and delete it!

Paste this in:

<?xml version="1.0" encoding="UTF-8" ?>
<hardware_settings_restrictions>
  <cpu>
    <restrict_info>
      <restrict_if name="physicalCores" op="int_ge" value="1">
        <restrict_add>
          <!-- <threadStrategy workerMapFile="system/workerMap2Core.xml"  forceFeedbackProcessor="1" dvdStorageProcessor="1" dataSetMonitorProcessor="0" renderProcessor="0" updateProcessor="1" fileStreamProcessor="1" /> -->
          <!-- <threadStrategy workerMapFile="system/workerMap3Core.xml"  forceFeedbackProcessor="2" dvdStorageProcessor="2" dataSetMonitorProcessor="0" renderProcessor="0" updateProcessor="1" fileStreamProcessor="1" /> -->
          <threadStrategy workerMapFile="system/workerMap4Core.xml"  forceFeedbackProcessor="3" dvdStorageProcessor="3" dataSetMonitorProcessor="1" renderProcessor="0" updateProcessor="2" fileStreamProcessor="3" />
          <!-- <threadStrategy workerMapFile="system/workerMap6Core.xml"  forceFeedbackProcessor="4" dvdStorageProcessor="5" dataSetMonitorProcessor="1" renderProcessor="0" updateProcessor="2" fileStreamProcessor="3" /> -->
          <!-- <threadStrategy workerMapFile="system/workerMap8Core.xml"  forceFeedbackProcessor="6" dvdStorageProcessor="7" dataSetMonitorProcessor="4" renderProcessor="0" updateProcessor="2" fileStreamProcessor="5" /> -->
        </restrict_add>
      </restrict_if>
    </restrict_info>
  </cpu>
</hardware_settings_restrictions>

This file controls the threading map for the game, based on the number of physical cores you have, and is horribly broken right now.

You need to choose the strategy that matches your physical core count. This example has the 4 core map commented in. If you have 4 physical cores, just save the file. If not, comment in the strategy that makes the most sense for your number of physical cores, and comment the 4 core map out.

Save the file and run DiRT Rally.
When you get to the main menu, and the autosave spinner is gone, close the game.

To test whether this has worked, open the following file:
C:\Users\<YOUR_USER_NAME>\Documents\My Games\DiRT Rally\hardwaresettings\hardware_settings_config.xml

It should have the threadstrategy workerMapFile that you specified in hardware_settings_restrictions.xml somewhere near the top.

Run the game again and check whether it stutters, especially if it began stuttering in v0.80.

If anything goes wrong, revert to your back up file.


I hope that fixes the stuttering for the people who have been affected since v0.80.

Share this post


Link to post
Share on other sites
Thank you. Will test and report back. Do we have to delete the existing hardware_settings_config.xml or will it be overwritten?

Share this post


Link to post
Share on other sites
Thank you. Will test and report back. Do we have to delete the existing hardware_settings_config.xml or will it be overwritten?
That gets generated each time you run. hardware_settings_restrictions.xml is key, as it has the rules for picking the strategy.

Share this post


Link to post
Share on other sites
Thank you. Will test and report back. Do we have to delete the existing hardware_settings_config.xml or will it be overwritten?
That gets generated each time you run. hardware_settings_restrictions.xml is key, as it has the rules for picking the strategy.
Came up perfect! Thank you. Should we be concerned about the hardware_settings_info file as well? This is what mine is showing after loading and NOT playing,...just exit after first load.

<?xml version="1.0" encoding="UTF-8" ?>
<hardware_settings_info>
    <systemInfo OS="Microsoft Windows 8  (Build 9200)" totalMemory="16713172" winPlatformID="2" winMajorVersion="6" winMinorVersion="2" rating="4" />
    <cpu name="Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz" speed="3500" physicalCores="1" logicalCores="8" hyperThreading="true" sse3Supported="true" avxSupported="true" rating="2" />


Share this post


Link to post
Share on other sites
Thank you. Will test and report back. Do we have to delete the existing hardware_settings_config.xml or will it be overwritten?
That gets generated each time you run. hardware_settings_restrictions.xml is key, as it has the rules for picking the strategy.
Came up perfect! Thank you. Should we be concerned about the hardware_settings_info file as well? This is what mine is showing after loading and NOT playing,...just exit after first load.

<?xml version="1.0" encoding="UTF-8" ?>
<hardware_settings_info>
    <systemInfo OS="Microsoft Windows 8  (Build 9200)" totalMemory="16713172" winPlatformID="2" winMajorVersion="6" winMinorVersion="2" rating="4" />
    <cpu name="Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz" speed="3500" physicalCores="1" logicalCores="8" hyperThreading="true" sse3Supported="true" avxSupported="true" rating="2" />


Nope, you can see where it has decided you have 1 physical core though, the source of the problem.

Works you say? Then I'm going to get me a beer! :D

Share this post


Link to post
Share on other sites
Thank you. Will test and report back. Do we have to delete the existing hardware_settings_config.xml or will it be overwritten?
That gets generated each time you run. hardware_settings_restrictions.xml is key, as it has the rules for picking the strategy.
Came up perfect! Thank you. Should we be concerned about the hardware_settings_info file as well? This is what mine is showing after loading and NOT playing,...just exit after first load.

<?xml version="1.0" encoding="UTF-8" ?>
<hardware_settings_info>
    <systemInfo OS="Microsoft Windows 8  (Build 9200)" totalMemory="16713172" winPlatformID="2" winMajorVersion="6" winMinorVersion="2" rating="4" />
    <cpu name="Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz" speed="3500" physicalCores="1" logicalCores="8" hyperThreading="true" sse3Supported="true" avxSupported="true" rating="2" />


Nope, you can see where it has decided you have 1 physical core though, the source of the problem.

Works you say? Then I'm going to get me a beer! :D
I think im a bit lost... so, if you get physicalCores="1" at hardware_settings_info.xml is wrong or correct?

Share this post


Link to post
Share on other sites
v0.80 will always report 1 physical core in hardware_settings_info.xml, it's hardware_settings_config.xml you want to check.

Share this post


Link to post
Share on other sites
v0.80 will always report 1 physical core in hardware_settings_info.xml, it's hardware_settings_config.xml you want to check.
Then I have the workerMap4Core.xml running according to my i7.

Thanks, cheers! (have another beer!)

Share this post


Link to post
Share on other sites
This did nothing for me unfortunately. Still the same issue with the rhythmic stuttering in menus and in game whenever my G27 is connected. Feels strange that this should have anything to do with CPU identification, but I have confirmed that workerMap4Core.xml is now in use. Did you change anything to do with input handling? Seems to affect a lot of Logitech wheel users. I got rid of it once after fooling around with Logitech driver reinstall and calibrating in game but it was back at the next restart of the game and I can't figure out what step (or steps) removed it.

It is however very clear that the G27 is causing the issue. The stutter goes away as soon as I unplug the wheel and comes back as soon as I plug it back in. Before 0.8 there was no problem and no other games displays this behaviour.

Share this post


Link to post
Share on other sites
Be sure you edit "hardware_settings_restrictions.xml" commenting the correct lines of  NOT your  "system/workerMapXCore.xml" where X is your number of cores. 

In example,  i7-5820K  has 12 threads with 6 physical cores. You should set "system/workerMap6Core.xml" WITHOUT comment (and the rest commented).


Share this post


Link to post
Share on other sites
Tried it, didn't solve the issue. Problem is still there, when my steering wheel is plugged in. Without the wheel, everything is OK.

Share this post


Link to post
Share on other sites
OzoreXS said:
Be sure you edit "hardware_settings_restrictions.xml" putting the correct number of physical (not logical) cores in "system/workerMapXCore.xml" where X is your number of cores. Just checking.

In example,  i7-5820K  has 12 threads with 6 physical cores. You should put "system/workerMap6Core.xml"

or ím wrong? o_O
Whoa! You need to comment in the whole line! If you just set the workerMapXCore bit then you don't assign the threads!

If there's no improvement, just revert to the backup and wait for v0.90.

Share this post


Link to post
Share on other sites
hakonp said:
This fix did not work for me. Problem persist whenever the wheel is plugged in.
Is your wheel plugged directly into a usb2 or usb3 port? Are you running Nvidia Experience? Have you tried deleting the two hardware files in your My Games\dirt folder first?

Share this post


Link to post
Share on other sites
hakonp said:
This fix did not work for me. Problem persist whenever the wheel is plugged in.
Is your wheel plugged directly into a usb2 or usb3 port? Are you running Nvidia Experience? Have you tried deleting the two hardware files in your My Games\dirt folder first?
Not me that you quoted but have the same issue. USB2 or 3 makes no difference. Running AMD card so no Nvidia Experience. Deleting xml files does nothing either. 

EDIT: Success! Applying this fix and then deleting/renaming both XML files in Documents\My Games\DiRT Rally\hardwaresettings (I did the wrong ones first time around, duh) seems to have solved the stuttering. Doesn't reset on restart either! Finally I can enjoy Finland with my wheel :)

So for those who applied this fix with no improvement (still stutter when wheel is attached): apply this fix and confirm that the correct xml file is in use then delete/rename "hardware_settings_config.xml" and "hardware_settings_info.xml" in C:\Users\<your_user_name>\Documents\My Games\DiRT Rally\hardwaresettings.

Share this post


Link to post
Share on other sites
OzoreXS said:
Be sure you edit "hardware_settings_restrictions.xml" putting the correct number of physical (not logical) cores in "system/workerMapXCore.xml" where X is your number of cores. Just checking.

In example,  i7-5820K  has 12 threads with 6 physical cores. You should put "system/workerMap6Core.xml"

or ím wrong? o_O
Whoa! You need to comment in the whole line! If you just set the workerMapXCore bit then you don't assign the threads!

If there's no improvement, just revert to the backup and wait for v0.90.
YAY! sorry for that. What a jackass I am lol; I edited my post to evade more confusion.
I didnt understood/notice the "comment" programming tag <!-- --> that involves comments... what a embarrassment xD

Your example worked for me coz its ready for a 4 core CPU like mine, for that I think it worked like it should.

The people who has a 2 core, 6 core...etc need to "uncomment" their line with "system/workerMapXCore.xml" that belongs to their CPU and comment all the other ones!

Now its cristal clear. Again, sorry for this misunderstanding.

Good job, have a six pack beer... after all its friday :)


Share this post


Link to post
Share on other sites
os3n said:
hakonp said:
This fix did not work for me. Problem persist whenever the wheel is plugged in.
Is your wheel plugged directly into a usb2 or usb3 port? Are you running Nvidia Experience? Have you tried deleting the two hardware files in your My Games\dirt folder first?
Not me that you quoted but have the same issue. USB2 or 3 makes no difference. Running AMD card so no Nvidia Experience. Deleting xml files does nothing either. 

EDIT: Success! Applying this fix and then deleting/renaming both XML files in Documents\My Games\DiRT Rally\hardwaresettings (I did the wrong ones first time around, duh) seems to have solved the stuttering. Doesn't reset on restart either! Finally I can enjoy Finland with my wheel :)

So for those who applied this fix with no improvement (still stutter when wheel is attached): apply this fix and confirm that the correct xml file is in use then delete/rename "hardware_settings_config.xml" and "hardware_settings_info.xml" in C:\Users\<your_user_name>\Documents\My Games\DiRT Rally\hardwaresettings.

Thought I'd try this as one last go at fixing it and the problem remains. Bring on 0.9

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(

Share this post


Link to post
Share on other sites
Okay, I've tried every suggestion here but nothing has worked so far.
Have run the game without Experience running. No change
I don't have any USB2 ports, only 3 so that is not an option. This has been suggested by the Codies before which I find rather troubling actually. Even if the USB3 was the problem this is still a software thing with Dirt Rally. No lagging behavior is shown in any other game or System Control Panel.
For me this is a mutation of the classic input lag which I had before the 0.80 update.
I have run the games with a keyboard input profile loaded but the wheel still plugged. I get the SAME BEHAVIOR. That's pretty damn weird, right? The game isn't even using the wheel but still lags just because it is plugged in.
All problems are still resolved by unplugging the wheel.
I would say that I guess that I'll wait for the 0.90 update but there has been no indication that anyone is looking into this specific issue and I went through several updates without anyone addressing the input lag bug.
Look Codies. I thought the whole idea of an open Beta was that the community could help shape the content, not a public bugfixing bash. Here I am, 3, 4 or 5 updates later and I still can't help with that because the game is still unplayable. Will this bug get fixed for the 0.90. Will it be fixed for the release version. Will it get fixed ever or did I buy a game you won't support?

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
This is what I did:
Delete the contents of the restrict file, then copied and pasted the Codies 4Core above into the restrict file, saved. Deleted the hardware files in My Documents\My Games\Dirt Rally, started DR and exited once the updating circle stopped. Restarted game. Try that.

Share this post


Link to post
Share on other sites
hakonp said:
Okay, I've tried every suggestion here but nothing has worked so far.
Have run the game without Experience running. No change
I don't have any USB2 ports, only 3 so that is not an option. This has been suggested by the Codies before which I find rather troubling actually. Even if the USB3 was the problem this is still a software thing with Dirt Rally. No lagging behavior is shown in any other game or System Control Panel.
For me this is a mutation of the classic input lag which I had before the 0.80 update.
I have run the games with a keyboard input profile loaded but the wheel still plugged. I get the SAME BEHAVIOR. That's pretty damn weird, right? The game isn't even using the wheel but still lags just because it is plugged in.
All problems are still resolved by unplugging the wheel.
I would say that I guess that I'll wait for the 0.90 update but there has been no indication that anyone is looking into this specific issue and I went through several updates without anyone addressing the input lag bug.
Look Codies. I thought the whole idea of an open Beta was that the community could help shape the content, not a public bugfixing bash. Here I am, 3, 4 or 5 updates later and I still can't help with that because the game is still unplayable. Will this bug get fixed for the 0.90. Will it be fixed for the release version. Will it get fixed ever or did I buy a game you won't support?
What version of Windows are you using BTW? What are your hardware stats?

Share this post


Link to post
Share on other sites
hakonp said:
Okay, I've tried every suggestion here but nothing has worked so far.
Have run the game without Experience running. No change
I don't have any USB2 ports, only 3 so that is not an option. This has been suggested by the Codies before which I find rather troubling actually. Even if the USB3 was the problem this is still a software thing with Dirt Rally. No lagging behavior is shown in any other game or System Control Panel.
For me this is a mutation of the classic input lag which I had before the 0.80 update.
I have run the games with a keyboard input profile loaded but the wheel still plugged. I get the SAME BEHAVIOR. That's pretty damn weird, right? The game isn't even using the wheel but still lags just because it is plugged in.
All problems are still resolved by unplugging the wheel.
I would say that I guess that I'll wait for the 0.90 update but there has been no indication that anyone is looking into this specific issue and I went through several updates without anyone addressing the input lag bug.
Look Codies. I thought the whole idea of an open Beta was that the community could help shape the content, not a public bugfixing bash. Here I am, 3, 4 or 5 updates later and I still can't help with that because the game is still unplayable. Will this bug get fixed for the 0.90. Will it be fixed for the release version. Will it get fixed ever or did I buy a game you won't support?
What version of Windows are you using BTW? What are your hardware stats?
Windows 10. Encountered the lag at Windows 8.1 first. Switching to 10 actually fixed the fullscreen bug for me but the lag persisted.

Specs are:
i7 5500U 5th Gen @2.4
16GB Ram
GeForce GTX 960M
Logitech DFGT
System and Game running on separate SSDs
All wrapped up in an Alienware 13 laptop bought last spring

Share this post


Link to post
Share on other sites

×