Jump to content

Archived

This topic is now archived and is closed to further replies.

v0.80 Stuttering Bug

Recommended Posts

Adding to previous. Game runs beautifully without the wheel plugged in. High Consistent FPS on medium to high settings. When the wheel is plugged in; unplayable.

Share this post


Link to post
Share on other sites
Definitely sounds like a wheel/usb issue within the game.

The reason I asked is that only in GRID2 my wheel would disconnect while racing in Windows 8.1,...go figure?! I've tried running my stuff on two separate drives before, it worked, but,...it never performed right until I just bought another SSD and RAID' them and doubled the drive size. I do religious back ups and images :)

Ouch a LAPTOP! this will be rough :)
OK,...the wheel.
Unplug wheel and ALL other usb devices (except keyboard and mouse)
1) Disable windows auto driver updates,...temporarily:
Advance System Settings, hardware tab, device installation settings, "no, let me choose", "never install", uncheck "automatically", save changes. (this is just temp).
2) Device Manager, view, select "show hidden devices", open HID tree,...delete and remove drivers for any hidden ghost devices including your wheel and all disconnected usb devices. (light grey in colour)
3) uninstall the Logitech Gaming software for your wheel.
4) with the wheel still disconnected, reinstall the Logitech wheel software,...you should "hear" the software installing the usb drivers, plug the wheel in when it says to,...check to make sure everything works.
5) DO NOT plug in any usb devices except the wheel.
6) launch DR with the modded Codies workmap files for your physical cores, exit once loaded and updated. relaunch DR.
7) FULLY calibrate wheel by selecting its preset, apply, go through the whole routine,...save.
8) Play DR,...any improvement?

9) Return windows auto driver update back to normal.

Share this post


Link to post
Share on other sites
Not a bad idea making it recreate the user files, gonna check they don't contain other crap too though, i thought i saw something else in there regarding settings.

Share this post


Link to post
Share on other sites
Well, that didn't fix it :(  Still the conflict of workermapcore files bewteen those two, as well as detecting the processor as single core with 8 threads.


Share this post


Link to post
Share on other sites
Definitely sounds like a wheel/usb issue within the game.

The reason I asked is that only in GRID2 my wheel would disconnect while racing in Windows 8.1,...go figure?! I've tried running my stuff on two separate drives before, it worked, but,...it never performed right until I just bought another SSD and RAID' them and doubled the drive size. I do religious back ups and images :)

Ouch a LAPTOP! this will be rough :)
OK,...the wheel.
Unplug wheel and ALL other usb devices (except keyboard and mouse)
1) Disable windows auto driver updates,...temporarily:
Advance System Settings, hardware tab, device installation settings, "no, let me choose", "never install", uncheck "automatically", save changes. (this is just temp).
2) Device Manager, view, select "show hidden devices", open HID tree,...delete and remove drivers for any hidden ghost devices including your wheel and all disconnected usb devices. (light grey in colour)
3) uninstall the Logitech Gaming software for your wheel.
4) with the wheel still disconnected, reinstall the Logitech wheel software,...you should "hear" the software installing the usb drivers, plug the wheel in when it says to,...check to make sure everything works.
5) DO NOT plug in any usb devices except the wheel.
6) launch DR with the modded Codies workmap files for your physical cores, exit once loaded and updated. relaunch DR.
7) FULLY calibrate wheel by selecting its preset, apply, go through the whole routine,...save.
8) Play DR,...any improvement?

9) Return windows auto driver update back to normal.
Thanks for the write up.

yeah, a laptop but it's pretty spec'd up and runs the game fine apart from this crazy bug. No overheat or anything near it.

I followed your instruction but no luck and the problem persists. Same sort of stuttering that makes the game simply unplayable.

Am going to re-install the game overnight on another SSD as a last possible fix. After that it would be nice to hear from Codemasters that they are working on fixing this bug that they acknowledged somewhere around 0.50.

Share this post


Link to post
Share on other sites
I'd be looking at system drivers if i were you, although the fact it's only happening with this game, don't blame the game completely.  Laptops are nasty for hardware running correctly.

Share this post


Link to post
Share on other sites
I'd be looking at system drivers if i were you, although the fact it's only happening with this game, don't blame the game completely.  Laptops are nasty for hardware running correctly.
So laptops are somehow worse at running a HID through a USB? Really? How exactly?

Also, I'm not the only one who's experiencing this bug. It's been reported with all kinds of rigs so there's that.

And yeah. If Dirt Rally is the ONLY software having issues with the wheel. Not simply with input lag but actual stuttering, then yes: I do blame the game completely, solely and absolutely.

Share this post


Link to post
Share on other sites
Alright, that's fine you thinking that, and whilst the game can probably do stuff to help this, i've had to piss around with enough 'non existent' laptop chipset problems to know they're obnoxiously easy to have issues with :(  Sorry.

Hopefully if you've got that all up to date, and you're lucky enough to have a non problem system, it'll just be an edge case fix in the game that can hopefully fix it.

Share this post


Link to post
Share on other sites
Well, that didn't fix it :(  Still the conflict of workermapcore files bewteen those two, as well as detecting the processor as single core with 8 threads.


The hardware file is correct in showing:
<cpu name="Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz" speed="3500" physicalCores="1" logicalCores="8" hyperThreading="true" sse3Supported="true" avxSupported="true" rating="2" />
Codies changed their cpu nomenclature over the years. physical cores=1, cores=4, logical cores-8. They probably do this because there are some motherboards that can have two cpus with multiple cores and logic cores.

And the hardware config:
<threadStrategy workerMapFile="system/workerMap4Core.xml"
If you run Afterburner and configure the OSD it shows ALL eight "cores" being used.

Hakonp
Laptops usually don't have very good I/O performance,...kinda depends on the game. Just make sure you're not running anything chewing up cpu or disk activity like anti virus, downloading,...etc and you have the power management set to "High Performance", no fancy power saving or sleep modes with AC plugged in. Run msconfig and do a selective startup and uncheck "load startup items". If it runs better, enable one item at a time until you find the culprit.
Laptop companies love to add fluff.



Share this post


Link to post
Share on other sites
Alright, that's fine you thinking that, and whilst the game can probably do stuff to help this, i've had to piss around with enough 'non existent' laptop chipset problems to know they're obnoxiously easy to have issues with :(  Sorry.

Hopefully if you've got that all up to date, and you're lucky enough to have a non problem system, it'll just be an edge case fix in the game that can hopefully fix it.
I see where you're coming from, but this is a brand new system and bang up to date. And I've had a wheel performance issue that has been reported by so many different people with different rigs. It just can't possibly be an issue with this being a laptop when so many other people on mighty towers are having identical issues.

Hey Superd00ps
Done did that and there's nothing zapping up any resources. First thing I did when I got this computer was to purge it of any bloatwear so there's nothing running in background. Have checked with the performance monitor.
What does however zap major resources is Dirt Rally itself. Even just hanging out in the menu it's taking some serious CPU power running.

Share this post


Link to post
Share on other sites
Malyngo said:
If your CPU is seriously taxed even in the menu, it might be that unplugging the wheel will save the CPU cycles for the FFB, so that is why it is running fine without the wheel, but starts stuttering with the wheel.
Just as a thought.
Just to clarify, when I say serious I'm talking about 30-40% cyclical load directly from the game, not the total load. Which for an in game menu operation is quite wild.

My thought was something like what you're talking about. I get the same stuttering even if the game is set to using the keyboard. The only thing that ever changes is that the wheel is plugged or unplugged, no matter which input profile is loaded.

There must be some wildly inefficient coding that creates some kinda "feedback loop" with the wheel signal. That would explain why the game does this cyclical, rythmical  stuttering. Also it would explain why a modern i7 is having problems with running FFB which is essentially 2 decade old hardware technology. 

Share this post


Link to post
Share on other sites
Fine.
The point remains that the stuttering happens weather I'm using the Wheel profile or not. The wheel only needs to be plugged in. So the game shouldn't even be using that advanced algorithm but it still is

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
Yes, that is the bug that will be fixed in v0.90!!

Share this post


Link to post
Share on other sites
This is what the 4Core file looks like when running on my system,...all 8 threads working. The white was not a good choice,..but.
https://youtu.be/56j3IMcMcHA




Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
Yes, that is the bug that will be fixed in v0.90!!
@MrJamieLowes Right, but this is *after* i modded the files, was i expecting something that wasn't going to happen?

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
Yes, that is the bug that will be fixed in v0.90!!
@MrJamieLowes Right, but this is *after* i modded the files, was i expecting something that wasn't going to happen?
The workaround is to get the game to use the correct threading strategy, not fix the info file output. That will be broken until v0.90.

If your game still stutters after applying the workaround then something else is causing the stuttering. Which I can appreciate is very frustrating.

Share this post


Link to post
Share on other sites
For those who think the stutter is USB related:

Have you tried with bundled Windows USB drivers and 3rd party (chipset) drivers separately?

Common USB3 chips are Intel, Asmedia,... be sure you have intalled MOBO chipset drivers and each comopnents: audio, USB, intel MEI, etc... in trying to evade I/O conflicts.

To do this, simply refer to your MOBO manufacturers download page and download your drivers packages. BIOS updates are highly recommended by the way.

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
Yes, that is the bug that will be fixed in v0.90!!
@MrJamieLowes Right, but this is *after* i modded the files, was i expecting something that wasn't going to happen?
The workaround is to get the game to use the correct threading strategy, not fix the info file output. That will be broken until v0.90.

If your game still stutters after applying the workaround then something else is causing the stuttering. Which I can appreciate is very frustrating.
Yes it is quite frustrating. Are you guys going to be looking into the wheel induced stuttering for this update?

Share this post


Link to post
Share on other sites
OK, oddly, when i check to see if this has taken, the hardware_settings_config.xml file still states 2 core.  But the hardware_settings_info.xml *does* state workermap4core.xml

So that's wrong according to how i understood @MrJamieLowes instructions - what's more 'worrying' is the line above (still in the info file) that where it's stating the processors stats/abilities, because it states this:

<cpu name="Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz" speed="3398" physicalCores="1" logicalCores="8" hyperThreading="true"


I'm particularly noting the physical Vs logical cores here :(
Yes, that is the bug that will be fixed in v0.90!!
@MrJamieLowes Right, but this is *after* i modded the files, was i expecting something that wasn't going to happen?
The workaround is to get the game to use the correct threading strategy, not fix the info file output. That will be broken until v0.90.

If your game still stutters after applying the workaround then something else is causing the stuttering. Which I can appreciate is very frustrating.
Ah, got it, thanks.
No my system is fine, might actually be a little smoother when I did the daily, been busy with bike and haven't played :)

Share this post


Link to post
Share on other sites
I'm a bit late to this fix but helped me with 2 issues. The first one was that i suddenly had a black screen with cursor when i started a stage, beforehand i had to tone down the graphics because of a low framerate. Both where fixed and can play on max settings now( could've never done that before this fix).

Share this post


Link to post
Share on other sites
OK I'm done with this game for the moment, will come back when it's patched again. Today when starting the game the stutter while wheel is connected is back. Very frustrating. Haven't even restarted my computer since last time I played, have no idea how it's back. Tried to delete XML files again to no avail. I really hope you can get to the bottom of this as soon as possible devs :)

Share this post


Link to post
Share on other sites
The fix is now in the v0.90 patch code. So it will definitely be in the next release.

If you've applied the workaround, then make sure the restrictions file updates correctly when you update. If not, make sure you run the "verify integrity of game cache" command in Steam.

If the fix does not work for you, there are a couple of  new command line options that may help. I'll explain when v0.90 is released.

Note, this should fix the problem that was introduced in v0.80. It may or may not fix the stuttering some people were seeing before v0.80.

Share this post


Link to post
Share on other sites
Hello!

Why is stuttering the game is rallycross?
If I turn off,the ground cover work  is good.
The FPS is 57-60.
The videocard is work 64-65% .


Share this post


Link to post
Share on other sites

×