Jump to content Jump to content

[ ALL PLATFORMS ] - Desync and General Quality of Life in Multiplayer Discussion Thread


Recommended Posts

@BarryBLsome people have said this above already. Many of us are running and organising leagues. it would be very helpful if we get an update on how long this might take since pretty much all the leagues in the game have stopped their running for now because of 1.10. There are 100s and sometimes 1000s of people in leagues that need to know how long this interruption is going to take. 

And just a side note: if this is continuing you guys should seriously start considering things like refund. 

Link to post
Share on other sites
  • Administrator

I'll answer as many of the questions as I can.

1. Have the devs been only made aware now? by you? today? If so that is horrible to find out. Since we've been dealing with these issues for a week now. 

A: No. We've been aware for around a week. We have a bug reported internally on the appropriate systems. I've been tasked to get as much feedback on this topic in one place so our developers can see as much of it as possible. 

2. Are all hands on deck working on a fix? 

A: This issue is on our highest priority list. 

3. Will it be this week or can all the leagues already start canceling this weeks races? 

A: No exact ETA at this time. Once I have one, I will provide it.

4. Does Codemasters agree with the majority here that this and future games need to make sure the multiplayer is up to standard to what people might expect from a game in this day and age? (Edited question to be more objective @Bicarda)

A: This is something we are discussing internally at various levels to improve better implementation.

5. Can we have it explained to us what changes this and the next games will bring to improve the multiplayer and indeed some kind of timeline what to expect from F1 multiplayer gaming in the near / middle / far future and from upcoming iterations of the game (especially F1 2022) (Merged Questions)

A: No, and @Bicarda, you know this. Once we have any updates, I will share them as I usually do. There is no guarantees at this time, also I cannot confirm, deny or discuss any potential Codemasters and EA projects.

  • Like 1
  • Thanks 1
  • Agree 5
Link to post
Share on other sites
On 9/17/2021 at 11:41 AM, BarryBL said:

Some more detail on how would be appreciated. Completing a bug report would be the right start.

  •  

Hi Barry,

Detailed description of the issue

I don't know were to start to be honest, there are many issues. In the episode i mentioned in my current league, the problems seems to start once the safety car was deployed:

First issue starts 01:05:20. Race leader is ahead of SC after SC has ghosted. After this several players experience desync issues. This lobby starts with short Q and 50% race.

Third remake lobby 01:38:30 starts with desync issues and everybody just crash.  It is just a mess as you can see from the stream. This lobby starts with custom grid with the order from previously Q

During training sessions I have seen that cars get ghosted with no cross above them over longer periods, several laps.

The car seems to have the player pace ie it is not driven by AI, but I can drive straight trough them because they are ghosted.

Platform?
PC

[ONLINE] The amount of players in your session?

16 players (same country) in the race and 2 spectators
Normally 10-15 in or practice races

[ONLINE] Were you the host?

No,

I  experience the same issue as the host which is the spectator. Both spectators had issues, but they are not seeing the same people being disconnected.

What troubleshooting have you tried? Please list everything you tried.
honestly none.

Any screenshots or video of the issue? Remember to add as unlisted if video via a third party

League race with Desync issues

How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

I don't know, play online with a custom server for a longer period of time. Most of the lobbies as far as I know starts without issue, except that remake we had.

Edited by matses51
Link to post
Share on other sites

Desync is a regular issue right now (1.10), and it happens in almost every league/online race with 15/20+ players.
 

  • A detailed description of the issue.

    In certain scenarios the Leaderboard gets buggy. The following things may cause this desync issue:

    - One or more players have connection problems (really high ping or disconnections)
    - Host disconnects
    - Host Change

    As you can see from the attached video, at the beginning of the lap I'm 11th, then pass 8th and finally come back 11th again. No overtaking.
    2 Players were probably disconnected since the Race Start [X] (Nico. - EmaPoli9 )
    2 or 3 players with bad ping (red) (SyalKing - Re_Guiscardo - Alessandro Plone) who crashed several times. 
    The Host was spectating the game.

  • Report Code
    GXHA-HTDA-MSGG-CTMG
     
  • Platform?
    PC
     
  • [ONLINE] The amount of players in your session?
    20 players (same country)
    2 spectators
     
  • [ONLINE] Were you the host?
    No. The host was spectating.
     
  • What troubleshooting have you tried? Please list everything you tried.
    honestly none.
     
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    1. Join/Create online session
    2. Change the host after a crash/connection issue

    or

    1. Join/Create online session
    2. Play with several players with high ping (red)/disconnections (X) 

    I attach this Thread with another bug here:
  • Thanks 1
Link to post
Share on other sites
  • A detailed description of the issue.

    Two issues that are likely connected (happened in the same session):

    1) Delta speed timer cut short by "Safety Car coming back into pits" message resulting in DT Penalty
    I entered the pits during Safety Car. After exiting the pits I could not see the Delta for several seconds due to the yellow "CATCH SAFETY CAR QUEUE" banner at the top of the screen. The timer then appeared but stopped abruptly with 12.3 seconds remaining when the "SAFETY CAR COMING IN THIS LAP" Message appeared, resulting in me getting a Drive-Through Penalty for "speeding under safety car". Interestingly, as soon as the "Safety Car coming in this lap" message appeared you can see that it switches to Green Flag mode with the message 'resume racing'. This leads me to Bug #2:

    2) Safety Car glitches and stays out on track under Green Flag conditions
    Interestingly, the Safety Car then glitched out and did not come back into the pits but remained on track for the remainder of the race with Green Flags being waved. Overtaking it would result in DSQ.

  • Report Code
    KAAX-DEXD-VCKT-HBHE
     
  • Platform?
    PC
     
  • [ONLINE] The amount of players in your session?
    10+ players
     
  • [ONLINE] Were you the host?
    No. Unsure who was the host.
     
  • What troubleshooting have you tried? Please list everything you tried.
    None as it happened randomly and unexpectedly.
     
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
      I am unsure how to replicate as this has never happened to me before and seems to have happened randomly.
Edited by CptBalloonhands
  • Agree 2
Link to post
Share on other sites

Well based on the fact BarryBL renamed this thread I'm going to assume he's aware... From the posts I can tell hes a decent guy... I just wish we'd get a statement from CD saying they're aware and working on it. 

  • Like 1
Link to post
Share on other sites
2 minutes ago, TrovaMB said:

Well based on the fact BarryBL renamed this thread I'm going to assume he's aware... From the posts I can tell hes a decent guy... I just wish we'd get a statement from CD saying they're aware and working on it. 

Of course youre right. From my own experience (work as a marketing manager) its highly unlikely they do that publicly thru social media or official statements. They know exactly that this discussion is none existent for about 60% of people playing or even more perhabs. So why reveal issues when for the majority there arent any. 

 

Gonna be interesting. If they publicy say something, fair play. but from a marketing standpoint: NEVER.

Link to post
Share on other sites
2 minutes ago, MisterJes said:

I’m not really sure how to provide any further detail than others have presented, but our league is experiencing persistent desync issues so for now we are going to suspend it in our league Races until it is addressed.

Yes we did the same thing. its just one small league but in AOR, WOR, URL ive seen same things happen and they are acvtive globally. everybody is suspending league races. But idk maybe this is what EA wanted. no more private leagues.... Anyway, the patch is why i believe they HAVE TO make a public statement about this. I understand its got nothing to do with Barry here and im happy hes passed this to the social managers. Still, this is not a small issue anymore. this is a massive desaster here. 

Link to post
Share on other sites
4 hours ago, steviejay69 said:

[...]

SirBrokalot was crashed out first lap by "two Alpines driving through him". (26:25) Skatie and Flyskils are both showing as 'red bars' or 'X' connection. Session started before I was streaming but only Grigor had red bars in the lobby (he is in USA, not even East Coast - would not have got in the league in my day, but hey).

[...]

Thanks for pointing that out, Stevie. I can add some more information about my situation I guess:

Detailed description of the issue

I did some time trial before the actual event. I joined the lobby and did the (short) qualifying, everything went fine so far. After qualification I got to the podium pass progress screen and the game crashed before the animation of XP going towards the total XP took place:

https://clips.twitch.tv/NiceFrozenWormANELE-hPqr1obReD6kQFjI (if this helps, during TT the report code was EMPS-ASAB-GVVX-TCMG)

So, I restarted the game and rejoined the lobby. Formation lap was on, so I couldn't take control of my car until the grid was formed (which I believe is the expected behaviour). Interestingly, one of the Alpines that would later drive through me, didn't drive to the start position for me until after I took control of my car again:

image.thumb.png.03658a732e475528ee42246dcc3cdc9c.png

The Alpine car was teleported to the starting position right after I took control. The race start then looked like this:

https://www.twitch.tv/sir_brokealot/clip/TallTardySpiderCharlieBitMe-dsQZRZMbDYmWwF17 (Report code: VXKX-MCKG-EBDJ-DVHE)

I thought everything was fine until the Alpine moves towards me after turn 1, when I noticed that there was an issue. Alright, I saw their X-symbol next to the name and carried on. Then after turn 3 the second car would drive through me which confused me even more. Next stop: wall (which might have been a driving error following my confusion). Just now that I watched the clip a few times, I noticed that the game unghosted every car on the grid EXCEPT mine.

Platform?
PC

[ONLINE] The amount of players in your session?

19 players

[ONLINE] Were you the host?

No

What troubleshooting have you tried? Please list everything you tried.

This is the first time this issue occurred and as several other people have similar experienced I shared my POV.

Any screenshots or video of the issue? Remember to add as unlisted if video via a third party

See screenshot above.

Game crash (Podium Pass progress screen): https://clips.twitch.tv/NiceFrozenWormANELE-hPqr1obReD6kQFjI
Desync issue: https://www.twitch.tv/sir_brokealot/clip/TallTardySpiderCharlieBitMe-dsQZRZMbDYmWwF17
Complete recording: Lobby starts at https://www.twitch.tv/videos/1153510925?t=00h18m45s; report code visible after crash at https://www.twitch.tv/videos/1153510925?t=00h46m07s

How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

I know developers (I am one myself) love this, but there is no reproduction procedure as of now.

  • Thanks 1
Link to post
Share on other sites
48 minutes ago, Badmayhem said:

Excuse me for my ignorance but has the possibility of a virus been explored? 

The PSGL race was before the 1.10 update iirc, however since then the problem seems to have grown among the community.

Just curious.

 

i know i caught the carlos sainz virus the way it takes over i dont know what else to call it so i would say yes most likely we need dedicated severs but codemasters/EA to cheap 

 

Link to post
Share on other sites

We just cancelled our league for this season until multiplayer is fixed because it’s just such an awful, unplayable experience. 
 

For me personally on China, I had one car 3 places behind me trigger an illegal overtake when I went a little off track on T1 with no one around me. Then it happened again a few laps later with another car that was near the back of the grid, whilst overtaking a Ferrari backmarker in turn 2 that decided to cut the corner then go straight into the opposite barriers across the track, collecting me in the process. Then, for more excitement, proceeded to flip out inside the barrier and disappear. 
 

No safety car despite incidents.

Cars (real players) spawning and despawning on the pit straight, had to dodge at one point. Another player didn’t dodge and his race was ended. Also at one point saw the car that was spawning and despawning just take off from the start line after appearing out of no where. 
 

Leaderboard was constantly changing, I was in 3-6th with nobody in front changing positions. 
 

This wasn’t just me, my fellow racers reported seeing the same garbage. 

  • Agree 1
Link to post
Share on other sites

To also note, other than the inconsistent desync happening, some are unable to even start the game.

What happens is that the game gets stuck on the black screen, then exits by itself. On some occasions, the crash reporter will open, but will then break when you want to send a report.

 

Link to post
Share on other sites
  • Administrator
11 hours ago, PPRShogun said:

To also note, other than the inconsistent desync happening, some are unable to even start the game.

What happens is that the game gets stuck on the black screen, then exits by itself. On some occasions, the crash reporter will open, but will then break when you want to send a report.

 

This is a separate issue @PPRShogun. Please post a unique report in 'Report An Issue' section as this topic needs to stay on subject

Link to post
Share on other sites

A detailed description of the issue.

Since the patch many cars per online race are desynced, cars ghost in very unpredictable and unsafe ways, online lobbies do not load, or drivers are stuck in the loading screen. Drivers also report that their games randomly crashes. Drivers have also reported that when they rejoin an online race after their game crashing they cant take control of their car again, with some reporting they can take control of their car, but that the camera becomes bugged.

As admin of the SLR league on PC it's very frustrating putting so much time and effort into building a community around a game that appears to care very little for those who play their game the most, online league racers. Most feel submitting a bug report is too painful a process to engage in and those who have engaged in the process of reporting bugs feel the issue was never resolved. This apathy is probably due to the fact that most people believe that releasing a game with so many bugs, bugs that have remained in the game for years, is an insult as essentially they are being taken for fools.

I do hope this recent debacle has shone a spotlight on the state of online lobbies and that the community get a version of the game that is finally bug free.

Platform?

PC

Game-mode? [ONLINE]

Social play lobby with 50% disctance League races

The amount of players in your session?

20 players each race with 2 commentators as spectators

If you know the players forum username, please tag as many people who were in your session here. [ONLINE]

Too many to include here.

Were you the host?

Has happened when im the host, but also when others host. Not one host has been able to avoid experiencing these issues.

Please post your DXDiag, including the make and model of motherboard.

This is honestly not relevant as we have various hosts complaing of these issues and every driver experiencing these issues on a regular basis.

What troubleshooting have you tried? Please list everything you tried.

Trying different hosts, different sets of drivers, sought advice from Codemasters technical forums.

Any screenshots or video of the issue? Remember to add as unlisted if video via a third party.

We stream our races on youtube and i guarantee you, every single race we have ever streamed will feature at least one bug, but for the recent desync issues you can check the Monaco and Baku races, with the Baku races being the worst affected:

https://www.youtube.com/channel/UChev0Do3mKr3HuZq4CKNSqw

Some crazy desync/bugs in LOR (Finnish League)
https://clips.twitch.tv/FaithfulFrailAntelopeDBstyle-75JSYO59srNcz_px
https://www.twitch.tv/videos/1153373292?filter=highlights&sort=time
https://www.twitch.tv/videos/1153314456?t=0h48m38s

How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.

Host an online race with full grids.

Has the issue become more prevalent since 1.10?

Very much so, but in all honesty, the issues were just compounded with the recent patch. For years those who drive regularly in leagues have reported so many bugs.

  • Agree 2
Link to post
Share on other sites
6 hours ago, Bicarda said:

That´s a bit of a long shot 😛 we've had these issues before. it just happens more often/faster now. 
I still very much think it's conneciton based. 

We had a whole race with nothing going wrong the other day where most people including the host were connected by wire (no wifi) 

Just seems to have gotten way more sensitive with the latest patch.

Maybe they should pack an ethernet cable with the next game if it's unplayable without XD 
 

The top Esport drivers use wifi...thats not hard to believe thats IMPOSSIBLE to believe😁 The fact that PSGLs other tiers aren't seeing these types of problems only raises my curiosity even more.

My thinking is if you dont eliminate the possibility of a virus you just be applying band aids to a leaking wound but Im a simplee man.

Edited by Badmayhem
Hit submit
  • Disagree 1
Link to post
Share on other sites
  • A detailed description of the issue.
    • Desync and a mass of other weird sync issues in online lobbies, including but not limited to:
      • Safety car driving around the track but the drivers do not see condition Safety Car.
      • Several cars/drivers desynced with each other, the host sees completely different things than the drivers or the co-commentator (the co-commentator saw that there was a mass crash on the main straight that actually never happened!).
      • Car getting throwing itself around when exiting pits, game resetting said car directly on the track.
      • Some spectators seeing that DNF'ed cars are still in the race even though they have retired (the host and the main streamer, me, saw that they were DNFed)
      • Result list/tower going completely haywire.
      • The co-commentator of the race no longer saw laps being completed rather he saw that the timing just continued forever even though the cars crossed the line (he saw that the race leader had a laptime of 5 mins and counting).
      • In the end I got kicked out of the race (I was the host as a spectator and the main streamer) and I was no longer able to join. I could join the lobby but I was unable to join back to the race.
      • Basically completely messed up the sync of the entire lobby which caused the race and the commentary to become a mockery.
      • Similar issues happened in many leagues I am involved in over the week but in this report I am specifically reporting the finnish league LOR / Leijonaonlineracing complete breakdown of the lobby midrace.
  • Report Code
    • XMHR-BRAP-BTBS-GVBE
  • Platform?
    • PC / Steam
  • Game-mode?
    • Social play, online lobby (Invite only)
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    • 19 drivers, 2 spectators
  • [ONLINE] Were you the host?
    • I was the host and I was a spectator, I have been hosting, streaming and commentating LOR league lobbies for the past 3 games.
  • [PC ONLY] Please post your DXDiag, including the make and model of motherboard.
    • Don't think this can be relevant at this stage as its happening all over the world.
    • But my PC specs in short are:
      • Core i9-10850K (running stock clocks & power limits)
      • 32gb DDR4 RAM
      • Asus PRIME Z490-A motherboard
      • Geforce RTX 2080 Ti (model: Palit Gaming Pro OC, running stock clocks)
  • What troubleshooting have you tried? Please list everything you tried.
    • Once the lobby started experiencing issues we tried to first reinvite my co-commentator back to the lobby to try at least get us both seeing the same things (he was seeing totally desynced race incidents that actually never happened). He was unable to rejoin back. Soon after I also go kicked out (posting video evidence below) and I was no longer able to load back into the race. I managed to get back to the lobby but I was unable the enter back into the race as a spectator so we had to stop the stream midway 😕
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    • https://www.twitch.tv/videos/1153314456?t=0h40m51s (Drivers T1uhgs & Makender were desynced to each other so T1uhgs didn't see Makender at all on his PoV)
    • https://www.twitch.tv/videos/1153314456?t=0h48m37s (Here's where it starts going downhill rapidly....I as the main streamer and the lobby host see condition Safety Car, but the drivers only physically see the safety car so they actually have to race it!!)
    • https://clips.twitch.tv/FaithfulFrailAntelopeDBstyle-75JSYO59srNcz_px (Here is a driver PoV of the situation, they see the Safety Car driving on the track but they do not have condition Safety Car)
    • https://www.twitch.tv/videos/1153314456?t=0h52m33s (Nappe hits an invisible car on the track, my co-commentator sees it and a mass crash on the main straight but on my screen there is nothing???)
    • https://www.twitch.tv/videos/1153314456?t=0h54m40s (Eventually I also get kicked out of the lobby with the error message "The session you are trying to join or spectate is no longer available". Despite many efforts to rejoin I was no longer able to rejoin the race as as spectator. I was able to join the lobby but not the race again. I tried to restart my game a couple of times to no avail. We had to cancel the rest of the race stream).
    • https://www.twitch.tv/videos/1153373292?filter=highlights&sort=time (Another Driver PoV of the madness that is happening. Vallu drives out of the pits, his car decides to do a somersault onto its roof, he gets reset in the middle of the track. Later he sees Makender flying also on his roof on the main straight (this never happened in reality!) and also can see Nappe's retired car on the main straight but on his PoV its actually not DNFed. You can also spot the safety car racing the cars at the end of this clip)
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    • Literally just host an online lobby with a lot of drivers after the recent 1.10 patch. 
    • I would also like to point out that in this race all of us - including the host - are from Finland .

 

As a P.S. I'd like to point out that many of these desync issues have been in the game for at least the past 4 games. I can remember at least as far back as F1 2018 where we have had desynced cars where the other driver doesn't see the other at all on track and as a consequence take them out unknowingly. The latest 1.10 patch has just raised the issues on a completely new level.

Edited by Icewind85
  • Thanks 1
  • Agree 5
Link to post
Share on other sites

Hi @all:

F1 2021 in its current state is a disgrace.
It's literally unplayable in multiplayer and especially it is NOT suitable as a serious eSport title. But at the same time you try to position it exactly as that.  That's embarrassing.
Are Jarno Opmeer, Simon Weigang etc pp for the F1 esports series even using the same software as we, the common people?

We put in a lot of hours into league gaming, taking it seriously, sacrificing huge amounts of our free time to race with ambitions, but the moment the race starts its all wasted time now...

Just check the Twitch Video @shion13 has posted, or go directly to AirborneMultigaming Twitch channel to see what's going on.

https://clips.twitch.tv/ConsiderateTacitDuckCclamChamp--0WiuFvv-kNN229q

The whole lobby was completely de-synced in our last Airborne League Race. As you can see, completely UNPLAYABLE.
And sadly, this is not the first race with those problems, those problems were present since Race 1 weeks ago! But since the last "Update/Patch" it is even worse.

Codemasters, you need to fix this immediately.
Your reputation is highly at risk right now.

And as @Schwalbe already mentioned before, we all will think twice about buying your product again if this wont change soon. The league drivers are every year the first to buy your new release for the full price. And all we get is.....this? Seriously?

All our League gaming is postponed until there is a fix.

Thanks for your attention.
 

Edited by TopGun888
  • Agree 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...