Jump to content Jump to content

Logitech G923 Xbox Series X DRS does not work when an Xbox controller is connected at the same time

Recommended Posts

  • A detailed description of the issue.
    • When using the Logitech G923 Wheel on Xbox Series X and an Xbox controller is also connected to the console, the DRS button on the wheel does not register in game. I have an Xbox controller connected at the same time in order to use my headset to speak to other people. 
  • Report Code
    • N/A
  • Platform?
    • Xbox Series X
  • Game-mode?
    • All game modes
  • [ONLINE] The amount of players in your session? If you know the players forum username, please tag as many people who were in your session here.
    • N/A
  • [ONLINE] Were you the host?
    • N/A
  • [PC ONLY] Please post your DXDiag, including the make and model of motherboard.
    • N/A
  • What troubleshooting have you tried? Please list everything you tried.
    • Mapped button registers as being pressed when testing the buttons in the "Controls, Vibration and Force Feedback" menu.
    • Have tried using different buttons for DRS but none worked.
    • Have made sure that DRS assist was off and needed to be manually activated.
    • Control scheme is set to "Expert".
  • Any screenshots or video of the issue? Remember to add as unlisted if video via a third party. 
    • N/A
  • How do you make the problem happen? Please add a step-by-step guide here so we can replicate and get reported as quick as possible.
    • Start the game with the wheel connected and an Xbox controller connected
    • Go into a race (e.g. time trial)
    • Make sure DRS assist is off
    • Make sure that a DRS button is mapped on the wheel in the settings
    • Enter a DRS zone on track and try to activate DRS
Link to post
Share on other sites

Thanks for your reply, I have just tried it out again. I changed to using the default G923 setup and it didn't work. I deleted my custom wheel controls setup and it didn't work. However, it did work once I disabled my custom Xbox controller setup and it returned to "Xbox Wireless Controller Preset 1". Thanks for your help, that works for me!

Link to post
Share on other sites

Yes, when I was using the wheel without an Xbox controller connected, everything worked just fine. Not a big issue really as I won't be using the controller with the wheel connected, so having the controller's control scheme as the default one isn't a problem. Thanks again!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...