Jump to content Jump to content

[PC] 1.13 Patch - No Force Feedback on Logitech G923


BradH63
 Share

Recommended Posts

1 minute ago, Scriptures said:

@crushf1 That is odd you have a 360 degree steering rotation.

So maybe you can help me with this, whenever I start f1 2021 for the first time I have to alt tab out and go into GHUB and manually change profiles to my steering wheel profile in order for my steering rotation to be set correctly. Personally I have mine at 340 degrees. But even when GHUB is running before I open f1 2021, I have to go back into ghub and switch profiles to get my steering rotation correct. Anytime I alt tab out, I have to do that before switching back to the game.

If I dont, then my FFB is wrong and my steering rotation is back to 900 degrees. Even if inside GHUB every profile has the same wheel settings. I can select my F1 2021 profile in GHUB, and if I click ANYTHING else with my mouse, other than clicking back into f1 game, my profile will switch back to 900 degrees steering rotation. 

i personally have never encountered a problem like this. it could be that G hub wont run in the background therefore closing the app and resetting your wheel but otherwise im not sure. i am not really the best guy at problem solving in terms of tech issues. do you close g hub or just leave it behind the game?

 

Link to comment
Share on other sites

7 minutes ago, crushf1 said:

i personally have never encountered a problem like this. it could be that G hub wont run in the background therefore closing the app and resetting your wheel but otherwise im not sure. i am not really the best guy at problem solving in terms of tech issues. do you close g hub or just leave it behind the game?

 

I have GHUB open in the background on windows start so it’s always running in the background. May uninstall GHUB and see what happens first

  • Agree 1
Link to comment
Share on other sites

1 hour ago, Scriptures said:

@crushf1 That is odd you have a 360 degree steering rotation.

So maybe you can help me with this, whenever I start f1 2021 for the first time I have to alt tab out and go into GHUB and manually change profiles to my steering wheel profile in order for my steering rotation to be set correctly, or else the wheel is set at 900 degrees. Personally I have mine at 340 degrees. But even when GHUB is running before I open f1 2021, I have to go back into ghub and switch profiles to get my steering rotation correct. Anytime I alt tab out, I have to do that before switching back to the game.

If I dont, then my FFB is wrong and my steering rotation is back to 900 degrees. Even if inside GHUB every profile has the same wheel settings. I can select my F1 2021 profile in GHUB, and if I click ANYTHING else with my mouse, other than clicking back into f1 game, my profile will switch back to 900 degrees steering rotation. 

Scriptures I have a fix for this issue. You need to create a persistent profile for each piece of hardware in GHUB with the F1 game as the application. You do this at the top of each bit of hardware AFTER adding F1 2021 as an application. You then go to the gear up the top right in the main menu of GHUB and apply from the dropdown “set persistent profile” and set F1 2021 as your profile. After doing this you should be able to; once you start up F1, minimise to GHUB, untick “apply settings from game” and simply reapply. I do this once after booting the game and it was working prior to this update, it should stay working until you exit the game. I had tried several ways to set a persistent profile in GHUB that for some reason changed profiles on me as well. I played around a bit and this worked for me and avoids use of your mouse or anything else switching profiles on you. Another thing to note is that steam still thinks F1 is running after you shut it down. What I have to do is exit steam, which then waits for F1 2021 to exit, and then reboot and start fresh. That fixes it for me, my friend has the G29 and he has a different process so it just depends. Hope this works for you! 
 

Edit: if this doesn’t work try going in to where you add F1 as an application and just above the profile will have “settings” go in there and tick “set as persistent profile” on your desired profile 

Edited by PEEN1E
  • Thanks 1
  • Disagree 1
Link to comment
Share on other sites

19 minutes ago, PEEN1E said:

Scriptures I have a fix for this issue. You need to create a persistent profile for each piece of hardware in GHUB with the F1 game as the application. You do this at the top of each bit of hardware AFTER adding F1 2021 as an application. You then go to the gear up the top right in the main menu of GHUB and apply from the dropdown “set persistent profile” and set F1 2021 as your profile. After doing this you should be able to; once you start up F1, minimise to GHUB, untick “apply settings from game” and simply reapply. I do this once after booting the game and it was working prior to this update, it should stay working until you exit the game. I had tried several ways to set a persistent profile in GHUB that for some reason changed profiles on me as well. I played around a bit and this worked for me and avoids use of your mouse or anything else switching profiles on you. Another thing to note is that steam still thinks F1 is running after you shut it down. What I have to do is exit steam, which then waits for F1 2021 to exit, and then reboot and start fresh. That fixes it for me, my friend has the G29 and he has a different process so it just depends. Hope this works for you! 
 

Edit: if this doesn’t work try going in to where you add F1 as an application and just above the profile will have “settings” go in there and tick “set as persistent profile” on your desired profile 

Thank you my friend. I will try this method out! About the f1 game not closing, I know what you mean. I will hit task manager and close f1 .exe thru task manager and that will close f1 without needing to exit steam if you don’t want to. I knew that stupid persistent profile switching, and locking, was messing me up somehow. @PEEN1E

Link to comment
Share on other sites

22 minutes ago, Scriptures said:

Thank you my friend. I will try this method out! About the f1 game not closing, I know what you mean. I will hit task manager and close f1 .exe thru task manager and that will close f1 without needing to exit steam if you don’t want to. I knew that stupid persistent profile switching, and locking, was messing me up somehow. @PEEN1E

Scriptures I forgot to mention, make sure the padlocks are unlocked in each bit of hardware. Locking them before setting the profiles will make it so you cannot untick “apply settings from game.” If you cannot get it to work feel free to add me on steam and I can walk you through it some time. Cheers 

Link to comment
Share on other sites

Adding my hat to this pot, after a frustrating 3 days of thinking it was my fault. 

 

We at least i know 100% of my racing sim equipment and software is up to date, now just waiting on the Codie Hotfix... 

How unlucky we all happen to own the one single wheel that this is an issue for. 

Link to comment
Share on other sites

On 11/16/2021 at 1:58 PM, f1_facu said:

IDGF about you bro, with all respect.

I want an ETA as a customer of the game, we at least deserve to know when they'll fix this critical mess.

And I don't want to play another game 😉 I paid a lot to play this one, given the increase of the price the quality should be better, not worst…

Its not that they wont give us an ETA when they finally find a fix. as it stands right now they cant, so they dont. How much more would you cry and moan if they said 24 hours, and the hotfix didnt come exactly at 24 hours. you would be on here screaming at them. It is a process, let them figure it out.  

Link to comment
Share on other sites

10 hours ago, pali082 said:

If G-HUB is uninstalled and configured with microsoft drivers from steam like G923 for PS4. The FFB works partially

Unfortunately this doesn´t work on my PC. 

I´tried a new clean installation of Win 10, just installed necessary drivers, steam and F1 2021. The wheel worked, but only without Forcefeedback. Afterwards I installed G-Hub, but nothing changed. 😞

Link to comment
Share on other sites

So guys, I Found a fix on the G29/G923 No FFB errors. This works for me,  you can give it a try.

1. Use geek uninstaller, and remove GHUB or Logitech Gaming Software. Restart PC.
2. Download GHUB and Install, then plug ur Wheel.
3. Using RegEdit

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F

Check these values, and change if required -  it works for me:

OEMName: **"Logitech G29 Driving Force Racing Wheel USB" **must be instead of "G29 Driving Force Racing Wheel"
OEMData: **43 00 08 10 19 00 00 00** must be instead of 00 00 00 10 00 00 00 00 (or any other value)

4.Reboot ur PC And try F1 again.

Hope this  helps for you as well. Happy Gaming!

Link to comment
Share on other sites

23 minutes ago, Mickp20 said:

So guys, I Found a fix on the G29/G923 No FFB errors. This works for me,  you can give it a try.

1. Use geek uninstaller, and remove GHUB or Logitech Gaming Software. Restart PC.
2. Download GHUB and Install, then plug ur Wheel.
3. Using RegEdit

Go to HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\VID_046D&PID_C24F

Check these values, and change if required -  it works for me:

OEMName: **"Logitech G29 Driving Force Racing Wheel USB" **must be instead of "G29 Driving Force Racing Wheel"
OEMData: **43 00 08 10 19 00 00 00** must be instead of 00 00 00 10 00 00 00 00 (or any other value)

4.Reboot ur PC And try F1 again.

Hope this  helps for you as well. Happy Gaming!

Not working for me on G923

Link to comment
Share on other sites

8 minutes ago, raceharley said:

Mickp20

en mi computadora portátil con Windows 11 y solo:

HKEY_CURRENT_USER \ System \ CurrentControlSet \ Control \ MediaProperties \ PrivateProperties \ Joystick \ OEM \ VID_046D y PID_C26E

sin C26E

image.png.d80f3b6efab18f838b2a47b789e2e9a0.png

así que no funciona para G923

Grtz

VID_46D & PID_C24F identifies G29. For the G923 it is C26E. The same will not work with G923

Link to comment
Share on other sites

12 minutes ago, f1_facu said:

Hi @BarryBL 

Any news or workaround we could do until the patch is released?

Is this an F1 issue or Logitech issue? Can we have some insight on what's going on?

 

Thanks in advance

Can't help with news or a workaround, however we believe that it is an issue specific to the F1 2021 game, as the Logitech firmware seems to be working fine outside of the game.

  • Confused 1
Link to comment
Share on other sites

  • Administrator
16 minutes ago, f1_facu said:

Hi @BarryBL 

Any news or workaround we could do until the patch is released?

Is this an F1 issue or Logitech issue? Can we have some insight on what's going on?

 

Thanks in advance

Not at this time im afraid. We are working with our first party partners to find a resolution. As previously mentioned, once I have a update, I'll add onto this thread.

Link to comment
Share on other sites

15 minutes ago, coletylernugent said:

Can't help with news or a workaround, however we believe that it is an issue specific to the F1 2021 game, as the Logitech firmware seems to be working fine outside of the game.

196 / 5000
However, with the G-HUB update the G29s added to the problem and @BarryBL mentions that they are "working with our first party partners to find a resolution" and I understand that he refers to Logitech
Edited by pali082
Link to comment
Share on other sites

13 minutes ago, robmypro99 said:

Do we know for sure that loading ACC, then shutting it down and loading F1 2021 fixes this?  

So far there are no work-arounds specifically for the G923 on PC. Scroll up on the 5th page someone says they found a fix, but looks like its only for the G29.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...