Jump to content
  • 0
Sign in to follow this  

G25 slows down whole game (DIRT Rally) at second race

Question

System Spec
Gigabyte H97-HD3
Intel i5-4590
8GB Ram (Corsair)
Radeon R9 280
QWindows 10 N 64Bit

Steps to reproduce
Played a while under Windows 8.1 (N) and upgraded to Windows 10 (N, but media packs installed). In the first race the game plays well with my Logitech g25. While loading the second stage or race the whole game lags uns is terribly slow. After I restart the game, erverything works fine again for one race. This happens every time after a done stage. I had it, that, after a total crash in a race (first race) the second race had no problems, but the third.
Reinstalled the graphic card driver. No change. Plugged my logitech off and played with the Xbox one controller. Everything works fine. Reinstalled the logitech driver for windows 10 64bit. Still the same slow down.
After this I hope i have isolated the error, but i have no clue what to do next.

Your recent history of races 
Independent of racemode.

Which stage were you within the championship\custom event?
Every stage. (Haven't tested every)

What were you doing specifically when the crashed occurred?

How long was your current session?
Sometimes after something round about 5 minutes there are mini-stutter's.

Which graphics preset were you using?
Played under 8.1 with max details, maybe something about 30~40fps. Under windows 10 tested with max, normal and min details. Situtation is the same

I hope i could give a explanation of the error.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Hey,
no, that didn't brought a change. I also checked if the windows 10 recvording tool Game DVR is deactivated. It is not recording, but the program itself still running.
I also changed in the input/lg_g25.xml the priority to 1. I don't have a clue what the sense of it is, but it sounded good :-D.
Another thing i noticed is, that the whole inputbuffer of the system is getting slow. When game is getting slow, and i tab out of the game and write sometghing in annother program, the input is terribly slow.

Share this post


Link to post
Share on other sites
  • 0
Yeah, a lot of lagging. Not killed, but very slow

EDIT:  I tried to record a race and recognized that the stuttering begins after 1~2 minutes ()recorded with the windows 10 DVR and I think because of the recording taking additional resources). I will upload it to youtube if necessary.
Couldn't record or test much, I was just tired of the stuttering so i switched to the Xbox One controller so I'm able to play this beauty of a game :-D
Hope there will be a fix anyday, or i switch back to Windows 8.1

Share this post


Link to post
Share on other sites
  • 0
Maybe this information will be helpful.
Today i switched to the new latest driver from Ati (Crimson 15.300....). It hasn't brought any change.

Good Night

Share this post


Link to post
Share on other sites
  • 0
The new update didn't brought a change. I played a while with my Xbox One Controller and regognized, that the game gets slow after the first race.
The first race was in finnland, and a long one. Everything was smooth. In the second race it started to slow down. I had the feeling that while the loadingscreen for the new race comes, the fps crashes. Not that nerly the same as with my G25, but provable.
I started a benchmark and had 26fps at average. After a restart i had 111!!
EDIT:

<!-- Benchmark Mode Results -->
<!-- ================================================================================= -->
-<benchmark machine="xxx" date="19:04:16 on 12/12/2015" author="Demon.Spawn" instruction_set="SSE2" directx11_feature_level="11.0">

<totals race_time="00:00:46" total_race_time="00:00:46" total_time="00:00:48" races="1"/>

<fps_race av_fps_ms="38.243366" max_fps_ms="35.025032" min_fps_ms="42.498356" av_fps="26.148327" max_fps="28.551010" min_fps="23.530323"/>

<fps_total av_fps_ms="38.243366" max_fps_ms="35.025032" min_fps_ms="42.498356" av_fps="26.148327" max_fps="28.551010" min_fps="23.530323"/>

-<track totalProfiled="1" numInRotation="1" index="1">
<results av_fps_ms="38.243366" max_fps_ms="35.025032" min_fps_ms="42.498356" av_fps="26.148327" max_fps="28.551010" min_fps="23.530323" battery_percentage_used="0" samples="1221"/>

-<settings route="route_2" name="hafren_rally_01">
<car name="555" livery="17"/>
</settings>
</track>
-<hardware_settings_config deviceId="0x679A" version="11">

-<cpu>
<threadStrategy fileStreamProcessor="3" updateProcessor="2" renderProcessor="0" dataSetMonitorProcessor="1" dvdStorageProcessor="3" forceFeedbackProcessor="3" workerMapFile="system/workerMap4Core.xml"/>

</cpu>
-<audio_card>
<dynamic_range value="high"/>
<eq value="flat"/>
<voice_chat enabled="false"/>
<push_to_talk enabled="true"/>
<music level="30.00"/>
<replay_music level="30.00"/>
<effects level="60.00"/>
<engines level="60.00"/>
<speech level="30.00"/>
<voip level="30.00"/>
<surfaces level="50.00"/>
</audio_card>

-<graphics_card firstBoot="true" rating="1">
<directx forcedx10="false"/>
<eyefinity osd="" force=""/>
<stereo enabled="false" convergence="0.5" separation="0.015"/>
-<resolution multisampling="2xmsaa" vsync="0" fullscreen="true" aspect="auto" height="1080" width="1920">
<refreshRate rate="50"/>
</resolution>
<gamma level="0.8"/>
</graphics_card>
<shadows enabled="true" particles="false" maskQuality="0" size="1024"/>
<advanced_fog enabled="false"/>
<particles enabled="true" nearFadeBias="0" lowResScalar="4" dynamicRes="true" wind="true"/>
<weather quality="0"/>
<crowd enabled="true" detail="2"/>
<cloth enabled="true" tessellation="true"/>
<groundcover clutter="true" mode="atoc"/>
<objects stones="false" maxlod="0" lod="1.0"/>
<trees maxlod="0" lod="0.75" meshes_in_all_passes="false" meshes="true"/>
<vehicles lodQuality="1" characterQuality="2"/>
<track lod="0.6"/>
<envmap size="256" mindistance="0.0" scaleminsize="1.5" drawallobjects="false" faces="6"/>
<water detail="1" tessellation="true" drawallobjects="false" scale="8" update="true"/>
<mirrors enabled="true" height="128" width="384" car_culldist="200.0" car_maxlod="2"/>
<skidmarks enabled="true"/>
<dynamic_ambient_occ enabled="true" quality="0"/>
<dynamic_ambient_occ_soft enabled="false"/>
<night_lighting shadowSize="1024" onlyHeadlights="false" shadows="false" lights="0" volumes="false"/>
<textures resolution="1"/>
<shaders quality="1" low_quality="false"/>
<anisotropic max="2" min="1"/>
<physics vehicleDamage="true" environmentalDamage="true"/>
<input device_type="auto"/>
<screenshotMode enabled="false"/>
<aoit enabled="false"/>
<avsm enabled="false"/>
<mouse_support enabled="false"/>
<oculus enabled="true" convergence="1.0" orientationLock="false" verticalOrientation="0.66" overdrive="true" vignette="true" timeWarp="true" chromatic="true" headMovement="true"/>

-<motion_platform>
<dbox enabled="true"/>
<udp enabled="false" delay="1" port="20777" ip="127.0.0.1" extradata="0"/>
<fanatec enabled="true" ledTrueForGearsFalseForSpeed="true" wheelVibrationScale="1.0" pedalVibrationScale="1.0"/>
</motion_platform>
<controls neutralTimeToShift="0.25"/>
</hardware_settings_config>
</benchmark>

Share this post


Link to post
Share on other sites
  • 0
Similar problem here with almost similar setup. AMD Radeon R9 270 

Started with 0.7 but it was more like stuttering that got worse every stage. Fps stayed at 60 

After 0.9 i got massive FPS droppings after a while with stuttering (or similarly looking)

-After one stage played, second stage always has 5-10 FPS drop from and it drops from there every minute you play. It also has lag/stutters and FFB effect lose their strength and especially almost all suspension effects and other finer effects (vibrations)
-if i go to options several times even in stage one it starts to drop and have these effects.
-if left idle on menu for a while (like bathroom break) i get massive fps drop that goes even as low as 5 FPS. And everything is really slow. So drop from 60 fps to 5 fps (50 fps drop)


Have to test typing to other programs like notepad while this happens.

I have already got used to starting game after every stage, but of course it is not the way that it was meant to play by the devs. 

Btw, i found similar sound problem threads from other codemasters titles (F1 2015 & grid 2)

Share this post


Link to post
Share on other sites
  • 0
Hey TuliRally.
Yeah this is my problem, when I play with the Xbox Controller (badly described before).
I will get my G25 from the basement so I can test if there is a change since version 0.9.

Now, as you mentioned the versions. I can only assume that the updates made it worse, or better, haven't played much when I upgraded to Windows 10 because of the stuttering. Especially with my G25.

Very nice to read, I'm not the only one :smile: 


Share this post


Link to post
Share on other sites
  • 0
I searched and found this interesting Thread in the steam forums
http://steamcommunity.com/app/310560/discussions/1/617335934132920537/

I applied the first workaround with the specific workermap[corenumber].xml and had a minimal improvement. After 4 races (again with the xbox controller) I still had 44fps at average in the benchmark, and very minimal stuttering.
Afterwards I tried the 4th workaournd with the deactivation of all razer programs, because I have a razer mouse.
The whole input changed. The was "heavier" but a lot more realistic. (It might be due to settings, but I have not changed them, just closed razer synapse and the running gamescanner from razer) After 3 races I had 44fps, but no mentionable stuttering.
Tomorrow I will definitly test the G25.
I would be so glad to play the game in a way worth this gem.

EDIT: I restarted the game, and started the razer synapse beforehand. The "settings" switched to the "easy" ones. I paused the game, closed razer synapse and it switched back to the "heavy" setup. I'm writing this while the game is paused, I'm at the second race and my keyboard input is slowed, haven't tested this for a while.

Share this post


Link to post
Share on other sites
  • 0
Have you uninstalled and deleted the game folder before reinstalling since the 1.0 patch came out?  

Along with disabling all that stupid peripheral management software, try things like usb hubs, anything else plugged in etc.  However if you're able to get things smoothed out with what you've already done, great!

Share this post


Link to post
Share on other sites
  • 0
I surely wanted to reinstall the game ^^ but my internet is not very fast, So I tried to avoid this step.
There is nothing more plugged in, but my headset. I do use the msi afterburner, relatek audio driver and the logitech profiler, but the last, imho shall not be part of the problem, because it's the program/(driver) for my G25.

Share this post


Link to post
Share on other sites
  • 0
So. Tested my G25 today. Nothing changed. I closed everything from razer. But while the first race, the framerate dropped, and in the second race it behaved somehow like slow motion. Additionally, the input of the steering wheel was lagging too. Sometimes when I was steering, or braking, it took maybe 0.2 seconds (not an exact value) till the game responded.

So I managed to smooth it out (hopefully) with my Xbox One controller, but the real inputdevice is still not playable -.-

Share this post


Link to post
Share on other sites
  • 0
So. Some update.
Some weeks ago I updated my graphic card driver and now the game works like a charme with my xbox controller. No drops or slowing.

With my G25 it still happens. I closed the logitech profiler and the razer synapse. Now the slowing (the game realy feels like in slow motion) starts in in the third race. In the first two races there are "just" some framedrops, but it is somehow playable.
Any thougts, ideas or maybe update news?

Share this post


Link to post
Share on other sites
  • 0
Please run MSI afterburner, set it's monitoring to show the GPU load and the GPU core clock.  Tell me if when you see the stutters, if the core clock is less than the max, which i think is 827mhz for that card?

Share this post


Link to post
Share on other sites
  • 0
Hey, Today I verified the game content and there was one file corrupted that has been replaced (5.3mb don't know whick one).
The behaviour of the failure changed back to the beginning. Everything is fine for 2-3 minutes. Then some framedrops and in the second race the game seems to run on 80% of speed.  Not like yesterday, where some framedrops happened from the beginning, but it got really bad in the third game.  I logged the gpu clock with MSI Afterburner and there was no low (972 at max). Just a steady straight line. Also when I type in another program the written text appears REALLY slow. So everything like before.
I have not tested the xbox controller so far.
Tomorrow I will do a full reinstall.

Share this post


Link to post
Share on other sites
  • 0
I had almost similiar issues, i have a g920 tho.. U should try closing the logitech gaming software in the taskmanager, the wheel will still work, ffb etc... but the problem will be solved. Not sure how it will work out for ur g25, but u can try it!

Share this post


Link to post
Share on other sites
  • 0
I will give it a try.
And it would be somehow....... strange if the driver/configuration program from logitech itself would be the problem.

EDIT: [deleted sarcastic statement]
No. This didn't help :-(
But thanks for the hint anyway :-D

Share this post


Link to post
Share on other sites
  • 0
Ok 2 more things;

What is your windows swap file/page file set to?
Can you set medium textures and try again please?

Share this post


Link to post
Share on other sites
  • 0
My pagefile is set to ~1,7 gig.
I have switched the settings all to low at some point before. There was no change. But I will test it tomorrow with the changed texture settings.

Share this post


Link to post
Share on other sites
  • 0
Are you saying, you have 1, 7GB page file?  or a 1.7GB page file?

Everything is stinking of a USB polling issue right now, but i wanted to check those points as well as there seems to be an issue where peoples gfx cards aren't up to the gfx settings, even though it generally seems to run smoothly.

Share this post


Link to post
Share on other sites
  • 0
I have a 1.7GB page file :smile: german notation...
Something like this would be my wild guess. But what really gets me, is the fact that everythings runs without a problem with my xbox controller, and with my G25 for about 2~3 minutes. When there would be a problem with slow graphic card, there would a slow framerate right from the beginning. So I guess, the graphic card is not the real problem, might be part of it, but not the main reason.

Share this post


Link to post
Share on other sites
  • 0
So.
Full reinstall comlpeted. Nothing is different. Problem is the same.
Interesting thing I noticed, is that it may depend on the length of the track. When I play a sprint it begins after 2~3 minutes. I now played a long track and it took 5~6 minutes. And it got worse myabe in the last part of the track before the finish line. Similar to the shorter tracks. Maybe coincidence, but maybe something for the devs.
The menus run totally smooth when I start Dirt Rally, but after the first race they are also very laggy. But when I drop off a race before, because of total damage and go back tot the menu, or to the next race, it still took some time before the problem occured.
Maybe something nice to know too.

Share this post


Link to post
Share on other sites
  • 0
So I can get that same problem at the moment when on a night stage at full length, occurs around same time.
It's the core clock on my AMD card lowering.

As for the swap file, not everything handles ram only so well, please either set it to windows manages or to 8gb or something to test this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×