Jump to content Jump to content

Grid Legends XSX Trial - crazy engine braking


 Share

Recommended Posts

For some reason on the Xbox version, when you take your foot off the gas there’s some crazy auto slowdown. Video here (sorry for lack of sound)

https://youtu.be/70-1I9DdwxY

 

You can see there are no brake lights and the slow down is very quick. Then I do the same with braking, and it’s quicker (which is right) but without braking feels too fast. 
 

A friend checked on the PS5 version, and it does exactly what I’d expect it to, video here: 

https://youtu.be/cS_8OQ2f3KY
 

I assume it’s something wrong with the Xbox version, I can’t find any settings (there aren’t many to choose from), so not sure what’s going on? Safe to say I won’t be buying the full version as it’s kind of not working properly. 

Link to comment
Share on other sites

Heya,

just to add it here as well, same for the PC Version (Steam)

 

https://answers.ea.com/t5/Bug-Reports/Clutch-not-working-correctly-when-disengaging-throttle/m-p/11321217#M62

https://answers.ea.com/t5/Bug-Reports/Car-slows-down-rapidly-when-off-gas/m-p/11319450#M51

https://www.reddit.com/r/gridgame/comments/t1ikxl/car_braking_without_accelerator/

 

Unfortunately an incredibly disappointing experience so far. Personally I was super stoked for another GRID release.

@CMTGK Maybe you could bring some insight into this?

At least acknowledgement of the bug from your side and a statement that it is being investigated would go a long way here.

This silence already makes me regret my pre-order.

Edited by oblivionfeast
Link to comment
Share on other sites

Just looked to see if anyone else was encountering a ridiculous level of engine breaking and came across this post. I find it so aggressive on some cars I lose the back end!! And with no in game settings for it I hope someone will do something about it. 
playing on pc.

Link to comment
Share on other sites

  • 2 weeks later...

It will be fixed in the next patch. 
 

In the meantime, try this fix:


"I fixed it by resetting the assists page, selected 'restore default settings' and then turned down Traction Control, Stability Control, and ABS options (but not all the way off)."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...