Jump to content Jump to content

[FIXED] Game looses connection to Racenet AND to Steam


F2CMaDMaXX

Recommended Posts

Tuesday:

Daily 2 Wager - OK - might actually get my money back on that one :)
Daily 1 - OK

Restarted game between the two runs.

Went to continue my Monthly, have already completed Germany, this would be the first stage in Wales

Monthly - Fail on stage start!!! :(

Weekly 1 (F2 Kit) - OK
Link to post
Share on other sites
Wednesday:

Well that was disappointing :(

Daily 1 - Nope
Daily 2 - Don't own it, can't earn money to buy it :(

Weekly 2 - Nope
Monthly - Nope (thought i'd try to continue it again, remember already done a complete location)

WRX - Nope.  Usual, everything goes fine until the track finishes loading, shows the background of the track pop up message saying lost connection to the session.  OK to that, drop back to menus and message stating to connect to Steam, make sure you're signed in and your connection is ok.
Link to post
Share on other sites
Thursday:

Daily RX: OK
Daily 2: Nope - failed at stage start
Weekly 2: Still no.
Monthly: Still Nope

Escort Cosworth: what the heck is wrong with that car?  massively over-geared, clips everything and wants to flip the car if you so much as touch off the edge of the road, why does it even have 7 gears?!  No wonder no one users it, even workshop setups don't stop it breaking like glass unless you drive it like a shopping trolley.
Link to post
Share on other sites
Saturday:

Daily 1: OK (80's RWD)
Daily 2: OK (R4)

Weekly 2: Still no. (GrpA)
Monthly: Still no. (2010)

Interesting thing i found tonight, i started a 1 race, 1 event custom champ with the 2007 focus.  Completed, checked the online events section and it still let me in :) (basically meaning that my progress/car upgrades and money earned is saved)

So i kept doing a few, still ok, still let me in after each single race.  So went to the regular champ, cancelled the one that had been sat there for months as i could never save progress in it (it was a 2010 champ) and started a fresh one with the Focus.
Saved and exited each stage, still allowed me into the online events tab.  I went and completed the whole champ, although on clubman level (as i've cancelled so many champs in progress)  All completed ok, car is upgrading nicely and i'm keeping the winnings!!
Anyway, no problems there.

So i wondered if it was the progress of the online events, choosing a car in use there, so i went and tried a 2010 single custom race, no problem, still able to access online events.
Tried an R4 car, same as the daily 2, no problem, tried the 80's RWD, ok, tried a GroupA (same as the weekly i can't start) no problems.
Went and tried the F2 Maxi, same as the weekly i was able to complete, but chose 1 stage, 2 events, completed both, was UNABLE to access Racenet afterwards.

I might try and see what's happening tomorrow after the dailies, i'll try 1/1 for the F2 kit car and see if it was the two races or the car/class.
Link to post
Share on other sites
It's funny, I remembered the first time we talked about this problem yesterday, when I tried to enter a daily with a BMW with the modded livery. I got the "unable to connect to racenet" message. Quit DR, got the old livery back and when I tried to do it again I couldn't, it said "stages completed 0/1".
Strange because that livery seemed to work for most people but not for me.
I know it's a pain and no one wants to hear this, but whenever you got time to spare I suggest you reinstall windows again.
Link to post
Share on other sites
Yeah, we figured it might have been liveries, but i proved that out a while ago.

Windows isn't the problem here either, it's certain conditions whilst in game that cause it to lock itself out.  Restarting the game fixes it, remember.

Anyway, off to try today's and to a little more experimenting with the post just above.
Link to post
Share on other sites
So, Sunday + a video :)

Daily 1: Nope.
Daily 2: Yup

Then i recorded this to show what happens when it fails, i used the 2010 monthly to demonstrate but when anything fails, it does this.  Notice the Daily in the beginning is no longer available, showing 0/1 - This is because i already tried it and it failed in the same way shown in this video.

https://youtu.be/feGKOAIQ3Bc

Link to post
Share on other sites
So here's an interesting find.

I went to continue my testing from last night, testing the F2 again, no problem.  So parked that test.

Tonight i decided to run a 2010 championship with the Fiesta, that's one i had problems with, i ran each stage, saved and exited to menu, tried online events to see if it still let me in.
Wales: No
Finland: Yes
Germany: Yes
Monte: No

With those tests, i thought i'd go back to the car i such success with; '07 Focus, ran a custom event (it doesn't matter if the event is a Daily, a custom champ, reg champ or custom event) Chose Monte and completed it and gained the Steam achievement for it!  Confirmed that i still had a connection by going back to career and checking online events; all ok.

Went to do the same stage, after restarting the game to make sure testing was fair, chose the 2010 Fiesta and ran it again, completed ok, obviously no steam achievement, checked online events, no connection.

Obviously there are various cars that do and do not work at certain events, without going through them all i can't say, but i can pick on the Online event combos and i'm going to guess (will check shortly) that the list can be made from there.  If other cars in the same category are affected that will narrow down cars Vs classes.

BTW this explains why the current monthly stopped working after i completed Germany, and the next set of stages moved to Wales (Fiesta does not work in Wales)
Link to post
Share on other sites
Further testing, i don't know what i'm onto here, but i'm onto something :)

I have checked all events with the 2010 Fiesta.

DO NOT WORK
Wales
Greece
Monte

YES THEY WORK
Finland
Germany
Sweden

Basically the 3 original events do not work with the original 2010 cars.  I checked all other 2010 cars and used Greece as the test bed.
WORK WITH ORIGINAL EVENTS
Polo
i20

DO NOT WORK WITH ORIGINAL EVENTS
Mini Countryman
Fiesta


I'm guessing that we can use the Dailies to read the other problems, here are this weeks events per today, Sunday.

Daily 1: Wales - GrpA Impreza - Does NOT work.
Daily 2: Sweden - R4 Evo - Does work.
Weekly 1: Finland - F2 - Does work.
Weekly 2: Monte - GrpA - Does NOT work. (Interesting that this is a class, doesn't work with any car, all original cars in GrpA)
-------------------------------
Monthly: Germany - 2010 (Chose Fiesta) Does Work
Monthly: Wales - 2010 (Still Fiesta) Does NOT work. (I bet if i reset the event and run the i20 or the Polo it would work)
Link to post
Share on other sites
I see... it looks like it depends sometimes on cars and sometimes on locations.
How about replacing the cars' folders for fresh stock ones? there may be a chance that the archives are corrupted. I'm not sure if you said in other post that you downloaded the game again and installed it from scratch, if that's not the case then it's possible that you have corrupted files (errors while downloading them)
Link to post
Share on other sites
To really dumb this down and really generalise, it's the original cars on the original events, so, both cars and locations matter.

I have already completely removed and reinstalled the game, so i've covered all the bases from that side.  My best bet now seems to be that i have an issue with my profile, i can't think of anything else.

Anyway, i *do* know that there are other people reporting the exact same type of racenet error that i get (i think i'm the only one to have publicly tested all of the scenarios) so it's not specific to my system, at least not the on the surface.

@Hatward and co. are on the case, i obviously have the option to reset my local profile (not sure if that would be enough though) but as i'm fairly confident that this is affecting quite a few of the racenet issue reporters, it would be more beneficial if we find the root cause and maybe fix a lot more people at the same time.
Link to post
Share on other sites
So i expected to be able to predict whether todays events would work or not based upon my findings, the acid test, so to speak.

I predicted;

Daily 1 would work - Because even though it was an original vehicle, it's on one of the 3 new events.
Daily 2 would work  - For exactly the same reason as above.

Weekly 1 would work - Because it's a new vehicle on an old location.
Weekly 2 would work - Because it's an old vehicle set on a new location.

Monthly will not change until i reset the event and start with a new vehicle, otherwise it will fail when it gets to Wales as is it's current state for me.


As for the old/new split, i do not know if this is specific to me, or generally something about added events after release.  
*IF* i am correct, it's original game release events Vs. new events added afterwards.  I got the game just before the Germany update, which i *think* was the first location add-on.  I think that is the same for everyone, but have no proof that it isn't based on the state of the game when your user profile was first created.

*Edit - All predictions correct :)
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...