Jump to content Jump to content

F1 2015 LOW FPS


ismaelN

Recommended Posts

Hello guys,

I'm going to be straight forward. I have really weird fps drops, however, I do not have drops that last less than a second, the fps slowly drops as the time advances. When i start to play, i'm at about 50-60 fps, then after 10 min at 35-40 and atfer 15 min i'm at less than 25. It is really really annoying.
I play F1 2014 and F1 2013 in max without any problems, and i can't even run f1 2015 in low properly (yes i am in low....). This is BS !
I tried to set the priority of the game to "high", to download the latest drivers of my GPU, activate the VSync, but none of those worked.

Help pls !

Link to comment
Share on other sites

ismaelN said:
Hello guys,

I'm going to be straight forward. I have really weird fps drops, however, I do not have drops that last less than a second, the fps slowly drops as the time advances. When i start to play, i'm at about 50-60 fps, then after 10 min at 35-40 and atfer 15 min i'm at less than 25. It is really really annoying.
I play F1 2014 and F1 2013 in max without any problems, and i can't even run f1 2015 in low properly (yes i am in low....). This is BS !
I tried to set the priority of the game to "high", to download the latest drivers of my GPU, activate the VSync, but none of those worked.

Help pls !

What Video card are you using? If you are on Nvidia, "disable" Vsync in game and enable in Nvidia Control Panel.
Link to comment
Share on other sites

hobbsy777 said:
ismaelN said:
Hello guys,

I'm going to be straight forward. I have really weird fps drops, however, I do not have drops that last less than a second, the fps slowly drops as the time advances. When i start to play, i'm at about 50-60 fps, then after 10 min at 35-40 and atfer 15 min i'm at less than 25. It is really really annoying.
I play F1 2014 and F1 2013 in max without any problems, and i can't even run f1 2015 in low properly (yes i am in low....). This is BS !
I tried to set the priority of the game to "high", to download the latest drivers of my GPU, activate the VSync, but none of those worked.

Help pls !

What Video card are you using? If you are on Nvidia, "disable" Vsync in game and enable in Nvidia Control Panel.
Nividia Geforce 960M, i did tired this but it did not worked
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...